Adium

Opened 15 years ago

Closed 14 years ago

Last modified 14 years ago

#999 closed defect (fixed)

Odd username wrap in Eclipse message style

Reported by: ilkka.viinikanoja@fimug.fi Owned by: nobody
Milestone: Adium X 1.0 Component: Adium UI
Version: Severity: minor
Keywords: Eclipse, wrap Cc:
Patch Status:

Description

The username field in the Eclipse message style occasionally wraps the last letter to a new line regardless of the username length. See the screenshots below:

http://ilkkavi.fidisk.fi/adium_bug_1.jpg

http://ilkkavi.fidisk.fi/adium_bug_2.jpg.

Interestingly enough, a 7-letter name did not wrap as incidated in the first screenshot but a 5-letter one did as well as the e-mail address in the second screenshot. Also another user (the one I'm having conversation with in the first screenshot) encountered this in his Adium, so it should not be due to my settings (which aren't tweaked that much).

Change History (10)

comment:1 Changed 14 years ago by Synapse

Is this an Adium issue, or an Eclipse issue? Review?

comment:2 Changed 14 years ago by David Smith

Eclipse issues are at least partially Adium issues, because Eclipse is included in the default distribution. Unclear where the fault lies though.

comment:3 Changed 14 years ago by rgovostes@…

I cannot reproduce this, all of my names display just fine. The language in use seems to be Finnish, maybe it's some problem with the rendering and a different language, although I'd think WebKit would support it properly, and you don't seem to be using any uncommon Unicode characters. I see that you're using Tiger, but which WebKit?

comment:4 Changed 14 years ago by dchoby98

Almost the exact same thing happens with many short messages in the aNon message view -- NOT the user name, but the messages. Only the last letter goes to a new line.

comment:5 Changed 14 years ago by ilkka.viinikanoja@…

My WebKit version is 412.6. It shouldn't be a language issue, since there aren't any e.g. Scandinavian characters in any of the names. I could actually test the issue with my iBook, which uses English as the main language. The Mini on which the error occurred is using Finnish as the main language.

comment:6 Changed 14 years ago by ilkka.viinikanoja@…

The same thing happened also with the iBook, so I guess language settings can be ruled out.

comment:7 Changed 14 years ago by Evan Schoenberg

Milestone: Adium X 0.83Adium X 0.90

Bumping to 0.90 to be reviewed for whether it's a CSS issue or a WebKit issue

comment:8 Changed 14 years ago by Colin Barrett

field_haspatch: 0

Anyone feel like trying to write a reduced case for this? If it is indeed a webkit bug, we should let them know ASAP.

comment:9 Changed 14 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

(In [14288]) Updated Eclipse message style from dzhim. Fixes #627. Fixes #729. Fixes #999.

comment:10 Changed 14 years ago by Evan Schoenberg

(In [14289]) Merged [14288]: Updated Eclipse message style from dzhim. Fixes #627. Fixes #729. Fixes #999.

Note: See TracTickets for help on using tickets.