Adium

Opened 12 years ago

Closed 9 years ago

Last modified 9 years ago

#9908 closed defect (fixed)

Recent Icons formatting not preserved when icon is actually selected

Reported by: lordcookies Owned by:
Milestone: Adium 1.4.2 Component: Adium Core
Version: Severity: normal
Keywords: Recent Icons Cc:
Patch Status:

Description

I recall seeing a similar ticket before, but I can't seem to find it anymore, and this bug has persisted for quite a while. In Leopard, when you set a display icon with a zoom setting or image effects, and then subsequently change the icon, when you reselect the previous icon in the recent icons panel, all those settings are lost.

Interestingly, when you select "Choose Icon..." from the menu afterwards, the preview image of the current icon displays all the formatting correctly.

Attachments (3)

Picture 2.png (74.6 KB) - added by lordcookies 12 years ago.
Image with zooming and modifications
Picture 3.png (5.4 KB) - added by lordcookies 12 years ago.
Icon as it appears when it is reapplied from the Recent Icons panel
Picture 4.png (85.7 KB) - added by lordcookies 12 years ago.
Image as seen when editing after applying the image. It has the modifications preserved, even though the displayed icon did not

Download all attachments as: .zip

Change History (13)

comment:1 Changed 12 years ago by Jordan

Milestone: Needs feedback from users
pending: 01

I think I've seen this before myself... some before and after screenshots might be handy to help illustrate the problem...

Changed 12 years ago by lordcookies

Attachment: Picture 2.png added

Image with zooming and modifications

Changed 12 years ago by lordcookies

Attachment: Picture 3.png added

Icon as it appears when it is reapplied from the Recent Icons panel

Changed 12 years ago by lordcookies

Attachment: Picture 4.png added

Image as seen when editing after applying the image. It has the modifications preserved, even though the displayed icon did not

comment:2 in reply to:  1 Changed 12 years ago by lordcookies

pending: 10

Replying to jas8522:

I think I've seen this before myself... some before and after screenshots might be handy to help illustrate the problem...

Hahaa... I added a few screenshots, but it's a little difficult to sequence. Hopefully it's understandable =)

comment:3 Changed 12 years ago by Jordan

Yeah this looks similar to what I've seen, though I don't think I've been able to reproduce it using 1.3svn in a while. There should be a 1.3 beta available sometime in the next couple weeks... try that out when it becomes available and comment here if the problem is solved.

comment:4 in reply to:  3 Changed 12 years ago by lordcookies

Replying to jas8522:

Yeah this looks similar to what I've seen, though I don't think I've been able to reproduce it using 1.3svn in a while. There should be a 1.3 beta available sometime in the next couple weeks... try that out when it becomes available and comment here if the problem is solved.

Hmmm....having tried the 1.3 beta, it seems as if there's no change to the issue =S

comment:5 Changed 11 years ago by Robert

Milestone: Needs feedback from usersAdium bugs

Any news on this, lordcookies?

comment:6 Changed 9 years ago by Robert

Owner: nobody deleted

comment:7 Changed 9 years ago by Adrian Godoroja <robotive@…>

Resolution: fixed
Status: newclosed

(In 378c29944977) Fix incorrect icon setting through the Contact List Image Picker. It took a few hours to fix this... :( please don't laugh! Fixes #9908

r=wix

comment:8 Changed 9 years ago by Frank

Milestone: Adium bugsAdium 1.4.2

comment:9 Changed 9 years ago by Adrian Godoroja <robotive@…>

(In 692222bbfb41) "User Picture Change" menu now uses an NSMenu making it prettier Fixes #11964 Refs #9908

r=wix

comment:20 Changed 9 years ago by Frank

Ticket #10744 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.