Adium

Opened 12 years ago

Closed 12 years ago

#9892 closed defect (fixed)

Growl uses actual buddy icon

Reported by: hortont424 Owned by: evands
Milestone: Adium 1.3 Component: Adium UI
Version: Severity: regression
Keywords: growl Cc:
Patch Status:

Description

It seems that sometimes (it's somewhat random, but definitely reproducible), the Growl notification window will show the AIM buddy icon, instead of the Address Book icon, even if the two options which force override of Address Book icons in Advanced Preferences are on. The icons work properly inside Adium, but the wrong picture is sent to Growl!

Change History (7)

comment:1 Changed 12 years ago by Jordan

Milestone: Adium X 1.3
priority: normallow
Severity: normalregression

Interesting. I may have had this happen and simply not notice as I don't pay close enough attention and likely wouldn't remember which picture is the correct one. See if you can narrow down which contacts this occurs for and if there's a commonality between them.

If this only recently started happening (which seems likely), it might be because of that fix that was recently done to get Facebook icons to show properly in Growl.

comment:2 in reply to:  1 Changed 12 years ago by Evan Schoenberg

Replying to jas8522:

that fix that was recently done to get Facebook icons to show properly in Growl.

Which fix?

comment:3 Changed 12 years ago by Evan Schoenberg

It is probably a timing issue. The first time a contact is seen, if we want its address book image we initiate a request for it. This request may take multiple run loops to resolve, as it runs asynchronously. The Growl notification might go out immediately and therefore might not yet have the address book image.

comment:4 Changed 12 years ago by Jordan

In which case, this is performing as best as can be expected...

comment:5 Changed 12 years ago by Evan Schoenberg

Nah, imperfect is never the best that can be expected :)

comment:6 Changed 12 years ago by Evan Schoenberg

Owner: changed from nobody to Evan Schoenberg
Status: newassigned

comment:7 Changed 12 years ago by Evan Schoenberg

Resolution: fixed
Status: assignedclosed

(In [23649]) * Do an immediate, local-only address book lookup if queried, falling back on a queued one if no local-only image can be found. This allows us to still retrieve any image being provided by a network source (e.g. an LDAP directory) but also be immediately responsive with local address book images. Fixes #9892

  • Properly update images from within the AIAddressBookUserIconSource if the preference to use address book images is toggled
  • Fixed a case in which a preference not to use address book images at all would be ignored previously in 1.3svn
Note: See TracTickets for help on using tickets.