Adium

Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#9803 closed defect (fixed)

Hide the contact information tooltip if the cursor vanishes

Reported by: derekschrock Owned by: nobody
Milestone: Adium 1.3 Component: Adium UI
Version: Severity: normal
Keywords: Cc:
Patch Status: Accepted

Description

When you double click a user in your buddylist and start typing the mouse icon disappears but the contact information tooltip remains.

Reproduce: 1) Quickly double click a user in your buddylist 2) Start typing in the message window 3) The mouse icon disappears but the contact information tooltip remains.

Note that if you wait for the tooltip to appear then double click the the contact the tooltip will disappear. It's a matter of how fast you're double clicking the contact.

This may be a special case because I have my message window to the right of my buddylist but the contact tooltip always gets in the way.

To help support my case, according to UI guidelines when the pointer leaves the object the help tag (contact tooltop) should vanish. I am assuming "vanish" means "leaves the object."

Attachments (1)

AIMessageEntryTextView.diff (117 bytes) - added by Derek Schrock 12 years ago.
AIMessageEntryTextView.m diff

Download all attachments as: .zip

Change History (8)

comment:1 Changed 12 years ago by Evan Schoenberg

I would be fine with a fix for this issue if someone could produce it. I see no way to determine whether the cursor is currently visible nor to be notified when the cursor hides because typing began.

comment:2 Changed 12 years ago by Derek Schrock

I don't think it's a matter of polling the cursor but rather a matter of 'if you're typing' do [contactListController hideTooltip]?

Changed 12 years ago by Derek Schrock

Attachment: AIMessageEntryTextView.diff added

AIMessageEntryTextView.m diff

comment:3 Changed 12 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

(In [23383]) Based on a patch by derekschrock (but changed from his patch to be implemented in AdiumTyping rather than AIMessageEntryTextView), hide any existing contact list tooltip when we begin typing. If there is no tooltip shown, this is a single objc call and two quick boolean comparisons, so it's wonderfully cheap. Thanks, derekschrock :) Fixes #9803.

comment:4 Changed 12 years ago by Robert

Milestone: Adium X 1.3

comment:5 Changed 12 years ago by Derek Schrock

The only problem I see with using AdiumTyping is that the account has to support "tell the other person I'm typing" and the user has to have that turned on in Privacy.

comment:6 Changed 12 years ago by Evan Schoenberg

(In [23391]) I'm not as happy about clearing the contact list tooltip from AIMessageEntryTextView, but derekschrock points out that doing so in AdiumTyping means the functionality only works if the account supports typing notifications and the user has them enabled. Refs #9803

comment:7 Changed 11 years ago by Robert

Patch Status: Accepted
Note: See TracTickets for help on using tickets.