Adium

Opened 12 years ago

Closed 12 years ago

#9619 closed defect (fixed)

Adium does not choose the correct outgoing account

Reported by: hinckleyscott Owned by: evands
Milestone: Adium 1.3 Component: Adium Core
Version: Severity: regression
Keywords: multiple accounts Cc:
Patch Status:

Description

I realized that some of my work contacts have ended up getting my personal account and visa-versa. I did a test with this with two Yahoo accounts and two contacts. Get info for Contact1 shows only Account1, and Contact2 shows only Account2. Upon double-clinking Account1 or Account2 it shows that the message will be from Account1. Both of them will allow you to pull-down to Account2. The behavior I would expect is that if they are only on one account then double-clicking them would bring up a messagebox FROM that account and there would not be a pulldown to choose any other account (as it does not belong to any other account)

Attachments (1)

screenshot.png (86.3 KB) - added by Tonda 12 years ago.
Requested screenshot showing info window and freshly started chat window

Download all attachments as: .zip

Change History (12)

comment:1 Changed 12 years ago by Jordan

Milestone: Needs feedback from users
pending: 01

According to [22534] this is better differentiated for 1.3 in that the accounts where you don't have the contact on the server-side list appear separated and below the accounts where you do. However you're describing a separate problem, in that it's not selecting the correct account by default (which it should).

Can you attach a screenshot that shows two things:

  1. The get info window with the pane that shows the associated accounts, and
  2. The message window when it is first opened and shows the incorrect account selected by default.

comment:1 Changed 12 years ago by trac-robot

pending: 10
Status: newclosed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

comment:2 Changed 12 years ago by Jordan

Component: YahooAdium Core
Status: closedreopened
Summary: Not respecting which yahoo account a contact is assigned toNot respecting which account a contact is assigned to

comment:3 Changed 12 years ago by Jordan

pending: 01

Changed 12 years ago by Tonda

Attachment: screenshot.png added

Requested screenshot showing info window and freshly started chat window

comment:4 Changed 12 years ago by Tonda

When I was getting the screenshot, I've found, that the problem probably occurs only if this is the first opened chat in Adium. I had several chats opened already, and when I opened this new chat, it was opened in new tab with right account number on the top. I tried to close chats window, but again - when I started chat with this person, right account number was there. So I Quit Adium, started it again and this time when I started chat, the wrong account number was there (and I was finally able to get screenshot).

comment:5 Changed 12 years ago by Tonda

OK, I tried little bit more - starting from situation on screenshot, I opened another 3 chats - all belonging to that account on screenshot, and all were opened exactly like the first one on screenshot - assigned to wrong account number. Then I opened another account which belongs to the account number that all chats are wrongly assigned to (the one ending 498) and sent a message. After that I started another chat with another person belonging to account ending 646, but it was again opened with assigned account 498. Then I started one more chat with person belonging to both account, I changed in chat window account 498 to 646, sent a message and then opened one more chat with another person belonging to 464 - and this time, this chat was opened with proper number on the top. So it seems to me like Adium starts to assign right accounts to chats only after that right account was used (and it works then until Adium is closed).

comment:6 in reply to:  5 Changed 12 years ago by Tonda

Sorry, I messed the last account number (on 4th line from bottom) - it is of course 646, and not 464

comment:7 Changed 12 years ago by Jordan

Milestone: Needs feedback from usersAdium X 1.3
pending: 10
Severity: normalregression
Summary: Not respecting which account a contact is assigned toAdium does not choose the correct outgoing account
Version: 1.2.41.2.5

comment:8 Changed 12 years ago by Jordan

priority: normalhigh

comment:9 Changed 12 years ago by Evan Schoenberg

Owner: changed from nobody to Evan Schoenberg
Status: reopenednew

The existing code for this, it turns out, was awful.

comment:10 Changed 12 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

(In [23333]) -[AdiumPreferredAccounts preferredAccountForSendingContentType:toContact:includeOffline:] now has much better logic for determining the best account to use. Accounts which have the contact on their contact list are preferred over those which don't; previously, this didn't even enter into the selection logic! We also prefer an account which was recently used over one which was not, all else being equal. Fixes #9619 and a number of longstanding complaints.

Note: See TracTickets for help on using tickets.