Adium

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#9565 closed defect (fixed)

Crash when changing name

Reported by: iStig Owned by: evands
Milestone: Adium 1.2.5 Component: Adium Core
Version: Severity: major
Keywords: nickname name crash Cc:
Patch Status:

Description

When I change my nickname in the Adium preferences window, Adium crashes. This only started happening today, and it's bloody annoying, as you can imagine. Right now, it's an incomplete version of my name, because I (obviously) can't change it.

I haven't installed anything in the last few days, and it only started happening now. There are no special characters or anything in the names I'm trying to change it to.

If this is an April Fool's day joke, it's terrible.

Attachments (2)

crashreport.rtf (34.8 KB) - added by iStig 12 years ago.
Crash report
jas8522.crashlog.txt (40.1 KB) - added by Jordan 12 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 12 years ago by Jordan

Milestone: Needs feedback from users
pending: 01

The only joke I see here, is a report of crashing without a crash log or debug log! Tsk tsk... results of TroubleshootingTips? ReportingBugs? All requirements!

Changed 12 years ago by iStig

Attachment: crashreport.rtf added

Crash report

comment:2 Changed 12 years ago by iStig

pending: 10

Sorry about that. Forgot to include it.

comment:3 Changed 12 years ago by Jordan

Milestone: Needs feedback from usersAdium X 1.2.5
Owner: changed from nobody to Evan Schoenberg
priority: normalhighest
Severity: normalblocker

Thanks iStig :) I was just able to reproduce this myself with 1.3svn

Summary:

Process:         Adium [151]
Path:            /Users/jordan/adium/build/Development/Adium.app/Contents/MacOS/Adium
Identifier:      com.adiumX.adiumX
Version:         1.3svn (1.3svn)
Code Type:       X86 (Native)
Parent Process:  launchd [110]

Date/Time:       2008-04-02 09:24:38.308 -0300
OS Version:      Mac OS X 10.5.2 (9C7010)
Report Version:  6

Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x00000000c595602f
Crashed Thread:  0

Thread 0 Crashed:
0   libobjc.A.dylib               	0x900d76e8 objc_msgSend + 24
1   Adium                         	0x003029c4 -[AIModularPane changePreference:] + 42 (AIModularPane.m:115)
2   com.adiumX.adiumX             	0x000adb32 -[ESPersonalPreferences changePreference:] + 841 (ESPersonalPreferences.m:123)
3   com.apple.Foundation          	0x957c202d __NSFireDelayedPerform + 477
4   com.apple.CoreFoundation      	0x95ccdb5e CFRunLoopRunSpecific + 4494
5   com.apple.CoreFoundation      	0x95ccdd18 CFRunLoopRunInMode + 88
6   com.apple.HIToolbox           	0x920ec6a0 RunCurrentEventLoopInMode + 283
7   com.apple.HIToolbox           	0x920ec4b9 ReceiveNextEventCommon + 374
8   com.apple.HIToolbox           	0x920ec32d BlockUntilNextEventMatchingListInMode + 106
9   com.apple.AppKit              	0x94fc57d9 _DPSNextEvent + 657
10  com.apple.AppKit              	0x94fc508e -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 128
11  com.apple.AppKit              	0x94fbe0c5 -[NSApplication run] + 795
12  com.apple.AppKit              	0x94f8b30a NSApplicationMain + 574
13  com.adiumX.adiumX             	0x00002dd7 main + 30 (main.m:4)
14  com.adiumX.adiumX             	0x00002742 _start + 216
15  com.adiumX.adiumX             	0x00002669 start + 41

Changed 12 years ago by Jordan

Attachment: jas8522.crashlog.txt added

comment:4 Changed 12 years ago by Jordan

Summary: Name changes kill AdiumCrash when changing name

For competion, the way I caused it was:

  1. Open preferences
  2. Go to Personal pane
  3. Change name - I added my last initial
  4. Wait about 10 seconds - maybe less - and it crashed.

comment:5 Changed 12 years ago by Evan Schoenberg

jas, your reproduction with 1.3svn isn't the same crash as the original reporter's crash with 1.2.4.... but might be related.

comment:6 Changed 12 years ago by Evan Schoenberg

Hm, actually, might be the same. My bad :)

comment:7 Changed 12 years ago by Evan Schoenberg

I can't reproduce with the steps above on 1.2.4 or 1.3svn. Does this crash for you if performing these steps immediately upon launching Adium, having held shift to prevent accounts from connecting?

comment:8 Changed 12 years ago by Jordan

I can reproduce it without connecting to any accounts. I think I figured out the exact steps to reproduce - I missed a key fact.

  1. Open Adium Personal Preferences such that you can still keep an eye on your name in the toolbar of the contact list window
  2. Change your name in personal prefs, and notice that it takes a second to update in the contact list toolbar. You will not get a crash at this point.
  3. Change your name in personal prefs again, but this time close the preferences window before the name gets updated in the toolbar of the contact list window - crashes every time.

comment:9 Changed 12 years ago by Evan Schoenberg

Now that is what I'm talking about!

comment:10 Changed 12 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

(In [23024]) Trigger changes on the alias and displayname fields immediately when the personal preferences are doing to close; this keeps any changes which were just made and does so before we deallocate. Fixes #9565.

comment:11 Changed 12 years ago by Evan Schoenberg

(In [23025]) Merged [23024]: Trigger changes on the alias and displayname fields immediately when the personal preferences are doing to close; this keeps any changes which were just made and does so before we deallocate. Fixes #9565.

Note: See TracTickets for help on using tickets.