Adium

Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#9557 closed defect (fixed)

St. John's, Newfoundland Time Zone issue

Reported by: sdpope Owned by: nobody
Milestone: Adium 1.4 Component: Adium UI
Version: 1.2.4 Severity: normal
Keywords: Cc:
Patch Status:

Description

With the time zone set to NDT, (St. John's - Canada), all logs display with a timestamp 30 minutes earlier than the actual time. The same thing when seeing logs in the message window. This has been around for a long time now, only filing the report now.

Immediate timestamps are accurate but timestamps from a previous window aren't.

This is probably caused by Newfoundlands time zone being UTC-3:30.

Change History (9)

comment:1 Changed 12 years ago by jas8522

  • Milestone set to Adium X 1.2.x

A screenshot would be handy to describe this better, though I think I know what you mean. If you can - please provide a capture.

comment:2 Changed 12 years ago by evands

Could you attach a log file from a conversation which exhibits this problem?

comment:3 Changed 12 years ago by jas8522

  • Milestone changed from Adium X 1.2.x to Adium X 1.3.x

comment:4 Changed 12 years ago by djmori

comment:5 Changed 11 years ago by jas8522

  • Milestone changed from Adium 1.3.x to Adium bugs

comment:6 Changed 11 years ago by zacw

  • Component changed from Transcripts Viewer to Adium UI
  • Owner set to nobody

Removing 'Transcript Viewer' component.

comment:7 Changed 11 years ago by wixardy

the string being stored: time="2009-05-13T02:40:48-02:-30"

comment:8 Changed 11 years ago by Zachary West <zacw@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In 0fefa6482887) Save the minutes properly for NDT timezone in ISO8601 unparsing. Fixes #9557.

comment:9 Changed 11 years ago by Robby

  • Milestone changed from Adium bugs to Adium 1.4
Note: See TracTickets for help on using tickets.