Adium

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#9523 closed defect (fixed)

message size changes with selection of "show received message colors"

Reported by: mathuaerknedam Owned by: nobody
Milestone: Adium 1.2.5 Component: Adium Core
Version: Severity: normal
Keywords: Cc:
Patch Status:

Description (last modified by Jordan)

After talking with Robby and Ksilebo, it seems like the actual problem in #6119 has gotten muddled. (Perhaps because the "clarification" offered in comment 6 is different from the original description.) Ksilebo's problem is different from mine, so I'll let him open his own ticket for that issue.

Here's how to reproduce the problem I'm seeing:

  1. Go to the messages pane of the Adium preferences
  2. If the "show received message colors" checkbox is selected, deselect it.
  3. Select the Stockholm messagestyle.
  4. Note the size of the message "Away for the sake of being away".
  5. Select "show received message colors".
  6. Note the size of the message "Away for the sake of being away".

The same thing happens when selecting "show received message fonts", but I've broken that into a separate ticket in anticipation of opinions different from my own. :)

Attachments (2)

color-off.png (115.6 KB) - added by mathuaerknedam 12 years ago.
"show received message color" deselected
color-on.png (116.1 KB) - added by mathuaerknedam 12 years ago.
"show received message color" selected

Download all attachments as: .zip

Change History (6)

Changed 12 years ago by mathuaerknedam

Attachment: color-off.png added

"show received message color" deselected

Changed 12 years ago by mathuaerknedam

Attachment: color-on.png added

"show received message color" selected

comment:1 Changed 12 years ago by Jordan

Description: modified (diff)
Milestone: Needs feedback from users
Version: 1.2.4b21.2.4

Here are the cases I have discovered:

  1. Enabling "Show received message fonts", then enabling "Show received message colors" does not cause a size change.
  2. Disabling "Show received message fonts", then enabling "Show received message colors" appears to set the size of the font to what the 'received' font would be, as well as changing the color.

So I think the problem is that the option to show received message colors changes the font size as well as the color, when it should only change the color. mathuaerknedam, can you corroborate this?

comment:2 Changed 12 years ago by Jordan

Milestone: Needs feedback from usersAdium X 1.2.5

Nevermind - your other ticket shows that you believe the same thing.

comment:3 Changed 12 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

(In [23031]) Enabling colors when encoding HTML should not change whether we include size tags; that is determined by whether we want font information. Fixes #9523

comment:4 Changed 12 years ago by Evan Schoenberg

(In [23032]) Merged [23031]: Enabling colors when encoding HTML should not change whether we include size tags; that is determined by whether we want font information. Fixes #9523

Note: See TracTickets for help on using tickets.