Adium

Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#9498 closed defect (fixed)

messagestyles in prefpane menu sorted incorrectly

Reported by: mathuaerknedam Owned by: cbarrett
Milestone: Adium 1.4 Component: Adium Core
Version: 1.2.4b2 Severity: minor
Keywords: Cc:
Patch Status:

Description

Due to different planned versions of a messagestyle, I have them names numerically. In finder, they are sorted correctly, like this:

PushPin
PushPin8
PushPin9
PushPin10

However, in Adium's "Message Style:" dropdown, they are sorted incorrectly, like this:

PushPin
PushPin10
PushPin8
PushPin9

Attachments (1)

sordid.png (53.1 KB) - added by mathuaerknedam 12 years ago.
incorrect sorting

Download all attachments as: .zip

Change History (11)

Changed 12 years ago by mathuaerknedam

incorrect sorting

comment:1 Changed 12 years ago by jas8522

  • Milestone set to Needs dev review

A solution would be to just name them PushPin01, 02, 03...

They are technically sorted lexicographically at the moment since 1 comes before 8...

comment:2 Changed 12 years ago by mathuaerknedam

Sure, I'd expect Adium is following some standard method of sorting. My position is that the finder way is the best way, or at least the way users would expect. Another example I just ran across is that finder sorts "yMous-INDENT, yMous, yMøus, yMousFOCUS" while Adium sorts "yMous, yMous-INDENT, yMousFOCUS, yMøus".

comment:3 Changed 12 years ago by jas8522

  • Milestone changed from Needs dev review to Adium X 1.3.x

Although I personally find that the sorting currently in Adium is better (at least from the examples provided), I also find that consistency with Finder and other applications may be more important.

We'll see what the others think...

comment:4 Changed 12 years ago by mathuaerknedam

Are there any differences in sorting according to language? I'd think that if theis, and if there's a usable mechanism to mirror the OS behavior here, it might be nice to use.

Just a thought, I don't know if it works for or against my position… :)

comment:5 Changed 12 years ago by djmori

comment:6 Changed 11 years ago by jas8522

  • Milestone changed from Adium 1.3.x to Adium 1.3.3
  • priority changed from normal to lowest
  • Severity changed from normal to minor

May as well at least get a decision on this by 1.3.3

comment:7 Changed 11 years ago by cbarrett

IIRC this is pretty easy to add with the NSNumericalSearch option for -[NSString compare:options:]

comment:8 Changed 11 years ago by cbarrett

  • Owner changed from nobody to cbarrett

comment:9 Changed 11 years ago by cbarrett

  • Resolution set to fixed
  • Status changed from new to closed

(In [25082]) Let all menus sort inline numbers in menus natrual language order. Fixes #9498. Ponies for everybody!

comment:10 Changed 11 years ago by cbarrett

  • Milestone changed from Adium 1.3.3 to Adium 1.4

I see no reason to backport this to Adium 1.3. It does not fix a serious bug or regression.

Note: See TracTickets for help on using tickets.