Adium

Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#9472 closed defect (fixed)

Path specified in %_adiumbuild causes incorrect or no result under certain circumstances

Reported by: elpasi Owned by: applmak
Milestone: Adium 1.3 Component: AppleScript
Version: Severity: normal
Keywords: applescript, adiumbuild, path Cc:
Patch Status:

Description

The applescript that allows the %_adiumbuild token to work is not working as it should under certain circumstances.

The script "awk -F\" | \" '{print $1}' /Applications/Adium.app/Contents/Resources/buildnum" always looks in /Applications/Adium.app, which means if the program is in another folder, or has been renamed, this script will not work. In addition, if you have a normal (or beta) version in Applications, and you have another SVN version in another folder, the SVN will claim to be your normal/beta version as it looks in the wrong place (e.g. if you have /Applications/Adium.app and /svn/Adium.app the svn version will look at the other copy (because it's at the filepath specified in the applescript) for it's buildnum file)

Change History (4)

comment:1 Changed 13 years ago by Jordan

Milestone: Adium X 1.2.x

Matt: Can we have the AS accept a parameter that is the bundle directory of the running application?

comment:2 Changed 12 years ago by Bill Garrison

File uploaded to fix #9420 fixes this also. :-) (Thanks for telling me, elpasi!)

comment:3 Changed 12 years ago by Matt Handley

Resolution: fixed
Status: newclosed

(In [23224]) I can verify that swapping out AdiumBuild.scpt with the new version provided by darkxsun fixes #9472. Good work!

comment:4 Changed 12 years ago by Robert

Milestone: Adium X 1.2.xAdium X 1.3
Note: See TracTickets for help on using tickets.