Adium

Opened 15 years ago

Closed 9 years ago

Last modified 9 years ago

#94 closed enhancement (fixed)

Chats are logged in cleartext when encrytion is enabled (OTR)

Reported by: chris snell Owned by:
Milestone: Adium 1.4.2 Component: Logging
Version: 0.80 Severity: normal
Keywords: encryption encrypted logging log otr Cc:
Patch Status:

Description (last modified by Robby)

Problem: Encrypted chats are apparently being logged in cleartext. Seems to me that people who care enough to encrypt chats would probably not want their conversations logged in cleartext. Perhaps there could be an option (enabled by default) to not log encrypted conversations?

Chris Snell

Change History (28)

comment:1 Changed 15 years ago by anonymous

  • Cc chris.snell@… added

comment:2 Changed 15 years ago by anonymous

  • Cc chris.snell@… removed

comment:3 Changed 15 years ago by catfish_man

  • Reporter chris.snell@… deleted

comment:4 Changed 14 years ago by tick

  • Cc chris.snell@… added
  • Milestone set to Adium X 0.90
  • Reporter set to chris snell

Why in the world was the reporter removed without any indication as to why in this ticket?

comment:5 Changed 14 years ago by ChrisSnell

  • Cc chris.snell@… removed

Because I asked for it to be removed. Trac does not obfuscate e-mail addresses and I don't want mine posted w/o obfuscation. Please leave it off.

comment:6 Changed 14 years ago by evands

  • Component changed from OTR to Logging
  • Owner changed from evands to nobody

comment:7 Changed 14 years ago by durin42

Evan suggests that we have checkboxes thus:
[ ] Log messages

[ ] include encrypted messages

comment:8 Changed 14 years ago by durin42

  • Milestone changed from Adium X 0.90 (Old) to Adium X 0.90

comment:9 Changed 14 years ago by catfish_man

  • Milestone Adium X 1.0 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Condensing logging tickets

comment:10 Changed 14 years ago by cbarrett

  • field_haspatch set to 0
  • Resolution duplicate deleted
  • Status changed from closed to reopened

Anyone object to a preference for this? It would be fairly trivial to implement. Where we check to see if the account is a guess account, we simply check to see if the chat should be logged (chats on a guest account always return NO).

Only question I have is where would the checkbox for this go? Under the "Log Mesages" checkbox?

comment:11 Changed 14 years ago by cbarrett

  • Owner changed from nobody to cbarrett
  • Status changed from reopened to new

comment:12 Changed 14 years ago by evands

No objection. See durin42's comment about an old comment I made (above) for my suggestion, which is that.

comment:13 Changed 14 years ago by tick

  • Milestone set to Adium X 1.1

comment:14 Changed 13 years ago by tick

  • Milestone changed from Adium X 1.1 to Adium X 1.2

comment:15 Changed 13 years ago by tick

  • Severity changed from normal to blocker

This is a blocker on 1.2

comment:16 Changed 13 years ago by cbarrett

Any objections to doing this? Figured I'd give this a stab, as the "owner" of the logging code.

comment:17 Changed 13 years ago by tick

  • Milestone changed from Adium X 1.2 to Sometime after 1.0
  • Severity changed from blocker to normal

Actually it's not a blocker on 1.2

comment:18 Changed 12 years ago by dmz

(I'd originally added this note to #7361, which has been closed as a duplicate of this; it applies here too, I believe)

Just a comment on this: I think it'd be a great option to have, but I submit that it should not be the default behavior... and also, that if Adium does disable logging for a user at any time during a conversation, it should put notes in the message window (much like the note about encryption being turned on or off) that explicitly says when logging is being disabled/re-enabled.

comment:19 Changed 12 years ago by djmori

comment:20 Changed 11 years ago by Robby

  • Patch Status set to None
  • pending set to 0
  • Type changed from defect to enhancement

comment:21 Changed 10 years ago by Robby

Ticket #11679 has been marked as a duplicate of this ticket.

comment:22 Changed 10 years ago by Robby

Ticket #12288 has been marked as a duplicate of this ticket.

comment:23 Changed 10 years ago by Robby

  • Keywords otr added; removed

comment:24 Changed 10 years ago by Robby

  • Description modified (diff)

comment:25 Changed 10 years ago by Robby

  • Description modified (diff)
  • Summary changed from Chats are logged in cleartext when encrytion is enabled to Chats are logged in cleartext when encrytion is enabled (OTR)

comment:26 Changed 10 years ago by cbarrett

  • Owner cbarrett deleted

comment:27 Changed 9 years ago by Zachary West <zacw@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In 030035dabb86) Add "Log only certain accounts", which lets you log only certain accounts, and add "Log secure chats" which (enabled by default) logs secure chats.

This was prompted by (for the first time evar!) using a Mac at work all day, and wanting my work chats logged but not my personal ones. I know, it breaks account/service/whatever agnosticism, but hey, whatevs. Encrypted chats not being logged has been a popular request for a while, and I was in here anyway.

Defaults to not "log only certain accounts", and accounts default to enabled for logging.

Take the opportunity to backport [da70be37dabb] as well, which renamed "Save open chats when quitting" to "Reopen chats from last time on startup".

Refs #8, fixes #94 (woohoo old tickets).

comment:28 Changed 9 years ago by Robby

  • Milestone changed from Good idea for "later" to Adium 1.4.2
Note: See TracTickets for help on using tickets.