Adium

Opened 13 years ago

Closed 12 years ago

#9303 closed defect (fixed)

Add to Address Book messes up the contact list nicknames

Reported by: Nuak Owned by: evands
Milestone: Adium 1.3 Component: Adium Core
Version: Severity: normal
Keywords: address book contact list add nickname Cc:
Patch Status:

Description

This bug happens when you are using custom nicknames for your contacts, but those are taken from the Address Book. Whenever you add a contact to the address book, every nickname in the contact list is changed for the email address. The custom nicknames defined inside Adium remain. The only solution to recover the nicknames is to restart Adium.

Change History (13)

comment:1 Changed 13 years ago by Evan Schoenberg

Is this when you add an item to the address book from within the Address Book application?

comment:2 Changed 13 years ago by Ricky Buchanan

Happens for me whenever the Address Book DB is edited from within the Address Book application while Adium is running, adding or removing or just changing a contact AFAICT. The address book integration is lost and the basic nicknames from the services are displayed instead. This problem doesn't happen immediately the Address Book editing is done but some various number of minutes later - next time Adium looks at the Address Book DB I assume.

Incidentally, it can also be fixed by opening prefs->advanced->address book and <b>unselecting</b> "Import my contacts' names from the Address Book" and then selecting it again.

comment:3 Changed 13 years ago by Ricky Buchanan

Also, this is not a new 1.2.3 bug. It's been present at least for several months - I didn't use Adium before that.

comment:4 Changed 13 years ago by Jordan

Milestone: Adium X 1.2.5

Another with the same problem: #9401

comment:5 Changed 12 years ago by Evan Schoenberg

I still can't reproduce this. Can anybody else?

comment:6 Changed 12 years ago by noleli

Yep, just happened to me. 1.2.4.

comment:7 in reply to:  6 Changed 12 years ago by Evan Schoenberg

Replying to noleli:

Yep, just happened to me. 1.2.4.

What had you changed in the AB? What name format do you use? Are you using nicknames, as well? Did all contacts on your list revert or just some of them?

comment:8 Changed 12 years ago by Elan Feingold

This happens to me too in 1.2.4. Very frustrating.

comment:9 Changed 12 years ago by Evan Schoenberg

Milestone: Adium X 1.2.5Adium X 1.2.x

comment:10 Changed 12 years ago by Jordan

Milestone: Adium X 1.2.xAdium X 1.3.x

comment:11 Changed 12 years ago by Josh Buhler

Happening in 1.2.5 as well. To reproduce on my machine, I right-click on a name in the contact list, and choose "Add to Address Book". I then choose to edit the entry in Address Book. It's usually at this point where the contact list no longer uses the names from Address Book, and reverts to the contact's IM account names.

It's usually at least half of the names that get messed up, but sometimes it's all of them.

In Adium's Preferences pane, under "Advanced" I have all but the following Address Book settings checked:

  • Use nickname if available
  • Use middle name if available

comment:12 Changed 12 years ago by Evan Schoenberg

Milestone: Adium X 1.3.xAdium X 1.3
Owner: changed from nobody to Evan Schoenberg
Status: newassigned

comment:13 Changed 12 years ago by Evan Schoenberg

Resolution: fixed
Status: assignedclosed

(In [23345]) When an object's address book preferences change, don't let its preferences become those of the global plugin. This fixes loss of AB data after changing a per-contact address book setting such as associating a contact with an address book card. Fixes #9303. Also, don't set the phonetic name if it's the same as the display name when adding to the address book.

Note: See TracTickets for help on using tickets.