Adium

Opened 15 years ago

Closed 15 years ago

Last modified 11 years ago

#93 closed defect (fixed)

Adium contact list is off screen in different multiple monitor setups

Reported by: drakino Owned by: anybody
Milestone: Adium X 1.0 Component: Adium Core
Version: Severity: normal
Keywords: multiple monitors contact list position Cc:
Patch Status:

Description

This occurs with 0.81 and OS X Tiger 10.4

Situation 1: Powerbook is positioned left of an LCD. Adium is kept on the powerbook screen, OS X is set to treat the LCD on the left as the main monitor with the menu bar. Powerbook is running native resolution of 1280x854, LCD is running at 1280x1024. Powerbook alignment is put against the bottom edges of the other screen to match physical arrangement.

Situation 2: Powerbook is on the right of a CRT. Adium is kept on the powerbook screen, OS X is set to use the CRT as the main monitor. Powerbook is again native 1280x854, CRT is run at 1280x960. Alignment is done against the top edges due to an iCurve stand being used to elevate the powerbook.

If Adium is closed and relaunched when the situation has not changed, the window positions are held properly. If however, adium is closed, then the situation changes from 1 to 2 above, Adium will launch fine, but typicially have the contact list off screen. No portion is visible at all. Using "Bring adium to the front" does not reveal it. Choosing Window-Minimise causes the OS X dock to crash and relaunch.

Typicially closing and reopening Adium fixes the problem, with the contact list appearing on the main monitor in a way that is so small, the hide/show toolbar control is on top of the stoplight controls. Resizing the window is possible though.

Change History (8)

comment:1 Changed 15 years ago by Ken Ferry

I am unable to reproduce this bug with my laptop and external monitor. It might be helpful if the original poster would specify window style and where he puts his contact list (i.e. on the right edge of screen x).

Also, there's a typo or something. In situation 1, "Powerbook is positioned left of an LCD", but "OS X is set to treat the LCD on the left as the main monitor". Is the powerbook on the left or on the right? Mac-arena suggests that the powerbook is physically on the left and logically on the right, but I'm thinkin' typo is more likely. :-)

comment:2 Changed 15 years ago by drakino

Sorry, thats what I get when I am distracted when writing.

Situation 1 has the powerbook physicially on the left and the LCD monitor on the right. The LCD on the right has the menubar, and the Powerbook has the dock pinned on the left. The adium contact list is kept open on the right edge of the powerbook monitor. This places it near the middle of my workspace due to my monitor arrangement.

Situation 2 seems accurate. The Adium contact list is kept on the right edge of the powerbook monitor again, but this time is on the far right of my workspace due to the monitor arrangement.

Keep in mind to reproduce this, you may need two different monitors that provide different DCC info to OS X, as it seems to save monitor arrangements based on that. It may also just simply be doing it via DVI and VGA, as the LCD in situation 1 is DVI, while the CRT uses VGA.

Adium window style is "Regular Window" as shipped with 0.81.

Situation 1, in badly rendered ASCII art:

            ____________
____________|  Main    |
|Powerbook *|  LCD     |
|          *|          |
------------------------

The * is where the Adium contact list is kept.

Situation 2:

 ______________________
|  Main   | Powerbook *|
|  CRT    |           *|
|         |-------------
-----------

comment:3 Changed 15 years ago by morganc

I have run into almost the same situation. It seems you only need to change the monitor setup, not have two separate external monitors. I use a second monitor at work which holds my contact list. When I come home (no second monitor) it is still on that portion of the screen. I can see it when using expose, but I can't access it to move it.

Sometimes when I would go back to work, it would still be there. Other times the location seems to have been corrupted and I could not reach it anywhere. Then I would have to delete the "Window Locations.plist" file.

It seems like the logical solution to this would be to validate the stored location as viewable, and if not, reset it. Unless of course that's what's already being done and its not working. :)

comment:4 Changed 15 years ago by Chris Forsythe

Milestone: Adium X 0.82Adium X 0.90

Moving this to .90.

comment:5 Changed 15 years ago by Augie Fackler

Resolution: fixed
Status: newclosed

I'm sure this was fixed, as games make the contact list move around all funkylike. Try it in .83, and if that doesn't work, reopen.

comment:6 Changed 15 years ago by David Smith

Milestone: Adium X 0.90 (Old)Adium X 0.90

comment:7 Changed 14 years ago by drakino

It looks mostly fixed, though it does take adium a bit of time (10-20 seconds) to snap onto a viewable space. Not sure if that is intended or not.

I fixed the problem mostly already anyhow when I rearranged my home office to match the work office layout.

comment:8 Changed 11 years ago by Zachary West

Component: Core AdiumAdium Core
Note: See TracTickets for help on using tickets.