Adium

Opened 13 years ago

Closed 12 years ago

#9193 closed defect (fixed)

Can't enable automatic encryption

Reported by: mirus Owned by: evands
Milestone: Adium 1.3 Component: Adium Core
Version: Severity: normal
Keywords: Cc:
Patch Status:

Description

I'm using italian localized 1.2.1 version of Adium and I can't enable automatic encryption. Every change I make disappears after relaunch.

Change History (10)

comment:1 Changed 13 years ago by Jordan

Milestone: Adium X 1.2.3
Owner: changed from nobody to Evan Schoenberg

This sounds like it's similar to #9253 ...

comment:2 Changed 13 years ago by Evan Schoenberg

Milestone: Adium X 1.2.3Adium X 1.2.4

Where are you changing it?

comment:3 Changed 13 years ago by Evan Schoenberg

(Unrelated to #9253, btw)

comment:4 Changed 13 years ago by Jordan

Milestone: Adium X 1.2.4Needs feedback from users
pending: 01

I can't reproduce this, but then I'm just using the plain ol' English version.

mirus: on top of Evan's question, try out TroubleshootingTips and don't forget to update to 1.2.3.

comment:5 in reply to:  4 Changed 13 years ago by Francesco Albano

pending: 10

I've updated to 1.2.3 and also to 1.2.4b1, same issue. evands: preference panel -> account -> account settings -> privacy -> automatic encryption. You can see a screenshot http://img409.imageshack.us/img409/7536/adiumbuglf5.jpg. After every relaunch of Adium the setting changes from automatic encryption to "su richiesta" (in english: on asking or something similar). It happens with every kind of account: Jabber, MSN, ICQ, Yahoo, ecc.

comment:6 Changed 12 years ago by Sean Carr

This also happens to me with 1.2.4 (English version) and Jabber, GTalk, and AIM. It seems like this problem has been reported under various descriptions on a bunch of different tickets. Has the root of the problem been discovered?

comment:7 Changed 12 years ago by Francesco Albano

Same issue with 1.2.5b2. With some previous version of Audium (maybe 1.1.x) auto-encryption worked well, I've used it for a while. Please fix this :)

comment:8 Changed 12 years ago by Evan Schoenberg

(In [23200]) Added debug logging for getting/setting per-account encryption preference. Refs #9193

comment:9 Changed 12 years ago by SeanMcTex

I noticed this today with 1.2.5. I set the preference for both AIM and GTalk to "Encrypt Chats Automatically", only to have them revert to "Encrypt Chats as Requested" after relaunch.

comment:10 Changed 12 years ago by Evan Schoenberg

Milestone: Needs feedback from usersAdium X 1.3
Resolution: fixed
Status: newclosed

Okay, I can reproduce this reliably in 1.2.5. The problem isn't present in 1.3svn. I believe the issue was related to one of the deep-seated preference problems which were resolved with the preferences rewrite in 1.3svn.

Note: See TracTickets for help on using tickets.