Adium

Opened 12 years ago

Closed 8 years ago

Last modified 8 years ago

#9126 closed defect (fixed)

Cannot delete Gadu-Gadu contact from list

Reported by: es_uomikim Owned by: nobody
Milestone: Adium 1.4.5 Component: Service/Gadu-Gadu
Version: 1.2.1 Severity: normal
Keywords: delete contact list Cc:
Patch Status: Accepted

Description

It is impossible to delete a contact or a contact group of Gadu-Gadu from contact list because it reverts on next login.

/1 I delete a contact

/2 it disappears

/3 I turn off Adium

/4 I turn it back on and...

/5 I see it on my contact list...

Because of that I have lots of old contacts on my list that I cannot remove.

I started even thinking about installing some other Gadu-Gadu client just only to delete those contacts and export contact list on server and to import it again with Adium--it's silly...

It is only possible to add new contacts on list, it is not possible to remove them. It's a serious malfunction.

PS: The same problems had some other people on few internet forums.

Attachments (2)

adium-libgadu-gg-immutable-contacts.patch (1.0 KB) - added by tomkiewicz 8 years ago.
First version, not so many changes.
adium-libgadu-gg-immutable-contacts-2.patch (1.7 KB) - added by tomkiewicz 8 years ago.
Better version, axe everything possible!

Download all attachments as: .zip

Change History (30)

comment:1 follow-up: Changed 12 years ago by edr1084

  • Milestone set to Needs feedback from users
  • pending changed from 0 to 1

It sounds like we aren't sending the change to the server and it's being redownloaded on connect. Do you have access to a PC to see if the same thing happens when running Pidgin? That way we can figure out if it's our problem or if the problem is actually in libpurple.

comment:2 Changed 12 years ago by es_uomikim

  • pending changed from 1 to 0

No, sorry, I don't have a PC...

comment:3 Changed 12 years ago by es_uomikim

Will it be repaired ever..?

comment:4 in reply to: ↑ 1 Changed 12 years ago by ars

I have the same issue... i cannot remove gadu-gadu contacts from adium (after adium restart they're back at the list). I've checked it on Pidgim 2.4.1 (and cross-checked it on native client Gadu-Gadu 7.7.0) and everything works just fine...

Besides I have one more problem, that i've seen being mentioned in other ticket.
With Adium not running I deleted all the gadu-gadu contact's entries from the blist.xml file, then I've cleared the list on the server using native client. After this Adium didn't load the contacts (correct). Then I added/edited the contacts in the native client and reuploaded them to the server. After this Adium imports only 1 contact out of over 150 (not quite correct :/ - I'll just mention that Pidgim works fine with the import of the new list).

And one more thing... While I was using Adium, I've added some new Gadu-Gadu contacts. I added the Aliases to them, but after importing the list from the server to the native client all the new added contacts (by adium) didn't have the alias i've set in adium. Insted of them there was duplicated gadu-gadu id number o_O.
(ggid: 123456; alias: 123456)

I hope you can do something about these problems...

comment:5 Changed 12 years ago by Robby

  • Milestone changed from Needs feedback from users to Adium X 1.3.2

As this seems a valid report I'll milestone it for 1.3.2.
ars says (Thanks, ars, by the way! :)) Pidgin works and I haven't found a corresponding ticket in Pidgin's Trac so there is no (obvious) evidence it's a Libpurple problem.

comment:6 Changed 12 years ago by djmori

comment:7 Changed 11 years ago by MarkS

I am using Adium 1.3 b11 and I can confirm having the same issue(as a feedback from others). I had a contact with three accounts tied together: Jabber, Gadu Gadu, and ICQ. I expanded the contact trying to delete the ICQ and Gadu Gadu contact. I couldn't remove the Gadu Gadu contact. I stayed on my list. The issue is that the Gadu Gadu contact was not used and I believe it was recycled.

comment:8 Changed 11 years ago by jas8522

  • Milestone changed from Adium 1.3.2 to Adium 1.3.3

comment:9 Changed 11 years ago by evands

  • Milestone changed from Adium 1.3.3 to Needs feedback from users

Please show the debug logging of Adium 1.3.3b1 or later (see CurrentAdiumDebug for instructions) of attempting to delete a Gadu-Gadu contact and it not working.

comment:10 Changed 11 years ago by es_uomikim

Here you are, sensitive data is replaced by "XXX":

19:58:56: -[AdiumPreferredAccounts preferredAccountForSendingContentType:toContact:]: Could not find an online choice to talk to <AIListContact:a696730 Gadu-Gadu.XXX>; will include offline accounts
19:58:56: <ESPurpleGaduGaduAccount:903ab90 2>:XXX: privacyOptions are 5
19:59:03: -[AIListCell _drawHighlightWithFrame:inView:]: 
19:59:06: (Libpurple: gg) ** gg_remove_notify_ex(0xa15e5a0, 0, 3);
19:59:06: (Libpurple: gg) ** gg_send_packet(0xa15e5a0, 0x0e, ...)
19:59:06: -[AIListCell _drawHighlightWithFrame:inView:]: 
19:59:06: Uploading gadu-gadu list...
19:59:06: (Libpurple: gg) ** gg_send_packet(0xa15e5a0, 0x16, ...)
19:59:06: (Libpurple: gg) ** gg_send_packet(0xa15e5a0, 0x16, ...)
19:59:06: (Libpurple: gg) ** gg_send_packet(0xa15e5a0, 0x16, ...)
19:59:06: (Libpurple: gg) ** gg_send_packet(0xa15e5a0, 0x16, ...)
19:59:06: -[AIListCell _drawHighlightWithFrame:inView:]: 
19:59:08: (Libpurple: gg) ** gg_watch_fd(0xa15e5a0);
19:59:08: (Libpurple: gg) // gg_watch_fd() GG_STATE_CONNECTED
19:59:08: (Libpurple: gg) ** gg_watch_fd_connected(0xa15e5a0, 0x136e240);
19:59:08: (Libpurple: gg) ** gg_recv_packet(0xa15e5a0);
19:59:08: (Libpurple: gg) // gg_recv_packet() header recv(15,0xbfffde70,8) = 8
19:59:08: (Libpurple: gg) // gg_recv_packet() body recv(15,0xa8bb618,1) = 1
19:59:08: (Libpurple: gg) // gg_watch_fd_connected() received userlist reply
19:59:08: (Libpurple: gg) ** gg_event_free(0x136e240);
19:59:09: (Libpurple: gg) ** gg_watch_fd(0xa15e5a0);
19:59:09: (Libpurple: gg) // gg_watch_fd() GG_STATE_CONNECTED
19:59:09: (Libpurple: gg) ** gg_watch_fd_connected(0xa15e5a0, 0x134d8e0);
19:59:09: (Libpurple: gg) ** gg_recv_packet(0xa15e5a0);
19:59:09: (Libpurple: gg) // gg_recv_packet() header recv(15,0xbfffde70,8) = 8
19:59:09: (Libpurple: gg) // gg_recv_packet() body recv(15,0xa89c298,1) = 1
19:59:09: (Libpurple: gg) // gg_watch_fd_connected() received userlist reply
19:59:09: (Libpurple: gg) ** gg_event_free(0x134d8e0);
19:59:09: (Libpurple: gg) ** gg_watch_fd(0xa15e5a0);
19:59:09: (Libpurple: gg) // gg_watch_fd() GG_STATE_CONNECTED
19:59:09: (Libpurple: gg) ** gg_watch_fd_connected(0xa15e5a0, 0xa4b7770);
19:59:09: (Libpurple: gg) ** gg_recv_packet(0xa15e5a0);
19:59:09: (Libpurple: gg) // gg_recv_packet() header recv(15,0xbfffde70,8) = 8
19:59:09: (Libpurple: gg) // gg_recv_packet() body recv(15,0xa426938,1) = 1
19:59:09: (Libpurple: gg) // gg_watch_fd_connected() received userlist reply
19:59:09: (Libpurple: gg) ** gg_event_free(0xa4b7770);
19:59:09: (Libpurple: gg) ** gg_watch_fd(0xa15e5a0);
19:59:09: (Libpurple: gg) // gg_watch_fd() GG_STATE_CONNECTED
19:59:09: (Libpurple: gg) ** gg_watch_fd_connected(0xa15e5a0, 0xa45ff90);
19:59:09: (Libpurple: gg) ** gg_recv_packet(0xa15e5a0);
19:59:09: (Libpurple: gg) // gg_recv_packet() header recv(15,0xbfffde70,8) = 8
19:59:09: (Libpurple: gg) // gg_recv_packet() body recv(15,0x13462b8,1) = 1
19:59:09: (Libpurple: gg) // gg_watch_fd_connected() received userlist reply
19:59:09: (Libpurple: gg) GG_USERLIST_PUT_REPLY
19:59:09: adiumPurpleNotifyMessage: type: 2

Buddy list uploaded
Your buddy list was stored on the server. 
19:59:09: (Libpurple: gg) ** gg_event_free(0xa45ff90);
19:59:11: (Libpurple: util) Writing file blist.xml to directory /Users/XXX/Library/Application Support/Adium 2.0/Users/Default/libpurple
19:59:11: (Libpurple: util) Writing file /Users/XXX/Library/Application Support/Adium 2.0/Users/Default/libpurple/blist.xml
19:59:13: -[AIListCell _drawHighlightWithFrame:inView:]: 
19:59:46: (Libpurple: gg) ** gg_ping(0xa15e5a0);
19:59:46: (Libpurple: gg) ** gg_send_packet(0xa15e5a0, 0x08, ...)

comment:11 Changed 11 years ago by es_uomikim

(I don't have to say it's still not working...)

comment:12 Changed 11 years ago by Robby

  • Milestone changed from Needs feedback from users to Adium 1.3.3

comment:13 Changed 11 years ago by evands

  • Milestone changed from Adium 1.3.3 to Waiting on libpurple

Please file a ticket with your debug logging on the libpurple Trac (http://developer.pidgin.im). Nobody on the Adium team uses or maintains the gadu-gadu protocol, and I don't see what the problem is based on your debug log.

When you file a ticket there, please note the ticket number here so we can cross-reference them.

comment:14 Changed 11 years ago by zacw

  • Status changed from new to closed

Closing all "waiting on libpurple" tickets. There's no reason to keep them around as open, and largely go ignored anyway. File a ticket at http://developer.pidgin.im for any functionality you want to see.

comment:15 Changed 11 years ago by anonymous

  • Milestone Waiting on libpurple deleted

Milestone Waiting on libpurple deleted

comment:16 Changed 9 years ago by Robby

Ticket #14220 has been marked as a duplicate of this ticket.

comment:17 Changed 9 years ago by Robby

es_uomikim had filed a ticket at Pidgin's Trac: #p8161.

comment:18 Changed 9 years ago by mg02

Hello, I see this ticket is closed, but there is still a problem here - the same all the time
I use the latest version of Adium - which is 1.4.1 at the moment.

How can this problem be fixed? How can I help in tracking the problem?
I created a debug .txt file - while trying to delete a contact, but I wanted to send it privately to the staff, not showing it here publicly.

Please help.

comment:19 Changed 9 years ago by Robby

mg02,

the ticket was closed because the problem lies in libpurple which is not developed by the Adium Team. A bug report was filed at the bug tracker of those who actually develop this library. See the comment above yours.

Last edited 9 years ago by Robby (previous) (diff)

comment:20 Changed 8 years ago by Robby

Ticket #15242 has been marked as a duplicate of this ticket.

comment:21 Changed 8 years ago by Robby

Ticket #15496 has been marked as a duplicate of this ticket.

comment:22 Changed 8 years ago by tomkiewicz

As I said in #p8161, it's Gadu-Gadu service provider issue, we cannot fix it by ourselves.

Anyway, using buddylist import/export mechanism as a synchronization service is IMHO misuse. New GG10 protocol provides new buddy list synchronization feature, but it's not yet implemented in libpurple. Most probably, when it will be ready, no changes in Adium (other than libpurple update) will be necessary to get that.

I have prepared two versions of patch (they differs in amount of code being removed), which should fix that issue by deleting gg buddy list synchronization support (it was not implemented in Pidgin, anyway). Unfortunately, I don't know that programming language. I even have no idea, what language it is! Also, I don't have Mac. So these patches are completely untested.

Changed 8 years ago by tomkiewicz

First version, not so many changes.

Changed 8 years ago by tomkiewicz

Better version, axe everything possible!

comment:23 Changed 8 years ago by Robby

  • Milestone set to Adium 1.4.4
  • Patch Status set to Needs Dev Review
  • Status changed from closed to new

comment:24 Changed 8 years ago by Robby

  • Milestone changed from Adium 1.4.4 to Adium 1.4.5

comment:25 Changed 8 years ago by Adrian Godoroja <robotive@…>

(In 33b9952680d3) Fix "Cannot delete Gadu-Gadu contact from list" by temporarily disabling Contact List sync with GG servers. Patch by Tomkiewicz, r=robotive. Refs #9126.

comment:26 Changed 8 years ago by Adrian Godoroja <robotive@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In 9b4f5ee4a326) Fix "Cannot delete Gadu-Gadu contact from list" by temporarily disabling Contact List sync with GG servers. Transplanted from 33b9952680d3 (1.4.x). Fixes #9126.
Changelog update.

comment:27 Changed 8 years ago by robotive

Contact list sync for Gadu-Gadu should be enabled when libpurple implements the new sync type.

comment:28 Changed 8 years ago by Robby

  • Patch Status changed from Needs Dev Review to Accepted
Note: See TracTickets for help on using tickets.