Adium

Opened 15 years ago

Closed 14 years ago

Last modified 11 years ago

#91 closed defect (fixed)

Contact icon overwrite problem (possibly)

Reported by: ivantse@gmail.com Owned by: anybody
Milestone: Adium X 1.0 Component: Adium Core
Version: Severity: minor
Keywords: images icons addressbook Cc: ivantse@…
Patch Status:

Description

  1. Check "Use Address book images as contacts' icons"
  1. The contact's icon will change to image in addressbook.
  1. Uncheck "Use Address book images as contacts' icons"
  1. The icon will not go back to the contact's current icon (non-addressbook icon) and remain as the addressbook image.

Thanks!

Ivan

Change History (8)

comment:1 Changed 15 years ago by samsamoa

Component: XtrasCore Adium

comment:2 Changed 15 years ago by Chris Forsythe

Cc: ivantse@… added
Milestone: Adium X 0.90
priority: normallow
Severity: normaltrivial

This is intended behavior if you have the "overwrite address book icons with contact icons" checkbox checked. Is this the case?

comment:3 Changed 15 years ago by Chris Forsythe

Summary: "Use Address book images as contacts' icons"Contact icon overwrite problem (possibly)

Changing the poorly worded summary

comment:4 Changed 15 years ago by ivantse@…

That's not the case. I haven't been using that checkbox.

The problem isn't that the server's image is overwriting the addressbook's image. Instead, I can never revert back to using the server's image once I've started using the addressbook's.

When unchecking "Use Address book images as contacts' icons" I'm expecting to be using the server's images again.

Ivan Tse

comment:5 Changed 14 years ago by Evan Schoenberg

(In [12993]) Fixed updating of metacontact icons when the contained contact icon changes or the metacontact's assigned icon changes. Fix note: A smaller float is a higher priority, so the meta contact looking for a high-priority image should load for a priority less than Medium_Priority, not greater than it.

Fixes #733 Fixes #988 Fixes #366 May be a fix for #486 (refs #486) Fixes #991 May be a fix for #91 (refs #91)

comment:6 Changed 14 years ago by Evan Schoenberg

(In [12995]) Merged [12993]: Fixed updating of metacontact icons when the contained contact icon changes or the metacontact's assigned icon changes. Fix note: A smaller float is a higher priority, so the meta contact looking for a high-priority image should load for a priority less than Medium_Priority, not greater than it.

Fixes #733 Fixes #988 Fixes #366 May be a fix for #486 (refs #486) Fixes #991 May be a fix for #91 (refs #91)

comment:7 Changed 14 years ago by David Smith

Milestone: Adium X 0.90 (Old)Adium X 0.90
Resolution: fixed
Status: newclosed

Closing this for now, as it may be fixed. Reopen if you can reproduce it.

comment:8 Changed 11 years ago by Zachary West

Component: Core AdiumAdium Core
Note: See TracTickets for help on using tickets.