Adium

Opened 12 years ago

Closed 12 years ago

Last modified 10 years ago

#9096 closed defect (fixed)

Message windows automatically avoiding dock when opened

Reported by: cometbus Owned by: nobody
Milestone: Adium 1.2.5 Component: Adium Core
Version: Severity: minor
Keywords: Cc:
Patch Status:

Description

Adium moves the chat window up about 100px from where I last left it. This happens on restart, or on close of window and re-opening of a chat window.

This seemed to start post 10.5 update.

This happens in 1.2.1 and back to 1.1.4

Change History (20)

comment:1 Changed 12 years ago by Jordan

Milestone: Needs feedback from users
pending: 01

I'm going to assume you haven't tried any of the TroubleshootingTips otherwise you would have mentioned the results of each one of them here already. A fresh set of prefs will likely solve this.

comment:1 Changed 12 years ago by trac-robot

pending: 10
Status: newclosed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

comment:2 Changed 12 years ago by Scott Haneda

I have tried the troubleshooting tips. I was not aware of them, but I generally will not report something as a bug unless I have taken it through its paces.

1) Make sure you're using the newest Adium release

Check

2) Remove any non-standard Xtras

Not using any

3) Try a fresh set of preferences

This was my first course of action

4) Try a fresh user account

Ok, I lied, I did this as a first step, thereby making step #3 not needed at all.

5) Try another client

non applicable

6) Remove and re-add an afflicted contact

non applicable

comment:3 Changed 12 years ago by Jordan

pending: 01
Status: closedreopened

Excellent. Does this happen every time you close and re-open a chat window? I cannot reproduce it by just opening one, closing it then opening it again. I'm using the 1.2.2 AdiumBeta.

comment:4 Changed 12 years ago by Scott Haneda

pending: 10

Yes, every single time, no matter who the contact is. I tihnk it has something to do with the bottom of the screen, I can move a window to the top of the screen, and close and re-open it, and it does not move, it opens back in the same place.

Same for the middle of the screen.

If I move the window to the bottom of the screen, as far as I can, even just releasing it, and it will pop up a bit in real time. Closing it and opening it again, and it is no longer even in that same place.

Truncate your chat window so the bottom of your screen chops it in half, dead on half, close it and open it, it should be moved up by 100 px or so.

Ok, so it has something to do with the Dock as well, turning the dock to hidden, and this bug no longer happens.

comment:5 Changed 12 years ago by Jordan

Cc: Evan Schoenberg added
Milestone: Needs feedback from usersAdium X 1.2.4

I thought this was intended functionality (from Apple) so as to prevent windows from being overlapped by and overlapping the dock when they are opened. But then interestingly, Finder windows do not behave like this... Evan would this be something in the Adium code that prevents windows from overlapping the dock?

comment:6 Changed 12 years ago by Jordan

Summary: Window position a constant moving targetMessage windows automatically avoiding dock when opened

Oh, one more note - I personally think this would be good behaviour for the contact list (which also behaves like this I believe), but wouldn't be necessary for message windows.

comment:7 Changed 12 years ago by Jordan

Cc: Evan Schoenberg removed
priority: normallow
Severity: normalminor

comment:8 Changed 12 years ago by Evan Schoenberg

Message windows open exactly where I left them and do not avoid the dock in my testing just now. Can anyone reproduce this problem?

comment:9 Changed 12 years ago by Jordan

Milestone: Adium X 1.2.5Adium X 1.2.4
Resolution: worksforme
Status: reopenedclosed

Indeed, I can no longer reproduce this - perhaps it was an OS X problem and 10.5.2 fixed it, since I don't recall there being any window positioning changes in the last couple months.

comment:10 Changed 12 years ago by Scott Haneda

Updated to 1.2.4, running 10.5.2 and I still experience no change in this behavior. See linked image, to see where a new window will default to, when making a new conversation. I can then move it down, and close it, and and it will open again in a slightly lower position. It will not perfectly remember window state though.

http://i27.tinypic.com/28cd3xt.png

comment:11 Changed 12 years ago by Jordan

Milestone: Adium X 1.2.4Adium X 1.2.5
Resolution: worksforme
Status: closedreopened

Evan, try the following:

  1. Move the message window so that it's bottom edge is against the bottom edge of the screen and behind the dock
  2. Close the window
  3. Open a message window

In my case, when the message window was re-opened, it's bottom edge was no longer against the bottom of the screen, but about half way up the dock. Then when I repeated those steps, it was just above the dock. Further repetition will result in it staying just above the dock, in the same place.

This was with [23090]

I think that when I tested this, I was looking for it to avoid the dock altogether, it seems that it 'slowly' makes its way up and away from it, the more you close and re-open the window.

comment:12 Changed 12 years ago by Evan Schoenberg

Hmph. It's off by the height of the toolbar, only if the dock is on the bottom and the window overlaps the dock. It doesn't happen if you use the pill button to turn off the toolbar.

comment:13 Changed 12 years ago by Evan Schoenberg

Resolution: fixed
Status: reopenedclosed

(In [23101]) Fixes #9096

comment:14 Changed 12 years ago by Evan Schoenberg

(In [23103]) -[AIWindowController stringWithSaveFrame] now generates its own string rather than relying on NSWindow's implementation, which performs some odd behavior when the window overlaps the dock and has a toolbar visible, moving it up by the height of the toolbar. Fixes #9096

comment:15 Changed 12 years ago by Evan Schoenberg

(In [23104]) Merged [23103]: -[AIWindowController stringWithSaveFrame] now generates its own string rather than relying on NSWindow's implementation, which performs some odd behavior when the window overlaps the dock and has a toolbar visible, moving it up by the height of the toolbar. Fixes #9096

comment:17 Changed 12 years ago by Scott Haneda

evands, thanks so much, I know this was an annoying thing to have to fix, but it was annoying to me and my workflow. Thanks again. Is there a nightly I can download to test?

comment:18 Changed 12 years ago by Evan Schoenberg

cometbus, 1.2.5 beta is now available.

comment:19 Changed 12 years ago by Scott Haneda

1.2.5 beta seems to resolve this for me. If we can keep this ticket open for the time being, I will have chats all day for a day, and give a final report here that I see resolution to this.

Thanks for looking into this, it was driving me a bit crazy at times, seems all better now.

comment:20 Changed 10 years ago by Daniel Seehof

This behavior has re-appaered for me with 10.6 and both the public and current beta of Adium. I can't position the message window below the upper edge of the Dock unless I hide the dock.

Note: See TracTickets for help on using tickets.