Adium

Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#9050 closed enhancement (duplicate)

modify addressbook name import in order to work with xmpp-gateways

Reported by: xmpp-nerd Owned by: nobody
Milestone: Component: Service/XMPP (Jabber)
Version: Severity: normal
Keywords: jabber, xmpp, addressbook Cc: Andreas Monitzer, Evan Schoenberg
Patch Status:

Description

Adiums feature to import the realnames from addressbook.app (if for example the icq number is included in a certain addressbook contact) is very handy. unfortunately this feature breaks when using an xmpp-icq-gateway.

the contact id in the roster is then "icqnumber@…" instead of just "icqnumber".

as adium knows about it's account gateways it should be possible to modify the addressbook interaction in order to work with gateways, too.

currently you have to workaround by saving your contacts icq number in addressbook like so:
icqnumber@… (Jabber)
instead of:
icqnumber (ICQ)

of course "icq" is just an example - this problem applies to all other services, too.

Change History (9)

comment:1 Changed 12 years ago by david

good you mentioned it. this is really one of the top issues for xmpp users (at least obviously in our humble opinion). i really hope that someone of the adium team shares our opinion. would be cool if they set a milestone not toooo far away :-)

comment:2 Changed 12 years ago by david

i just filed a real bug which is at least connected with adiums addressbook interaction features, maybe if someone is working on this one, he should also have a look on #9122 :-)

comment:3 Changed 12 years ago by Jordan

Milestone: Good idea for "later"

Adium obviously cannot know what domains are jabber gateways, so it would need to hope that anything with a number in front of it is an ICQ gateway?

comment:4 Changed 12 years ago by Andreas Monitzer

well, the gateways the user is subscribed to are known to adium (see the transport section of the account menu). just the type is a bit more complicated (disco#info).

comment:5 Changed 12 years ago by Jordan

Ahh yes of course - you must have an account with that transport anyway (unless we get into jabber cloud reachability) - I forgot about that.

comment:6 Changed 12 years ago by xmpp-nerd

exactly. that was what i meant :-) please dont issue it to the ticket graveyard "good idea for later" ;-)

comment:7 Changed 12 years ago by Carlos Morales

comment:8 Changed 11 years ago by Robert

Resolution: duplicate
Status: newclosed

Closed as duplicate of #7349.
... unless I'm mistaken.

comment:9 Changed 11 years ago by Robert

Milestone: Good idea for "later"
Note: See TracTickets for help on using tickets.