Adium

Opened 12 years ago

Closed 9 years ago

Last modified 9 years ago

#9004 closed defect (fixed)

VoiceOver support doesn't speak groups in contact window when interacting with the table.

Reported by: thewordnerd Owned by:
Milestone: Adium 1.5 Component: Adium UI
Version: 1.2.1 Severity: normal
Keywords: VoiceOver Accessibility Cc:
Patch Status:

Description (last modified by jas8522)

This is under OS X 10.5.1.

When in the contacts window, VoiceOver correctly speaks everything when the table listing contacts is not interacted with and arrowed through. It doesn't speak group names if the table is interacted with and scrolled through either using VO commands or arrows. This is important because ctrl-option-\ is the VO command to collapse/expand table rows with children, and doing so requires interaction, which doesn't provide the information needed to determine which group is being collapsed/expanded.

Steps to reproduce:

  1. Set focus onto the contacts window.
  2. Activate VO with cmd-f5.
  3. Ensure that the cursor is focused onto the contacts list table.
  4. Ensure that nothing is being interacted with by pressing ctrl-option-shift-uparrow until a short ping is heard.
  5. Arrow through the contacts list and, in particular, over a group. Notice how all information is spoken nicely.
  6. Interact with the table by pressing ctrl-option-shift-downarrow.
  7. Repeat step 5. Notice that, with groups, all that is spoken is "group."
  8. Arrow through the table using VO commands ctrl-option-up/downarrow. Notice how contact information is spoken, but only "collapsed level 0" is spoken for contact group rows.

Change History (11)

comment:1 Changed 12 years ago by jas8522

  • Description modified (diff)
  • Milestone set to Adium X 1.2.x

comment:2 Changed 12 years ago by jas8522

  • Milestone changed from Adium X 1.2.x to Adium X 1.3.x

comment:3 Changed 12 years ago by djmori

comment:4 Changed 11 years ago by jas8522

  • Milestone changed from Adium 1.3.x to Adium bugs

comment:5 Changed 10 years ago by wixardy

Ticket #10039 has been marked as a duplicate of this ticket.

comment:6 Changed 9 years ago by Robby

  • Owner nobody deleted

comment:7 Changed 9 years ago by Robby

Ticket #13011 has been marked as a duplicate of this ticket.

comment:8 Changed 9 years ago by Robby

  • Keywords VoiceOver added

comment:9 Changed 9 years ago by Robby

  • Keywords Accessibility added

comment:10 Changed 9 years ago by Frank Dowsett <wixardy@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In 814c67ba82e1) A start on fixing VO; first up: contact list. The role being set (row) is not what it should be (static text).

Fixes #12916 and #9004 Refs #15115

comment:11 Changed 9 years ago by wixardy

  • Milestone changed from Adium bugs to Adium 1.5
Note: See TracTickets for help on using tickets.