Adium

Opened 12 years ago

Closed 12 years ago

#8979 closed defect (fixed)

Google talk crash upon completing file transfer

Reported by: auria Owned by: am
Milestone: Adium 1.3 Component: Service/XMPP (Jabber)
Version: Severity: normal
Keywords: crash google talk file transfer Cc:
Patch Status:

Description

Google talk crash upon completing file transfer

The "version" field only offers me 1.2.1b1 but in the get info dialog it says "1.2.1" i.e. final, not beta

(I got a database crash while trying to submit the ticket, sorry if you receive multiple copies or something)

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x0000000a

Thread 0 Crashed:
0   libglib                        	0x08674004 g_list_find_custom + 96
1   libpurple                      	0x08825260 jabber_si_connect_proxy_cb + 308
2   libpurple                      	0x08810e94 jabber_iq_parse + 312
3   libpurple                      	0x08811a04 jabber_process_packet + 180
4   libpurple                      	0x0881ea48 jabber_parser_element_end_libxml + 180
5   libxml2.2.dylib                	0x91d69834 xmlParseStartTag + 9176
6   libxml2.2.dylib                	0x91d6b890 xmlParseDocument + 4812
7   libxml2.2.dylib                	0x91d4fc0c xmlParseChunk + 424
8   libpurple                      	0x0881ed10 jabber_parser_process + 176
9   libpurple                      	0x088125b8 jabber_recv_cb_ssl + 180
10  libpurple                      	0x087c3740 recv_cb + 80
11  com.apple.CoreFoundation       	0x907f13dc __CFSocketDoCallback + 532
12  com.apple.CoreFoundation       	0x907f1100 __CFSocketPerformV0 + 288
13  com.apple.CoreFoundation       	0x907de5b4 __CFRunLoopDoSources0 + 568
14  com.apple.CoreFoundation       	0x907dda2c __CFRunLoopRun + 452
15  com.apple.CoreFoundation       	0x907dd4ac CFRunLoopRunSpecific + 268
16  com.apple.HIToolbox            	0x93298b20 RunCurrentEventLoopInMode + 264
17  com.apple.HIToolbox            	0x9329812c ReceiveNextEventCommon + 244
18  com.apple.HIToolbox            	0x93298020 BlockUntilNextEventMatchingListInMode + 96
19  com.apple.AppKit               	0x9379dae4 _DPSNextEvent + 384
20  com.apple.AppKit               	0x9379d7a8 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 116
21  com.apple.AppKit               	0x93799cec -[NSApplication run] + 472
22  com.apple.AppKit               	0x9388a87c NSApplicationMain + 452
23  com.adiumX.adiumX              	0x000030ac _start + 760
24  com.adiumX.adiumX              	0x00002db0 start + 48

Attachments (7)

Adium_2008-03-10-111946_Minerva.crash (31.3 KB) - added by Markus Magnuson 12 years ago.
Crash log after finishing a file transfer on Gtalk
gtalk_crash.debug.log (6.1 KB) - added by Markus Magnuson 12 years ago.
Relevant debug output, from dropping the file on a contact, to crash
Adium_2008-03-11-101801_Minerva.crash (31.5 KB) - added by Markus Magnuson 12 years ago.
An here's a crash log from 1.2.4b1
Adium_2008-03-18-030015_vq-macbook.crash (36.3 KB) - added by Lawrence Velázquez 12 years ago.
Crash in 1.2.3, after completed transfer using "Send a file" in message window toolbar
gtalk_crash_124b2.log (5.9 KB) - added by Markus Magnuson 12 years ago.
Debug output from crashing Adium 1.2.4b2
Adium_2008-03-19-092027_Minerva.crash (31.2 KB) - added by Markus Magnuson 12 years ago.
And a crash log from 1.2.4b2
Adium_2008-04-01-233841_mimas.crash (37.0 KB) - added by Lawrence Velázquez 12 years ago.
crash log from 1.3svn (30 Mar 2008)

Download all attachments as: .zip

Change History (26)

comment:1 Changed 12 years ago by Jordan

Milestone: Adium X 1.2.2
Owner: changed from nobody to Evan Schoenberg

comment:2 Changed 12 years ago by Evan Schoenberg

Milestone: Adium X 1.2.2Waiting on libpurple
Owner: changed from Evan Schoenberg to nobody

This should be filed in Pidgin Trac.

comment:3 Changed 12 years ago by auria

Okay. I just wonder why you have "libpurple" as a component if such bugs cannot go here

comment:4 Changed 12 years ago by Jordan

Often bugs get reported here before they are in the Pidgin Trac, so we need a way of classifying it. Also, sometimes a bug is easily reproducible on OS X that might not be while using Pidgin, so a ticket here makes sense. Plus Evan and some of the other Adium devs submit occasional patches to Libpurple, so having it here can be handy for tracking.

Not only that, but if someone else experiences this bug, then they can find this ticket to reference it and know that we're aware of the problem! So it does have a few benefits having that libpurple entry as a selectable component.

comment:5 Changed 12 years ago by Robert

Milestone: Waiting on libpurpleNeeds feedback from users
pending: 01

Does this still occur in 1.2.4?

comment:6 Changed 12 years ago by Robert

Err, I mean 1.2.3, getting carried away here. ;)

comment:7 Changed 12 years ago by Markus Magnuson

Yes, I am still getting this in 1.2.3.

Changed 12 years ago by Markus Magnuson

Crash log after finishing a file transfer on Gtalk

comment:8 Changed 12 years ago by Jordan

Also try the 1.2.4 AdiumBeta :)

comment:9 Changed 12 years ago by Evan Schoenberg

It's still there in the 1.2.4 AdiumBeta, but I added debug logging trying to hunt down this specific crash. I haven't been able to reproduce the crash recently - it requires particular things to happen in a particular order, which is somewhat random since it depends on network conditions.

alimony, please see the instructions at CurrentAdiumDebug for getting the debug log file after reproducing this bug; attach that log file to this ticket. Thanks!

Changed 12 years ago by Markus Magnuson

Attachment: gtalk_crash.debug.log added

Relevant debug output, from dropping the file on a contact, to crash

Changed 12 years ago by Markus Magnuson

An here's a crash log from 1.2.4b1

comment:10 Changed 12 years ago by Robert

pending: 10

Changed 12 years ago by Lawrence Velázquez

Crash in 1.2.3, after completed transfer using "Send a file" in message window toolbar

comment:11 Changed 12 years ago by Lawrence Velázquez

Here's a crash log from my Adium 1.2.3 on Mac OS X 10.5.2. I sent a PNG by clicking on "Send a file" in my message window toolbar; Adium crashed as soon as the transfer completed.

comment:12 Changed 12 years ago by Jordan

pending: 01
Version: 1.2.1b11.2.3

Excellent, and the last one I'm going to get you to try is the 1.2.4 AdiumBeta - it has an updated libpurple communications core that might have solved this problem. If you can still reproduce it with that then we'll set this to be fixed for the next release.

Changed 12 years ago by Markus Magnuson

Attachment: gtalk_crash_124b2.log added

Debug output from crashing Adium 1.2.4b2

Changed 12 years ago by Markus Magnuson

And a crash log from 1.2.4b2

comment:13 Changed 12 years ago by Robert

pending: 10

Changed 12 years ago by Lawrence Velázquez

crash log from 1.3svn (30 Mar 2008)

comment:14 Changed 12 years ago by Jordan

Component: libpurpleJabber/XMPP
Keywords: crash, google, talk, file, transfercrash google talk file transfer
Milestone: Needs feedback from usersWaiting on libpurple
Owner: changed from nobody to Andreas Monitzer
Version: 1.2.31.2.4

comment:15 Changed 12 years ago by Carlos Morales

comment:16 Changed 12 years ago by ozean

The relevant bug at pidgin trac can be found here: http://developer.pidgin.im/ticket/5563

comment:17 Changed 12 years ago by Robert

Thanks a lot, ozean, much appreciated! :)

comment:18 Changed 12 years ago by Robert

#p5563 has been fixed just now, for Pidgin 2.5.0. :)

comment:19 Changed 12 years ago by David Smith

Milestone: Waiting on libpurpleAdium X 1.3
Resolution: fixed
Status: newclosed

Fixed in [23815]

Note: See TracTickets for help on using tickets.