Adium

Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#8966 closed defect (fixed)

divider lines in mockie message style

Reported by: dmainzman Owned by: jas8522
Milestone: Adium 1.3 Component: Adium Core
Version: Severity: normal
Keywords: divider lines mockie Cc:
Patch Status: Accepted

Description

In previous versions of Adium using the Mockie message appearance style, a faint grey divider line appeared between messages from the same person. Now in the 1.2.1 betas, I have noticed that the line is gone. Each message seems to blend into the next, as the background color for each user blends uniformly without the divider line. Under the Mockie style, since all messages in a row from each person are grouped under one instance of the screen name, the only way to tell what is a new message and what is just a line break is by looking at the time stamps, which not all users have enabled.

Attachments (2)

mockieDividerFix.diff (4.1 KB) - added by Jordan 12 years ago.
This fixes the divider lines and should also fix a potential issue with text overlap and certain time formats, though some might complain about too much spacing on the right side :P
mockie_margin_fix.diff (583 bytes) - added by Jordan 12 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 12 years ago by smn987

Yes, I just upgraded to 1.2.1 as well, and this regression creates serious usability problems with the Mockie style. A fix would be MUCH appreciated!

comment:2 Changed 12 years ago by Jordan

Keywords: divider, lines, mockiedivider lines mockie
Milestone: Adium X 1.2.2
Owner: changed from nobody to Jordan

I caused this when I removed paragraph tags from it and had to move things around to get it to display properly... I completely overlooked those dividers!

comment:3 Changed 12 years ago by Jordan

Status: newassigned

Changed 12 years ago by Jordan

Attachment: mockieDividerFix.diff added

This fixes the divider lines and should also fix a potential issue with text overlap and certain time formats, though some might complain about too much spacing on the right side :P

comment:4 Changed 12 years ago by Jordan

Patch Status: NoneNeeds Dev Review

comment:5 Changed 12 years ago by Evan Schoenberg

Resolution: fixed
Status: assignedclosed

(In [22458]) Correct between-message lines and spacing in Mockie. Patch from jas8522. Fixes #8966

comment:6 Changed 12 years ago by Evan Schoenberg

(In [22459]) Merged [22458]: Correct between-message lines and spacing in Mockie. Patch from jas8522. Fixes #8966

comment:7 Changed 12 years ago by smn987

Almost, but not quite, fixed. Notice that with this fix the divider line still doesn't go all the way across — it stops 40 pixels away from the right end. Seems the problem is that in Mockie's layout.css, the .text class's margin has been changed from zeros all around to "margin: 0 40px 0 0". Not sure why that right margin was added, but changing it back to zero fixes the problem. (I also see that for the .sender class, padding-right has been changed from zero to 30px; is there a reason for this? I'd think it should be changed back to zero as well, but I haven't really figured out what it does.)

Apologies for not just providing a convenient diff — I'm not really a developer and not even quite sure how to make a diff (especially because I'm not working with SVN, just changed a CSS file on my local machine); I just know how to occasionally muck around or tinker with Adium's internals on my computer sometimes when there's a feature that's important to me :-)

comment:8 Changed 12 years ago by proton

Resolution: fixed
Status: closedreopened

comment:9 Changed 12 years ago by smn987

Thanks for reopening this. I see that there's been another change to the css since my earlier comment — it looks like now the .text class uses the padding property rather than the margin property. In any case, the same basic issue remains. In pre-1.2.2 versions of Adium, messages sent and received using the Mockie style allowed the message text to flow around the timestamp. That is, the timestamp is in the upper-right corner of the message, but only one line high, so in a multi-line message the message text on lines below the timestamp would be able to make use of the whole width of the text area. But since the 1.2.2 changes, the style now includes a huge margin/padding on the right side, so when you have a very long multi-line message, there's a empty space running down the right side of the text area, beneath the timestamp.

Not only does this waste ugly and waste a huge amount of space, but it causes long messages to require many more lines than they did before, which detracts from usability. The message text and the timestamp are in different colors and easily distinguished, so I don't see any reason why we can't just have the text flow around the timestamp as it did in earlier versions, and jas8522 seems to indicate in an above comment that the change which causes this was meant to clean up the css rather than to address a usability issue, so my belief is that we can just reduce the size of this margin back to 2px or 4px like the rest, but someone more familiar with these changes than me might want to chime in n whether I'm overlooking something.

Changed 12 years ago by Jordan

Attachment: mockie_margin_fix.diff added

comment:10 Changed 12 years ago by Jordan

Milestone: Adium X 1.2.2Adium X 1.3
Patch Status: Needs Dev ReviewInitially Included
Version: 1.2.1b11.2.5

Fix attached for that margin issue.

comment:11 Changed 12 years ago by Carlos Morales

comment:12 Changed 12 years ago by Zachary West

Resolution: fixed
Status: reopenedclosed

(In [23491]) Untested patch from jas8522 to fix Mockie's margins being off. Fixes #8966.

comment:13 Changed 11 years ago by Robert

Patch Status: Initially IncludedAccepted
Note: See TracTickets for help on using tickets.