Adium

Opened 12 years ago

Closed 9 years ago

#8914 closed defect (cantreproduce)

XMPP URI for joining muc chatrooms don't

Reported by: bhyde Owned by:
Milestone: Component: Service/XMPP (Jabber)
Version: Severity: minor
Keywords: Cc:
Patch Status:

Description

This URI <xmpp:jabber@conference.jabber.org?join> is an instance of the format documented here <http://www.xmpp.org/extensions/xep-0045.html#registrar-querytypes> and the registered handler for the xmpp scheme should join the chat room denoted by that JID.

In Adium 1.2 it opens what appears to be a vanilla Jabber IM chat with that JID and displays a transcript of prior conversation. It will do that even if you already are in the chat room. It doesn't show the room's roster, and it doesn't display the muc command menu. If you remove ?join from the URI it does something else.

No doubt this has entanglements in the scheme for creating bookmarks to chatrooms.

Change History (15)

comment:1 Changed 12 years ago by Jordan

Milestone: Adium X 1.2.2

So the current action after clicking such a link is for Adium to load a normal chat window, when it should be creating a multi-user chat (at least that's what it sounds like to me)...

comment:2 Changed 12 years ago by Jordan

Did this work fine in 1.1.4?

comment:3 Changed 12 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

(In [22448]) Support joining XMPP conferences via xmpp://foo@conference.bar.org?join and xmpp://foo@conference.bar.org?join;password=blah URIs. Fixes #8914.

comment:4 Changed 12 years ago by Evan Schoenberg

(In [22449]) Merged [22448]: Support joining XMPP conferences via xmpp://foo@conference.bar.org?join and xmpp://foo@conference.bar.org?join;password=blah URIs. Fixes #8914.

comment:5 Changed 12 years ago by Ben Hyde

Thanks for working on this. But if it looks like there is a mistake. The xmpp uri are a bit odd. The double slash is actually exceptional, when it appears it prefixes the name of the who's making the connection, rather to whom the connection is being made. See section 2.3 in <http://tools.ietf.org/html/rfc4622>.

Assuming I'm reading the spec right xmpp://bob@s1.bar.org/bar@s2.gum.net?join is the syntax that Bob uses to go into the bar at s2.gum.net using the persona who's JID is bob@….

comment:6 Changed 12 years ago by Peter Saint-Andre

The XMPP URIs are not odd, they're just not hierarchical like many other URIs. Think mailto, not http. :)

To join the room foo on the XMPP chat service conference.bar.org, the proper URI is:

xmpp:foo@conference.bar.org?join

I think it's probably a good idea to ignore XMPP URIs with the double-slash form because they are used only in some special situations.

comment:7 Changed 12 years ago by Eric Richie

Resolution: fixed
Status: closedreopened

comment:8 Changed 12 years ago by Eric Richie

Reopened as per user request.

comment:9 Changed 12 years ago by Evan Schoenberg

Milestone: Adium X 1.2.2Patches welcome

Someone who cares about these URIs being better supported needs to pick up this ticket.

comment:10 Changed 12 years ago by Carlos Morales

comment:11 Changed 11 years ago by Robert

Milestone: Patches welcomeAdium bugs
priority: normallowest
Severity: normaltrivial

comment:12 in reply to:  description Changed 11 years ago by Sven Anderson

This is still very buggy. When opening the URI xmpp:foo@conference.bar.org?join everything seems to work. But if you close the chat and try to open the same URI again, nothing happens. I did some investigation: after the first URI request the applescript line

tell application "Adium" to get every chat

shows that the URI created two chats, one with the id "foo@…" (the normal one) and one with "foo" which is hidden. After closing the second one with applescript

tell application "Adium" to close chat "foo"

you can also close the real chat via GUI and reopen it with the URI again. This is maybe also connected to #10497?

comment:13 Changed 11 years ago by Sven Anderson

I fixed this together with some other things in #11785.

comment:14 Changed 9 years ago by Robert

Owner: nobody deleted

comment:15 Changed 9 years ago by Robert

Milestone: Adium bugs
Resolution: worksforme
Status: newclosed

#11785 was fixed. I guess that means this ticket can also be closed. Please comment if you have objections.

Note: See TracTickets for help on using tickets.