Adium

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#8828 closed defect (fixed)

Adium 1.2 repeating event sounds on G5 machines

Reported by: marcushe Owned by: nobody
Milestone: Adium 1.2.5 Component: Adium Core
Version: Severity: normal
Keywords: Cc:
Patch Status:

Description

Having an issue where sound from an event is usually repeated a random amount of times. Seems like it is caught in a loop. It repeats sounds more often than it doesn't. Sound also sometimes plays jittery.

I have dumped the application support folder and started from scratch with the same results. Using 10.5.1 on a G5.

Attachments (8)

AdiumSoundTester.zip (34.6 KB) - added by Evan Schoenberg 12 years ago.
Adium Sound Tester 1.0
AdiumSoundTester 2.0.zip (36.5 KB) - added by Evan Schoenberg 12 years ago.
Adium Sound Tester 2.0
AdiumSoundTester 2.1.zip (36.9 KB) - added by Evan Schoenberg 12 years ago.
Adium Sound Tester 2.1
AdiumSoundBugMachineExample.zip (177.6 KB) - added by Marcus Hesse 12 years ago.
System Profiler of example machine exhibiting the issue.
AdiumSoundTester 2.2.zip (37.3 KB) - added by Evan Schoenberg 12 years ago.
2.2
AdiumSoundTester 2.2.2.zip (37.3 KB) - added by Evan Schoenberg 12 years ago.
2.2
AdiumSoundTester 2.3.zip (37.5 KB) - added by Evan Schoenberg 12 years ago.
AdiumSoundTester reporter.zip (37.6 KB) - added by Evan Schoenberg 12 years ago.

Download all attachments as: .zip

Change History (71)

comment:1 Changed 12 years ago by Carlos Morales

Milestone: Needs feedback from users
pending: 01

weird. Not able to reproduce this on tiger

comment:2 Changed 12 years ago by Brandon Shea

Haven't noticed this (yet).

Are you sure it's just Adium having problems? Does other programs like iChat, iTunes, Colloquy, etc still have normal playback? And if you revert to an older version of Adium, does the problem disappear? Just trying to rule out some possibilities.

comment:3 Changed 12 years ago by Marcus Hesse

pending: 10

Reverted to 1.1.4 and problem dissappeared.

Replaced my Adium 1.2 with a fresh copy (maybe corrupted?) with sound bug continuing.

Also performed a system restart with no difference.

Any debugging I can attach?

comment:4 Changed 12 years ago by Carlos Morales

A console log would be great. Are you using built-in audio or something else?

comment:5 in reply to:  description ; Changed 12 years ago by Don Gillespie

Am also having the same problem. Reverting to 1.1.4 fixes. Repeating event sounds, broken and wavering sounds. I have feared that my sound card was dying. Running a powermac G5 duo (2.3 mhz), and Leopard 10.5.1. Nothing exotic.

comment:6 Changed 12 years ago by Peter Hosey

If you're having this problem, please post any Adium output you can find in the ConsoleLog. Remember to use WikiFormatting so your text will be readable!

comment:7 Changed 12 years ago by Evan Schoenberg

Also, what sound set are you using?

comment:8 in reply to:  7 Changed 12 years ago by Don Gillespie

Replying to evands:

Also, what sound set are you using?

Sound set: Tokyo Train Station.

comment:9 in reply to:  5 Changed 12 years ago by Scott Rae

Replying to owltech: I also have the same issue with a G5 PowerMac dual 2.3GHz, 10.5.1, and built-in audio. I'm using the iChat sound set with a few events removed. Issue does not occur after reverting to 1.1.3. The sound loop itself does not log any messages to console. However, quitting during the loop causes Adium to crash:

1/12/08 8:15:49 PM com.apple.launchd[94] ([0x0-0x257257].com.adiumX.adiumX[8307]) Exited abnormally: Segmentation fault 
1/12/08 11:35:33 PM Adium[9339] *** -[NSCFString allSounds]: unrecognized selector sent to instance 0x47d670 
1/12/08 11:35:33 PM Adium[9339] An uncaught exception was raised
 
1/12/08 11:35:33 PM Adium[9339] *** -[NSCFString allSounds]: unrecognized selector sent to instance 0x47d670 
1/12/08 11:35:33 PM Adium[9339] *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '*** -[NSCFString allSounds]: unrecognized selector sent to instance 0x47d670' 
1/12/08 11:35:33 PM Adium[9339] Stack: (
    2461663040,
    2520811180,
    2461692168,
    2461685508,
    2461686168,
    889800,
    2444507764,
    2444410688,
    2444458264,
    2444507988,
    2444410688,
    2444506436,
    2444506064,
    2444491920,
    2444488848,
    2461075468,
    2461214988,
    2444459584,
    2444459140,
    2501884924
) 
1/12/08 11:35:41 PM com.apple.launchd[94] ([0x0-0x2c12c1].com.adiumX.adiumX[9339]) Exited abnormally: Trace/BPT trap 
1/12/08 11:36:55 PM Adium[9448] <AIMessageTabSplitView: 0x76ef0e0>: the delegate <AIMessageViewController: 0x423de0> was sent -splitView:resizeSubviewsWithOldSize: and left the subview frames in an inconsistent state: 
1/12/08 11:36:55 PM Adium[9448] Split view bounds: {{0, 0}, {372, 99}} 
1/12/08 11:36:55 PM Adium[9448]     Subview frame: {{0, 0}, {339, 111}} 
1/12/08 11:36:55 PM Adium[9448]     Subview frame: {{348, 0}, {24, 111}} 
1/12/08 11:36:55 PM Adium[9448] The outer edges of the subview frames are supposed to line up with the split view's bounds' edges. NSSplitView is working around the problem, perhaps at the cost of more redrawing. (This message is only logged once per NSSplitView.) 
1/12/08 11:36:55 PM Adium[9448] <AIMessageTabSplitView: 0x46f620>: the delegate <AIMessageViewController: 0x423de0> was sent -splitView:resizeSubviewsWithOldSize: and left the subview frames in an inconsistent state: 
1/12/08 11:36:55 PM Adium[9448] Split view bounds: {{0, 0}, {556, 405}} 
1/12/08 11:36:55 PM Adium[9448]     Subview frame: {{0, 0}, {740, 379}} 
1/12/08 11:36:55 PM Adium[9448]     Subview frame: {{0, 385}, {740, 20}} 
1/12/08 11:36:55 PM Adium[9448] The outer edges of the subview frames are supposed to line up with the split view's bounds' edges. NSSplitView is working around the problem, perhaps at the cost of more redrawing. (This message is only logged once per NSSplitView.) 

There are also a few crash reports due to this. Would e-mail be the preferred way to submit them?

comment:10 in reply to:  description Changed 12 years ago by bronsonwagner

I am having this same exact issue and it's definitely Adium only. It began as soon as I opened Adium after upgrading to 1.2. It also does not matter which sound set is used, they all do it. I am running Leopard on a Dual 2Ghz G5.

comment:11 Changed 12 years ago by Robert

pending: 01

Sorry for the lacking response.

Is this still an issue?

comment:12 Changed 12 years ago by Marcus Hesse

pending: 10

Yes - still an issue with 1.2.2. Waiting for a fix. Us Dual-Core G5 owners are stuck on 1.1.4 until then {:o(.

comment:13 Changed 12 years ago by Robert

Milestone: Needs feedback from usersAdium X 1.2.x

Ok, that sucks, of course. I hope it gets fixed soon.

comment:14 in reply to:  description Changed 12 years ago by Don Gillespie

Replying to marcushe:

Having an issue where sound from an event is usually repeated a random amount of times. Seems like it is caught in a loop. It repeats sounds more often than it doesn't. Sound also sometimes plays jittery.

I have dumped the application support folder and started from scratch with the same results. Using 10.5.1 on a G5.

v1.2.3 has not solved this problem. What's that status on it? What kind of reportable experiments can I do to provide information? I am stuck at v1.1.4. -owltech

comment:15 Changed 12 years ago by Elliott Harris

priority: normalhigh

Setting this as high priority, seems like it's probably a memory management bug given that we are sending a selector to the wrong class. I'm debating moving this to 1.2.4, we should really have had this fixed much sooner.

comment:16 Changed 12 years ago by Elliott Harris

Milestone: Adium X 1.2.xAdium X 1.2.4

I'd like some feedback on this concerning 1.2.4b1, if the problem persists, I'd really like to push this to a blocker on 1.2.4, as we really need it fixed. If anyone can dedicate their time and machine to help us out on this, we'd appreciate it -- just reply to this ticket. If it still persists on 1.2.4b1, I'd like to dedicate some time to figuring this out and getting it fixed. Thanks.

comment:17 in reply to:  16 Changed 12 years ago by Marcus Hesse

Replying to eharris:

I'd like some feedback on this concerning 1.2.4b1, if the problem persists, I'd really like to push this to a blocker on 1.2.4, as we really need it fixed. If anyone can dedicate their time and machine to help us out on this, we'd appreciate it -- just reply to this ticket. If it still persists on 1.2.4b1, I'd like to dedicate some time to figuring this out and getting it fixed. Thanks.

Amen! {:o)

comment:18 Changed 12 years ago by Evan Schoenberg

Milestone: Adium X 1.2.4Needs feedback from users

We need someone on a G5 to test Adium 1.2.4 (or its beta) and report back.

comment:19 in reply to:  18 Changed 12 years ago by Don Gillespie

Replying to evands:

We need someone on a G5 to test Adium 1.2.4 (or its beta) and report back.

Count me in on that.

Model Name: Power Mac G5 Model Identifier: PowerMac11,2 Processor Name: PowerPC G5 (1.1) Processor Speed: 2.3 GHz Number Of CPUs: 2 L2 Cache (per CPU): 1 MB Memory: 5 GB Bus Speed: 1.15 GHz Boot ROM Version: 5.2.7f1 Serial Number: G86091VSUUZ

System Version: Mac OS X 10.5.2 (9C31) Kernel Version: Darwin 9.2.0 Boot Volume: Leopard Boot Mode: Normal Computer Name: fox User Name: owl (owl) Time since boot: 1 day9:49

What do I need to do?

Don GIllespie

comment:20 Changed 12 years ago by Jordan

Download the 1.2.4 AdiumBeta and see if the problem continues. If it does, see if you notice any debug logging from when the sound event occurs. You will be able to enable debug logging from the Adium menu under debug window once you are running the beta.

comment:21 Changed 12 years ago by Don Gillespie

Sending (a single letter "a") is still somewhat jerky. Here is what I get in the log file:

21:29:16: (Libpurple: util) Writing file /Users/owl/Library/Caches/Adium/Default/6033748e983389ad9928da896b5fe8a0d41c2198.gif
21:29:16: (Libpurple: oscar) Sending IM, charset=0x0000, charsubset=0x0000, length=57
21:29:17: (Libpurple: oscar) Sent message to sheilalark2.

It sometimes repeats the entire event sound, but mostly repeats the last part of it (the last half second, it seems).

Receiving (a single letter "a") causes multiple (4-5 times), random, entire event sound repeats. Here's the log entry:

21:37:27: (Libpurple: oscar) incomingim_ch1: unknown TLV 0x0013 (len 1)
21:37:27: (Libpurple: oscar) Received IM from sheilalark2 with 1 parts
21:37:27: (Libpurple: util) Writing file /Users/owl/Library/Caches/Adium/Default/6033748e983389ad9928da896b5fe8a0d41c2198.gif
21:37:27: (Libpurple: oscar) Parsing IM part, charset=0x0000, charsubset=0x0000, datalen=14
21:37:27: adiumPurpleConvWriteIm: Received <HTML>g</HTML> from sheilalark2
21:37:27: -[AIDockBehaviorPlugin performActionID:forListObject:withDetails:triggeringEventID:userInfo:]: Performing action BounceDockIcon for <AIListContact:ab50480 AIM.sheilalark2> with details {
    BehaviorType = 1;
}. Triggerring event was Content_MessageReceived.

comment:22 Changed 12 years ago by Marcus Hesse

Same here- 1.2.4 beta has same problem, getting same output with no errors.

comment:23 Changed 12 years ago by Robert

Milestone: Needs feedback from usersAdium X 1.2.x

comment:24 in reply to:  23 Changed 12 years ago by Don Gillespie

Replying to Robby: This version of Adiumx (1.2.4b2) works fine, now! no duplications, no jerks, just clear, clean sounds.

GOOD JOB! what was wrong? Care to share?

Don Gillespie owltech

comment:25 Changed 12 years ago by Jordan

Milestone: Adium X 1.2.xAdium X 1.2.4
Resolution: fixed
Status: newclosed

owltech: I don't think anything was done specifically for this problem, but there were a few other audio issue fixes in 1.2.4 that must have also repaired this issue.

comment:26 Changed 12 years ago by Evan Schoenberg

If 1.2.4b1 didn't work and 1.2.4b2 did, then it's not really fixed, most likely... as there were no changes to sound code between those two versions. Time will tell.

comment:27 Changed 12 years ago by Jordan

evands: I was just going through the changesets between b1 and b2 to see if anything could have affected this - I didn't see anything, so I was just thinking the same thing...

comment:28 Changed 12 years ago by Marcus Hesse

Not fixed! Issue still remains with 1.2.4b2. On a Dual Core 2.0 G4 with 4 Gigs RAM...

comment:29 Changed 12 years ago by Marcus Hesse

In addition, it only seems to be sounds from messages received and not sent...

comment:30 Changed 12 years ago by Marcus Hesse

Ah!, and I meant Dual Core G5 not G4...

comment:31 Changed 12 years ago by Jordan

Milestone: Adium X 1.2.4Adium X 1.2.x
Resolution: fixed
Status: closedreopened
Version: 1.21.2.4b2

comment:32 in reply to:  31 ; Changed 12 years ago by Don Gillespie

Replying to jas8522: I wife and I just torture tested it on our practically identical machines, and it works fine. I have a G5 duo 2.3 running 10.5.2 and she has a G5 dual 2.0 running 10.4.11. No problems, event sounds are steady and non-repeated.

comment:33 in reply to:  32 Changed 12 years ago by Don Gillespie

Replying to owltech:

Replying to jas8522: My wife and I just torture tested it on our practically identical machines, and it works fine. I have a G5 duo 2.3 running 10.5.2 and she has a G5 dual 2.0 running 10.4.11. No problems, event sounds are steady and non-repeated.

Moreover, she now has the 1.2.4b2 running as well, with no sound problems. She has just tested it with other remote (non-adium) clients, and it still works fine.

comment:34 Changed 12 years ago by Marcus Hesse

I can confirm for a second time I definitely still have the issue with 1.2.4b2. However It only happens on received messages now instead of both sent & received. Dual Core 2.0 G5 4 Gigs RAM.

comment:35 in reply to:  34 Changed 12 years ago by Evan Schoenberg

Replying to marcushe:

I can confirm for a second time I definitely still have the issue with 1.2.4b2. However It only happens on received messages now instead of both sent & received. Dual Core 2.0 G5 4 Gigs RAM.

Try swapping the sounds you have assigned? Sent and received messages go through the same code path in terms of playing sounds.

comment:36 Changed 12 years ago by Marcus Hesse

My bad on the "only received messages" part, its still all sounds that are repeating.

For further proof, here is a video I made documenting the bug still in 1.2.4b2 (I'm not crazy).

Thanks! - Marcus

homepage.mac.com/marcushe/AdiumBugVideo.m4v

comment:37 in reply to:  36 Changed 12 years ago by Scott Rae

Replying to marcushe:

For further proof, here is a video I made documenting the bug still in 1.2.4b2 (I'm not crazy).

This is the behavior I was seeing earlier, but I haven't been able to recreate it in 1.2.4. Does quitting the client while it's looping cause it to crash, like my earlier comment? Perhaps a crashdump is the easiest way to find the offending code.

comment:38 Changed 12 years ago by Marcus Hesse

Can't get it to crash while the sound is looping or crackly...quits normally.

This has to be some kind of memory allocation issue..

comment:39 Changed 12 years ago by Evan Schoenberg

I am doubtful that it is a memory allocation issue.

Please try the attached testing program. It provides two buttons. The one labeled 'complete' does exactly what Adium normally does. The one labeled 'simplified' uses QTMovie in the simplest way possible. Do either reproduce the problem you're seeing?

Changed 12 years ago by Evan Schoenberg

Attachment: AdiumSoundTester.zip added

Adium Sound Tester 1.0

comment:40 Changed 12 years ago by Marcus Hesse

Bingo! "Complete" reproduces the problem, "Simplify" works fine.

comment:41 Changed 12 years ago by Evan Schoenberg

Great! Now we'll make 'simplify' progressively closer to 'complete'. Please try level 1, level 2, and level 3 in the attached version 2 of the testing program.

Changed 12 years ago by Evan Schoenberg

Attachment: AdiumSoundTester 2.0.zip added

Adium Sound Tester 2.0

comment:42 in reply to:  41 Changed 12 years ago by Don Gillespie

Replying to evands:

Great! Now we'll make 'simplify' progressively closer to 'complete'. Please try level 1, level 2, and level 3 in the attached version 2 of the testing program.

Any chance of sending me the test program? I really would like to see what it does on my systems.

tech@…

comment:43 Changed 12 years ago by Don Gillespie

Found the program. FYI, there is no difference in the sound in any version or level for me, either system.

comment:44 Changed 12 years ago by Marcus Hesse

In version 2.0 of the program, "Complete" still produces the problem, and levels "1", "2", and "3" all are fine....

Changed 12 years ago by Evan Schoenberg

Attachment: AdiumSoundTester 2.1.zip added

Adium Sound Tester 2.1

comment:45 Changed 12 years ago by Evan Schoenberg

Interesting... please try all 5 levels in version 2.1.

comment:46 Changed 12 years ago by Marcus Hesse

Hey guess what - simplified level 5 reproduces the problem.

comment:47 Changed 12 years ago by Evan Schoenberg

Thanks for your rapid fire testing this evening. I have to head out; will update with a new version when I can.

Changed 12 years ago by Marcus Hesse

System Profiler of example machine exhibiting the issue.

comment:48 Changed 12 years ago by Marcus Hesse

I have added an attachment of the System Profiler of my machine if it helps any.

Changed 12 years ago by Evan Schoenberg

Attachment: AdiumSoundTester 2.2.zip added

2.2

Changed 12 years ago by Evan Schoenberg

Attachment: AdiumSoundTester 2.2.2.zip added

2.2

comment:49 Changed 12 years ago by Evan Schoenberg

Oops, attached twice. The 2.2 files above are identical.

Please try levels 6 and 7 with 2.2. Also, take a look at the Console (/applications/utilities/Console) and see if there's any output when trying these.

comment:50 Changed 12 years ago by Marcus Hesse

In version 2.2.2, Levels 5 & 7 reproduce the issue, with nothing interesting in the console. (Unless a bunch of "Updating for system output device change" - one every couple seconds are abnormal).

comment:51 Changed 12 years ago by Evan Schoenberg

Incredibly abnormal! :)

What is your sound configuration? Do you use the built-in sound device, or do you have an external one such as an iMic or a Firebox? Do you use built-in audio, USB speakers, headphone-style speakers, or headphones?

comment:52 Changed 12 years ago by Marcus Hesse

Hi, sorry for the delay - was actually out of town getting Apple Marketing training at the Cupertino HQ!

I use the built-in audio with external speakers. They are headphone-style.

Thanks!

comment:53 Changed 12 years ago by Scott Rae

Well, I thought the 1.2.4 betas had mysteriously cured the problem, but I just updated to 1.2.4b3 and immediately started hitting it again. I tried out the latest AdiumSoundTester, and I also hear the sound hitch or double-play on levels 5 and 7, but not on level 6 after a few dozen tries.

I downgraded to 1.2.4b2 and hit the issue again there, so apparently I just got lucky before, or there's an outside issue at work that wasn't occurring for the past few weeks. The log file shows only one instance of BounceDockIcon for each message:

23:13:29: (Libpurple: oscar) Sending IM, charset=0x0000, charsubset=0x0000, length=17
23:13:29: (Libpurple: oscar) incomingim_ch1: unknown TLV 0x0013 (len 1)
23:13:29: (Libpurple: oscar) Received IM from yattarou with 1 parts
23:13:29: (Libpurple: oscar) Parsing IM part, charset=0x0000, charsubset=0x0000, datalen=17
23:13:29: adiumPurpleConvWriteIm: Received <HTML>test</HTML> from yattarou
23:13:29: -[AIDockBehaviorPlugin performActionID:forListObject:withDetails:triggeringEventID:userInfo:]: Performing action BounceDockIcon for <AIListContact:adcfe80 AIM.yattarou> with details {
    BehaviorType = 1;
}. Triggerring event was Content_MessageReceived.
23:13:29: (Libpurple: oscar) Sent message to yattarou.
23:13:31: (Libpurple: oscar) Sending IM, charset=0x0000, charsubset=0x0000, length=17
23:13:32: (Libpurple: oscar) incomingim_ch1: unknown TLV 0x0013 (len 1)
23:13:32: (Libpurple: oscar) Received IM from yattarou with 1 parts
23:13:32: (Libpurple: oscar) Parsing IM part, charset=0x0000, charsubset=0x0000, datalen=17
23:13:32: adiumPurpleConvWriteIm: Received <HTML>test</HTML> from yattarou
23:13:32: -[AIDockBehaviorPlugin performActionID:forListObject:withDetails:triggeringEventID:userInfo:]: Performing action BounceDockIcon for <AIListContact:adcfe80 AIM.yattarou> with details {
    BehaviorType = 1;
}. Triggerring event was Content_MessageReceived.
23:13:32: (Libpurple: oscar) Sent message to yattarou.
23:13:42: (Libpurple: oscar) Sending IM, charset=0x0000, charsubset=0x0000, length=17
23:13:42: (Libpurple: oscar) incomingim_ch1: unknown TLV 0x0013 (len 1)
23:13:42: (Libpurple: oscar) Received IM from yattarou with 1 parts
23:13:42: (Libpurple: oscar) Parsing IM part, charset=0x0000, charsubset=0x0000, datalen=17
23:13:42: adiumPurpleConvWriteIm: Received <HTML>test</HTML> from yattarou
23:13:42: -[AIDockBehaviorPlugin performActionID:forListObject:withDetails:triggeringEventID:userInfo:]: Performing action BounceDockIcon for <AIListContact:adcfe80 AIM.yattarou> with details {
    BehaviorType = 1;
}. Triggerring event was Content_MessageReceived.
23:13:42: (Libpurple: oscar) Sent message to yattarou.
23:13:44: purple closeChat:AIM.yattarou

Incidentally, it seems messaging myself is the easiest way to get this to happen. I get loops at least 75% of the time, compared to only once in several messages with others.

comment:54 Changed 12 years ago by Evan Schoenberg

srae, what's your sound configuration, and what's your CPU / system config?

comment:55 in reply to:  54 Changed 12 years ago by Scott Rae

Replying to evands:

srae, what's your sound configuration, and what's your CPU / system config?

Sound uses built-in line out. System is a dual core G5, 2.3GHz, 4.5GB RAM, running 10.5.2 with current system updates.

comment:56 Changed 12 years ago by Don Gillespie

I am also back to repeating and jagged sounds. I have the same config as srae, and the same symptoms. Amazingly, 1.2.4b2 was fine for a while, and later degraded. The only updates have been Safari 3.1, Aperture 2.1, and the latest Apple security update. I don't think they are related to the problem.

Changed 12 years ago by Evan Schoenberg

Attachment: AdiumSoundTester 2.3.zip added

comment:57 Changed 12 years ago by Evan Schoenberg

Please try levels 5 through 7 on tester 2.3.

comment:58 in reply to:  57 Changed 12 years ago by Scott Rae

Replying to evands:

Please try levels 5 through 7 on tester 2.3.

I tried 50 reps on levels 5-7, as well as a few Complete, and could not recreate the issue. Just to make sure, I went back to AdiumSoundTester 2.2.2, and it still skips.

comment:59 Changed 12 years ago by Don Gillespie

AdiumSoundTester 2.3 does not fail for me on any level or on complete. No skipping or repeating.

comment:60 Changed 12 years ago by Evan Schoenberg

Milestone: Adium X 1.2.xAdium X 1.2.5
Summary: Adium 1.2 repeating event soundsAdium 1.2 repeating event sounds on G5 machines

Changed 12 years ago by Evan Schoenberg

comment:61 Changed 12 years ago by Evan Schoenberg

I'd like to file this problem with Apple officially. Could one of you who was seeing this issue please run the "AdiumSoundTester reporter" version I just attached and check the Console for output over 10 seconds before playing a sound and then after playing a sound (any level)?

comment:62 Changed 12 years ago by Evan Schoenberg

Resolution: fixed
Status: reopenedclosed

(In [23017]) The G5 has a rather odd bug in its interaction with CoreAudio which leads us to get repeated spurious notifications that kAudioHardwarePropertyDefaultSystemOutputDevice changed. We can't make use of the notification on that platform; doing so means that playing sounds continuously stutter as we pause and resume them while trying to update the output device (and also eat CPU in the process).

Once the requested debug output from a G5 is given, I'll be filing this with Apple.

Fixes repeated/stuttering event sounds on G5s, which have been a problem since the switch to QTMovie for sound playing. Fixes #8828

comment:63 Changed 12 years ago by Evan Schoenberg

(In [23020]) Merged [23017] and [23018]: Fixed repeating/stutterring event sounds on G5 machines. Fixes #8828

Note: See TracTickets for help on using tickets.