Adium

Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#8821 closed defect (fixed)

AppleScript crashes when trying to get every window

Reported by: mtimmsj Owned by: applmak
Milestone: Adium 1.2.1 Component: AppleScript
Version: Severity: regression
Keywords: AppleScript crash window Cc:
Patch Status:

Description

Steps to reproduce:

Run the following in Script Editor when you have some chat windows open:

tell application "Adium" to get every window

This results in an Adium crash and an Applescript -609 "connection is invalid" error. This crash also occurs if you try to get the properties of a window using:

tell application "Adium" to get properties of window 1

The key seems to be having chat windows open.

Sometimes the error is -100000 "AppleEvent Handler failed and the crash doesn't occur until you run the script a second time.

The console output is:

1/7/08 5:03:24 PM com.apple.launchd[96] ([0x0-0x7d07d0].com.adiumX.adiumX[14859]) Exited abnormally: Segmentation fault

Sometimes the console will also report:

1/7/08 5:00:13 PM Adium[14831] An exception was thrown during execution of an NSScriptCommand... 
1/7/08 5:00:13 PM Adium[14831] Error while returning the result of a script command: the result object...
(
    <NSWindow: 0x7005250>,
    <AIBorderlessWindow: 0x707dae0>,
    <NSStatusBarWindow: 0x8c8f530>,
    <NSWindow: 0x8c9bc60>,
    <NSWindow: 0x85b4170>,
    <NSWindow: 0x85add20>,
    <NSWindow: 0xa92a160>,
    <NSWindow: 0xa939e50>,
    <NSWindow: 0x8b92b90>,
    <AIMessageWindow: 0x8a470f0>,
    <NSWindow: 0x874c130>,
    <NSWindow: 0x426680>
)
...could not be converted to an Apple event descriptor of type 'list of window'. Element 9 could not be converted to an Apple event descriptor of type 'window'. NSScriptTypeDescription 

Attachments (1)

Adium_2008-01-07-170321_Macintosh.crash (33.1 KB) - added by Mike 13 years ago.
Crash Log

Download all attachments as: .zip

Change History (9)

Changed 13 years ago by Mike

Crash Log

comment:1 Changed 13 years ago by Jordan

Milestone: Adium X 1.2.1
Severity: normalregression

comment:2 Changed 13 years ago by Jordan

Milestone: Adium X 1.2.1Adium X 1.2.2
Owner: changed from nobody to Matt Handley

comment:3 Changed 13 years ago by Matt Handley

Resolution: fixed
Status: newclosed

(In [22276]) This fixes a crash when trying to get a message window's specifier. Closes #8821.

comment:4 Changed 13 years ago by Robert

I'd say this goes in 1.2.1.

comment:5 Changed 13 years ago by Peter Hosey

Milestone: Adium X 1.2.2Adium X 1.2.1

Why was it even moved back to 1.2.2? If it's a regression (and I agree that it is), the fix should go into 1.2.1.

comment:6 Changed 13 years ago by Peter Hosey

(In [22277]) Merged r22276 from trunk (because #8821 is a regression and milestoned for 1.2.1): This fixes a crash when trying to get a message window's specifier. Closes #8821.

comment:7 Changed 13 years ago by Evan Schoenberg

Milestone: Adium X 1.2.1Adium X 1.2.2

comment:8 Changed 13 years ago by Evan Schoenberg

Milestone: Adium X 1.2.2Adium X 1.2.1
Note: See TracTickets for help on using tickets.