Adium

Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#8818 closed defect (fixed)

AppleScript no longer has access to contact images

Reported by: mtimmsj Owned by: nobody
Milestone: Adium 1.2.1 Component: AppleScript
Version: Severity: regression
Keywords: AppleScript contact images Cc:
Patch Status:

Description

Prior to Adium 1.2, the contact class in AppleScript contained a property to get and set a contacts image utilizing something like:

tell application "Adium" to get the image of theContact

And

tell application "Adium" to set the image of theContact as TIFF picture

In 1.2 this property no longer exists which is a regression.

Change History (10)

comment:1 Changed 13 years ago by Mike

I misspoke, the image was a property of the list object class.

comment:2 Changed 13 years ago by Jordan

Resolution: invalid
Status: newclosed

Ahh good, so it is indeed accessible, just from another place.

comment:3 in reply to:  2 Changed 13 years ago by Mike

Replying to jas8522:

Ahh good, so it is indeed accessible, just from another place.

Perhaps you misunderstood me. A contacts image is not accessible in 1.2 as the list object class is no longer available and the contact class (where it would seem most appropriate) does not have the property. If it is accessible from another place I have yet to find it. I've looked through the entire dictionary for Adium and can find no references to images.

comment:4 Changed 13 years ago by Evan Schoenberg

Resolution: invalid
Status: closedreopened

comment:5 Changed 13 years ago by Jordan

Milestone: Adium X 1.2.2
Severity: normalregression

comment:6 Changed 13 years ago by Matt Handley

Resolution: fixed
Status: reopenedclosed

(In [22234]) Added image property to contacts. It's read only, and allows a scripter to get at the image data. Added NSDataAdditions to get that to work. This is because Adium now uses sdef as the AS dictionary, which needs these two extra methods. Closes #8818.

comment:7 Changed 13 years ago by Robert

I'd say this goes in 1.2.1.

comment:8 Changed 13 years ago by Matt Handley

Milestone: Adium X 1.2.2Adium X 1.2.1

comment:9 Changed 13 years ago by Evan Schoenberg

Milestone: Adium X 1.2.1Adium X 1.2.2

comment:10 Changed 13 years ago by Evan Schoenberg

Milestone: Adium X 1.2.2Adium X 1.2.1
Note: See TracTickets for help on using tickets.