Adium

Opened 13 years ago

Closed 13 years ago

Last modified 8 years ago

#8762 closed defect (fixed)

Unable to add: Could not add the buddy 1 for an unknown reason.

Reported by: owzark127 Owned by: nobody
Milestone: Adium 1.2.4 Component: Adium Core
Version: Severity: normal
Keywords: Cc:
Patch Status:

Description

I have just recently updated to Adium 1.2. Whenever I open up Adium, everything loads correctly and my accounts login, but i receive an error message saying "Could not add the buddy 1 for an unknown reason." I two accounts, a GTalk and AIM account. They are set to automatically login whenever I open up Adium. The computer I am running on is a 1.6 GHz Power Mac G5 running OS X 10.5.1 "Leopard". Attached to this ticket is a screenshot of the error message.

Attachments (2)

errorMessage.png (24.6 KB) - added by owzark127 13 years ago.
Screenshot of the Error Message
Screen shot 2010-06-17 at 3.16.11 PM.png (278.3 KB) - added by Dan Pritchard 10 years ago.
Oh crap, and i wasn't even trying to add a buddy. this just happens when i sign on!

Download all attachments as: .zip

Change History (26)

Changed 13 years ago by owzark127

Attachment: errorMessage.png added

Screenshot of the Error Message

comment:1 Changed 13 years ago by Carlos Morales

Milestone: Needs feedback from users
pending: 01

I can not reproduce this. Does this happens with a certain contact, or just any @gmail address?

comment:2 in reply to:  description Changed 13 years ago by sublime10c

I also have the same problem except I am only running an aim account. I am running a 1.83 GHz Macbook with OS X 10.4.11

comment:3 in reply to:  1 Changed 13 years ago by bartstam

Replying to djmori:

I can not reproduce this. Does this happens with a certain contact, or just any @gmail address?

Similar problem as described. Error doesn't occur after I removed my ICQ account within Adium. If I add my ICQ again, problem will reoccur, every time I restart Adium.

comment:4 Changed 13 years ago by lilitaliandragon

I have two aim accounts and a gmail account and I get the same error, usually doubled though, so I'd assumed it had to do with the aim accounts but I am not sure. I have a 1.83 GHz Macbook with OS X 10.5.1

comment:5 Changed 13 years ago by m1ss1ontomars2k4

I can confirm this; I get the same message in Pidgin as well when I'm on Windows and using the same AIM account as I am on Mac OS X.

Perhaps one should try adding 1 as a buddy (put the digit as a screenname) and see what happens.

comment:6 in reply to:  5 ; Changed 13 years ago by m1ss1ontomars2k4

Replying to m1ss1ontomars2k4:

I can confirm this; I get the same message in Pidgin as well when I'm on Windows and using the same AIM account as I am on Mac OS X.

Perhaps one should try adding 1 as a buddy (put the digit as a screenname) and see what happens.

I should probably also note that this didn't happen in Adium until today. For some reason, for the entire afternoon Adium did not report buddies that had signed on as being online, and as people signed off, my buddy list got shorter and shorter. Eventually I only had 25 people listed as online on my buddy list (including away/idle/mobile). After I restarted Adium, my buddy list was restored to show that more than 80 of my contacts are online. However I then got this weird, meaningless error that I usually only get in Pidgin. I can reproduce this error perfectly in Pidgin, by the way.

comment:7 Changed 13 years ago by Carlos Morales

Milestone: Needs feedback from usersNeeds dev review
pending: 10

comment:8 in reply to:  6 ; Changed 13 years ago by dwrecktion

This has probably happened to me for the past year when I try to add an AIM account. I've kept update the whole time and started on a G4 iBook and now on a 1.83Hz Macbook OS X 10.4.11. The only way I can add buddies is to sign on via iChat and add the buddy from there.

comment:9 in reply to:  8 ; Changed 13 years ago by m1ss1ontomars2k4

Replying to dwrecktion:

This has probably happened to me for the past year when I try to add an AIM account. I've kept update the whole time and started on a G4 iBook and now on a 1.83Hz Macbook OS X 10.4.11. The only way I can add buddies is to sign on via iChat and add the buddy from there.

Yes, I used to have to do that too; I created a new group to add buddies to and now it appears to work.

I reverted to Adium 1.2 using Time Machine and the bug went away.

comment:10 in reply to:  9 Changed 13 years ago by m1ss1ontomars2k4

Replying to m1ss1ontomars2k4:

I reverted to Adium 1.2 using Time Machine and the bug went away.

Sorry, I lied. Adium 1.2 still has this bug. Recently, it will usually either give this bug, or it will show all of my buddies as being offline when they are not. In particular, my AIM bot is definitely online, as I can message and see in my logs that my AIM bot did indeed receive a message, but I never receive a reply from my bot, even though it sends one.

Sometimes neither bug shows up, luckily enough; the entire day I kept having these bugs when I didn't want them, and as soon as I attempted to reproduce them, they stopped occurring and I got disconnected for signing on and off too frequently.

comment:11 Changed 13 years ago by markus

i have had this bug since the last 4 updates or something, every time i start adium i get the exact same message box as is attached to this ticket.. ive thought that this would be fixed in the coming updates but since nothing happens i just want to bump this thread :) when the bug first started to appear i was running 10.4, but now ive upgraded to leopard and the bug still remains..

do you want a stack retrace or something?

cheers

comment:12 Changed 13 years ago by 3ckig

Is there any ongoing Development for solving this issue? It is really annoying to have this error message on adium start.

comment:13 Changed 13 years ago by Evan Schoenberg

In what language does Adium run for you?

comment:14 Changed 13 years ago by markus

english?

comment:15 in reply to:  13 Changed 13 years ago by 3ckig

Replying to evands:

In what language does Adium run for you?

German

comment:16 Changed 13 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

(In [22968]) Resuppress the 'Could not add buddy 1 for an unknown reason' message and handle it in all languages. Fixes #8762

comment:17 Changed 13 years ago by Evan Schoenberg

(In [22969]) Merged [22968]: Resuppress the 'Could not add buddy 1 for an unknown reason' message and handle it in all languages. Fixes #8762

comment:18 Changed 13 years ago by Robert

Milestone: Needs dev reviewAdium X 1.2.4

Changed 10 years ago by Dan Pritchard

Oh crap, and i wasn't even trying to add a buddy. this just happens when i sign on!

comment:19 Changed 10 years ago by Robert

dgp, see the newest post on the Adium blog.

comment:20 Changed 8 years ago by ckujau

Robby, did you refer to this: http://adium.im/blog/2010/06/ If so, the outcome of this bug would be "It's AOL's fault, they fixed it", right?

For some time now I have the same error message ("Unable to add the buddy 1 for an unknown reason.") with Adium 1.5.3 whenever I sign in to an ICQ account.

I don't know if ICQ is "aware" of anything or would even care to "fix" it. But I still think this "for an unknown reason" message could be improved.

FWIW, Pidgin has a simliar bug: http://developer.pidgin.im/ticket/3697, even older than this one.

comment:21 Changed 8 years ago by ckujau

Looking at SLPurpleCocoaAdapter.m, this could be the one:

//Suppress notification warnings we have no interest in seeing
[...]
if ([secondaryString isEqualToString:
   [NSString stringWithFormat:[NSString stringWithUTF8String:_("Could not add the buddy %s for an unknown reason.")], "1"]]) {
  /* Rather random error displayed by OSCAR (since forever, as of libpurple 2.4.0) for some clients while connecting */
  return NULL;

(is the message somhow mapped to ../en_GB/LC_MESSAGES/pidgin.mo?)

So, if the error is not important (and this is the correct line of code), couldn't we just suppress it?

comment:22 Changed 8 years ago by d-b

I started to receive this error message the last few days. And I haven't done anything with my ICQ account for ages.

comment:23 Changed 8 years ago by Schnitz

It started happening today to me as well. I am running Adium 1.5.3 on Mountain Lion.

comment:24 Changed 8 years ago by Robert

This has been frequently reported over the past couple of days. Obviously, the issue was introduced server by ICQ but it remains unclear whether it's a temporary problem. (http://developer.pidgin.im/ticket/3697#comment:70)

I've added this issue to our Help page. The issue is also being discussed in a thread on the Adium forum.

Note: See TracTickets for help on using tickets.