Adium

Opened 12 years ago

Closed 12 years ago

#8730 closed defect (fixed)

Contact list shows mixed information from Metacontacts

Reported by: jas8522 Owned by: nobody
Milestone: Adium 1.3 Component: Adium Core
Version: Severity: normal
Keywords: Cc:
Patch Status:

Description (last modified by Jordan)

Take a look at the attached screenshots. You can see that in some cases it shows available service icons (from one of the accounts associated with the metacontact) but then the status message shows "Away".

Sometimes this can even end up with contacts sorted such that a busy contact shows up amongst the available contacts and vice versa (because one account is represented by position, but the other is represented by status icon).

Correct me if I'm wrong, but my understanding is that it should show all the data associated with the account firstly by status, then by preference shown in the get info window list of accounts, but not little bits of both. If you look closely at the pictures you can see that just about every piece of data can get mixed up between the two associated accounts, including display picture/buddy icon.

Refs: #9141

Attachments (2)

display pic discrepancy.png (122.7 KB) - added by Jordan 12 years ago.
Display picture in CL is that of offline account.
Image 2.png (44.6 KB) - added by Carlos Morales 12 years ago.
Display Pic disc. from #8813

Download all attachments as: .zip

Change History (8)

comment:1 Changed 12 years ago by Jordan

Damn it! I just accidentally deleted the good images I had with discrepancies, but here's one that I'm encountering right now. These problems are always with 1.2, though I seem to recall it happening with 1.1.x releases as well.

Changed 12 years ago by Jordan

Attachment: display pic discrepancy.png added

Display picture in CL is that of offline account.

comment:2 Changed 12 years ago by Carlos Morales

Felix posted this on #8813 "When you have a contact for which you have two addresses (in this case, MSN and Bonjour), the picture shown on the Contact list can be different than the picture shown when you put your mouse over the contact to get its "contextual informations". Look at the screenshot, it should explain better than me.

This is very, very, very trivial. Just a bit odd."

Changed 12 years ago by Carlos Morales

Attachment: Image 2.png added

Display Pic disc. from #8813

comment:3 Changed 12 years ago by Jordan

Milestone: Needs dev reviewAdium X 1.2.3

#8562 has a less descriptive version of this.

comment:4 Changed 12 years ago by Evan Schoenberg

Milestone: Adium X 1.2.3Adium X 1.2.4

comment:5 Changed 12 years ago by Jordan

Description: modified (diff)

comment:6 Changed 12 years ago by Evan Schoenberg

Milestone: Adium X 1.2.5Adium X 1.3
Resolution: fixed
Status: newclosed

The originally attached screenshots got mangled, and I can't reproduce this in 1.3svn. The display picture discrepancies should be fixed by the image handling rewrite I did in 1.3svn.

Note: See TracTickets for help on using tickets.