Adium

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#8729 closed defect (fixed)

iChat Import Assistant hangs when it tries to convert an alias

Reported by: Thunderforge Owned by: nobody
Milestone: Adium 1.2.1 Component: Adium Core
Version: Severity: normal
Keywords: iChat Import Assistant Cc:
Patch Status:

Description

When using the iChat Import Assistant to import chat transcripts, it hangs if an alias is in the "iChats" folder. iChat Import Assistant will sit there doing nothing (it does not freeze the program though). Moreover, if the user tries to cancel the import, the Assistant will just sit there doing nothing. This appears to happen both with aliases to folders and to files.

Attachments (1)

console.log (268 bytes) - added by Thunderforge 12 years ago.
Console Output, Adium 1.2

Download all attachments as: .zip

Change History (12)

comment:1 Changed 12 years ago by Thunderforge

After a bit more researching, I discovered that the iChat Import Assistant will try to convert ANY type of file. For example, if there is a .txt file in the "iChats" folder, it will try to convert it (and will say it was successful, not sure what to make of that). It will even try to import a .app file (in which case it will try to import the package contents).

The simple workaround for all this is to have the iChat Import Assistant simply check to make sure the file it is trying to import ends with a .ichat extension, signaling that what it is trying to import is indeed an iChat transcript file and not something else.

comment:2 Changed 12 years ago by Jordan

Milestone: Adium X 1.2.2

I assume you can reproduce this with the 1.2 AdiumBeta? As far as I know nothing was changed in the importer.

comment:3 Changed 12 years ago by Evan Schoenberg

Any Console output when this happens?

Changed 12 years ago by Thunderforge

Attachment: console.log added

Console Output, Adium 1.2

comment:4 Changed 12 years ago by Thunderforge

Turns out there was Console output. I went ahead and uploaded the log. The error in the log report was written after the import process began, and no error was created when I clicked "Cancel Import." To make the log, I had one alias in the "iChats" folder and no other files. The same thing happens in both Adium 1.1.4 and Adium 1.2.

comment:5 Changed 12 years ago by Evan Schoenberg

So what sort of alias do you have in iChats, anyways? Is it an alias to a log file, or to another location which iChat was using and which you would expect to be imported by Adium?

comment:6 Changed 12 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

(In [22159]) Resolve aliases passed to BGICLogImportController, and catch exceptions thrown by the NSKeyedUnarchiver/NSUnarchiver when attempting to parse an iChat log and log them rather than crashing. Fixes #8729

comment:7 Changed 12 years ago by Evan Schoenberg

Milestone: Adium X 1.2.2Adium X 1.2.1

comment:8 Changed 12 years ago by Evan Schoenberg

(In [22160]) Merged [22159]: Resolve aliases passed to BGICLogImportController, and catch exceptions thrown by the NSKeyedUnarchiver/NSUnarchiver when attempting to parse an iChat log and log them rather than crashing. Fixes #8729

comment:9 Changed 12 years ago by Thunderforge

The alias I had in the iChats folder was actually to an older application I had for converting iChat transcripts to text (so I'd just take the transcript file I wanted to convert to text and drop it on the alias to convert it). I hadn't thought about aliases to other folders with chats in them, but I suppose somebody might try that. At any rate, you seem to have the problem fixed, so I applaud you for that.

comment:10 Changed 12 years ago by Evan Schoenberg

Milestone: Adium X 1.2.1Adium X 1.2.2

comment:11 Changed 12 years ago by Evan Schoenberg

Milestone: Adium X 1.2.2Adium X 1.2.1
Note: See TracTickets for help on using tickets.