Adium

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#8722 closed defect (fixed)

Problem re-joining public AIM chat

Reported by: dobedobedoh Owned by: nobody
Milestone: Adium 1.2 Component: Service/AIM
Version: Severity: normal
Keywords: aim aol messenger group chat rejoin Cc:
Patch Status:

Description (last modified by Evan Schoenberg)

Description: Trying to join a public chat fails if you have previously joined that chat. E.g. If I join the AIM Genealogy Chat at http://www.aim.com/community/chats.adp, I can initially join and partake in the chat. If I then close down the chat and try to connect later, I am unable to. No errors are displayed on screen. However, the following lines appear in the debug log:

Upon closing the chat

00:42:09: -[CBPurpleAccount leftChat:]: Chat left - something should happen here!
00:42:09: (Libpurple: oscar) Scheduling destruction of FLAP connection of type 0x000e
00:42:09: purple closeChat:genealogychat.1
00:42:09: closeChat: Removed <<<AIChat: 0x98f1ae0>:genealogychat.1>> [{(
    <AIChat: 0x9b636b0>:Genealogy Chat.0
)}]
00:42:09: (Libpurple: oscar) Destroying oscar connection of type 0x000e.  Disconnect reason is 0
00:42:09: (Libpurple: oscar) Disconnected.  Code is 0x0000 and msg is 
00:42:13: (Libpurple: oscar) rate limit cleared (param ID 0x0003): curavg = 4500, maxavg = 4500, alert at 2500, clear warning at 3100, limit at 2000, disconnect at 1500 (window size = 20)

Trying to re-open the chat:

00:42:14: chatWithName Genealogy Chat identifier (null) existing --> <AIChat: 0x9b636b0>:Genealogy Chat.0
00:42:14: chatWithName Genealogy Chat created --> <AIChat: 0x9b636b0>:Genealogy Chat.0

Looks like the line reading 'Chat left - something should happen here' really means it. I'm guessing the previous reference to the chat isn't being destroyed, and as a result, is preventing future attempts to open a chat window.

Attachments (1)

Genealogy chat log.txt (5.4 KB) - added by Andrew Nicols 12 years ago.

Download all attachments as: .zip

Change History (6)

Changed 12 years ago by Andrew Nicols

Attachment: Genealogy chat log.txt added

comment:1 Changed 12 years ago by Evan Schoenberg

Description: modified (diff)

comment:2 Changed 12 years ago by Jordan

Milestone: Adium X 1.2.2

Confirmed.

comment:3 Changed 12 years ago by Jordan

Keywords: messenger group rejoin added
Summary: Problem re-joining public AIM chat.Problem re-joining public AIM chat

comment:4 Changed 12 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

(In [22099]) Added -[AIService normalizeChatName:] which can be used to let a service perform normalization on a chat name so that, for example, "Genealogy Chat" and "genealogychat" are equal in terms of AIM chat rooms (since the AIM server drops captilization and spaces for chat room names). This fixes a condition which could lead to both a leaked AIChat instance and an inability to rejoin the chat after leaving for rooms which return from the server with a different name than initially specified, such as when joining "Genealogy Chat" via a link.

Fixes #8722

comment:5 Changed 12 years ago by Evan Schoenberg

Milestone: Adium X 1.2.2Adium X 1.2
Note: See TracTickets for help on using tickets.