Adium

Opened 13 years ago

Closed 13 years ago

Last modified 11 years ago

#8702 closed defect (fixed)

Certificate alert text does not fit

Reported by: mrjoe Owned by: nobody
Milestone: Adium 1.2.2 Component: Adium Core
Version: Severity: normal
Keywords: Cc:
Patch Status:

Description

One of my jabber account has a certificate which can not be validated. The alert which is displayed doesn't show the whole text. Seems to be a leopard issue as it looks ok on tiger.

Attachments (1)

Afbeelding 1.png (65.3 KB) - added by Jeroen Asselman 13 years ago.
Screenshot showing the problem

Download all attachments as: .zip

Change History (21)

Changed 13 years ago by Jeroen Asselman

Attachment: Afbeelding 1.png added

Screenshot showing the problem

comment:1 Changed 13 years ago by Jordan

Component: Adium UILocalization
Milestone: Adium X 1.2

That language needs the translations to be reset and updated, what language are you using?

comment:2 Changed 13 years ago by Evan Schoenberg

Milestone: Adium X 1.2Waiting on Apple

Actually, that dialogue isn't under our control; it's entirely Apple's dialogue. I've seen that happen -once- and haven't been able to reproduce it; I don't see anything we can do about it.

comment:3 Changed 13 years ago by Evan Schoenberg

Milestone: Waiting on AppleAdium X 1.2.1
priority: normalhigh

Rather, can do about it for 1.2. We should just implement our own dialogue and use the certificate view to display the pertinent information for 1.2.1.

comment:4 Changed 13 years ago by Jeroen Asselman

The language used is Dutch.

comment:5 Changed 13 years ago by masukomi

I can replicate this bug consistently. English language, but dvorak layout (which is treated as a language).

Adium v 1.2 (jan 5)

OS X 10.5.1

comment:6 in reply to:  3 ; Changed 13 years ago by Andreas Monitzer

Replying to evands:

We should just implement our own dialogue and use the certificate view to display the pertinent information for 1.2.1.

I tried that before using Apple's dialog (due to the sheet issue). It was a real b* with 200+ lines of code, didn't look as good as Apple's dialog, couldn't provide all the information their implementation displays, and you couldn't edit the trust settings (I have no idea how to re-implement that).

comment:7 in reply to:  6 Changed 13 years ago by Evan Schoenberg

Replying to am:

Replying to evands:

We should just implement our own dialogue and use the certificate view to display the pertinent information for 1.2.1.

I tried that before using Apple's dialog (due to the sheet issue). It was a real b* with 200+ lines of code, didn't look as good as Apple's dialog, couldn't provide all the information their implementation displays, and you couldn't edit the trust settings (I have no idea how to re-implement that).

Hm. iChat definitely handles it this way, so it's in some way possible, though that says nothing as to how difficult it is :)

comment:8 Changed 13 years ago by Andreas Monitzer

Maybe they just took the (closed-source) code for SFCertificateTrustPanel, modified to their liking and compiled it into iChat.

comment:9 Changed 13 years ago by Evan Schoenberg

Touché.

comment:10 Changed 13 years ago by masukomi

I assume this is probably not a viable solution, but what would happen if you just stuck a few blank lines up above the start of the real text? Would the dialog not just expand downwards and the lines you wanted to be seen get pushed into the realm of the visible?

comment:11 in reply to:  10 Changed 13 years ago by Andreas Monitzer

Component: Localizationlibpurple

Replying to masukomi:

I assume this is probably not a viable solution, but what would happen if you just stuck a few blank lines up above the start of the real text?

The problem is that whenever the sheet does open properly, you'd have a lot of blank lines up there and it'd look just as weird. The real problem is that the sheet doesn't slide all the way done for some very strange reason. I've never seen this behavior anywhere else on Mac OS X.

comment:12 Changed 13 years ago by Andreas Monitzer

done -> down too early in the morning for me ;)

comment:13 Changed 13 years ago by masukomi

"...whenever the sheet does open properly..."

Does this particular sheet ever open properly in Adium? If not, then why not use the proposed solution? Someday Apple will fix whatever it is that's causing this and all you'll have to do is remove a couple blank lines. In the interim people would have a slightly odd looking, but readable, dialog. The alternative seems to be some even uglier code hack that would involve hours of work and would, probably, also have to be removed once Apple fixes whatever's causing this.

comment:14 Changed 13 years ago by Andreas Monitzer

I have it open properly here pretty frequently.

comment:15 Changed 13 years ago by Evan Schoenberg

I delibeately have one account not set to always trust just to keep seeing it. Out of perhaps 250 times seeing it, I've seen it not come all the way out twice.

comment:16 Changed 13 years ago by Evan Schoenberg

Milestone: Adium X 1.2.1Adium X 1.2.2

comment:17 Changed 13 years ago by Lukáš Polívka

I can reproduce this every time I start Adium (1.2.1b1 currently, Leopard 10.5.1).

I have one other Jabber account enabled and one ICQ account disabled.

comment:18 Changed 13 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

(In [22480])

  • Fixed shifted text in the certificate trust panel. The bolded title was never intended to show more than one line of text... the textview itself was shifting up due to attempts to size it to fit in some situations, while the sheet was coming out fine. We now use the informational text - a private method, used by iChat as well to set non-bolded informational text - for the detailed information. This not only fixes #8702 but looks a ton better.
  • Use the independent window rather than the account sheet again. I think the problem was the 0-pixel height of the content view the fake window was using; I've seen 0-sized windows act strangely before. We now use a 1-pixel height, which looks just as good.
  • Set the security policy of the certificate panel to the SSL policy, since that's the Right One. It has a description in the docs as "Basic X509 plus host name verification per RFC 2818" versus "Basic X509-style certificate evaluation" of the Apple Basic we were using before, for whatever that's worth.

comment:19 Changed 13 years ago by Evan Schoenberg

(In [22481]) Merged [22480]:

  • Fixed shifted text in the certificate trust panel. The bolded title was never intended to show more than one line of text... the textview itself was shifting up due to attempts to size it to fit in some situations, while the sheet was coming out fine. We now use the informational text - a private method, used by iChat as well to set non-bolded informational text - for the detailed information. This not only fixes #8702 but looks a ton better.
  • Use the independent window rather than the account sheet again. I think the problem was the 0-pixel height of the content view the fake window was using; I've seen 0-sized windows act strangely before. We now use a 1-pixel height, which looks just as good.
  • Set the security policy of the certificate panel to the SSL policy, since that's the Right One. It has a description in the docs as "Basic X509 plus host name verification per RFC 2818" versus "Basic X509-style certificate evaluation" of the Apple Basic we were using before, for whatever that's worth.

comment:20 Changed 11 years ago by Zachary West

Component: libpurpleAdium Core

Removing 'libpurple' component.

Note: See TracTickets for help on using tickets.