Adium

Opened 12 years ago

Closed 9 years ago

#8657 closed defect (cantreproduce)

2 pixel border at bottom of the chat window

Reported by: julians Owned by: evands
Milestone: Component: Adium Core
Version: Severity: minor
Keywords: Cc:
Patch Status:

Description

The border at the bottom of the chat window is 1 px too tall. See screenshot.

Attachments (2)

Picture 1.png (5.3 KB) - added by julians 12 years ago.
stillthere.png (5.3 KB) - added by julians 12 years ago.

Download all attachments as: .zip

Change History (22)

Changed 12 years ago by julians

Attachment: Picture 1.png added

comment:1 Changed 12 years ago by julians

Oh, and it’s on Leopard. And I had the same issue in the versions before it (1.1.x), at least on Leopard.

comment:2 Changed 12 years ago by Jordan

Milestone: Adium X 1.2

I can see this as well - appears thicker than the rest of the window edges.

comment:3 Changed 12 years ago by Jordan

Hmm... when zooming in on this it seems to actually be 1px ... and identical to the side borders. It is darker than the sides - perhaps that's the problem?

comment:4 Changed 12 years ago by julians

Na, it’s a two-pixel border. The borders on the side and at the bottom are actually part of the shadow. (You can try that for yourself in Interface Builder. Just remove the shadow from a window and the borders go away.) The upper part of the two-pixel border must be drawn by Adium, you just need to remove it.

comment:5 Changed 12 years ago by Jordan

Milestone: Adium X 1.2Good idea for "later"

This exists because the text entry border is there as well as the window border. It does not appear when the tabs are on the top, and when tabs are on the side, it is only 2 pixels for the width of the text entry area. Not blocking 1.2 on this and I'm not convinced this is actually a 'bug' since both borders should really be there...

comment:6 Changed 12 years ago by julians

But it looks absolutely horrible? :(

comment:7 Changed 12 years ago by Evan Schoenberg

Both borders shouldn't be there...

comment:8 Changed 12 years ago by Evan Schoenberg

Sorry, hit submit too quickly.

...if in fact it's both borders. We can move the view in the window down a pixel to suppress one of them if that's the case.

comment:9 Changed 12 years ago by Jordan

Milestone: Good idea for "later"Adium X 1.2.1
Version: 1.2b51.2

comment:10 Changed 12 years ago by Evan Schoenberg

Owner: changed from nobody to Evan Schoenberg
Status: newassigned

comment:11 Changed 12 years ago by Evan Schoenberg

Resolution: fixed
Status: assignedclosed

(In [22302]) Hide the PSMTabBarControl entirely after it hides itself, and be sure it's not hidden after it shows itself. This fixes a one-pixel extra border we were seeing - the outline of the control? A shadow thrown by it? - in the region of the hidden tab bar. Fixes #8657.

comment:12 Changed 12 years ago by Evan Schoenberg

(In [22303]) Merged [22302]: Hide the PSMTabBarControl entirely after it hides itself, and be sure it's not hidden after it shows itself. This fixes a one-pixel extra border we were seeing - the outline of the control? A shadow thrown by it? - in the region of the hidden tab bar. Fixes #8657.

comment:13 Changed 12 years ago by Evan Schoenberg

Milestone: Adium X 1.2.1Adium X 1.2.2

comment:14 Changed 12 years ago by Evan Schoenberg

Milestone: Adium X 1.2.2Adium X 1.2.1

Changed 12 years ago by julians

Attachment: stillthere.png added

comment:15 Changed 12 years ago by julians

It’s still there, as you can see in the screenshot.

comment:16 Changed 12 years ago by Jordan

Milestone: Adium X 1.2.1Adium X 1.2.2
Resolution: fixed
Status: closedreopened

comment:17 Changed 12 years ago by Evan Schoenberg

Milestone: Adium X 1.2.2Patches welcome

I don't see any cause of this, and I don't personally notice it. Perhaps someone else wants to take a shot.

comment:18 Changed 12 years ago by Carlos Morales

comment:19 Changed 11 years ago by Robert

Milestone: Patches welcomeAdium bugs
priority: normallowest
Severity: normaltrivial

comment:20 Changed 9 years ago by Robert

Milestone: Adium bugs
Resolution: worksforme
Status: newclosed

I don't see this in 1.4b19. Let us know if are still experiencing this.

Note: See TracTickets for help on using tickets.