Adium

Opened 15 years ago

Closed 15 years ago

#860 closed enhancement (fixed)

Allow drag and drop of text, URL's, and files onto contacts on contact list

Reported by: anonymous Owned by: kbotc
Milestone: Adium X 1.0 Component: Adium UI
Version: Severity: normal
Keywords: Cc:
Patch Status:

Description (last modified by adamiser)

I'd like to be able to drag some text from safari and drop it on a buddy to open an IM window (if not open already), and send the message. (If that makes you guys nervous, it could just insert the message into the text box, and require the user to press enter to send.)

I'd like to be able to drag a URL similarly, so it will send the page name as a link, in an IM.

I'd also like to be able to drag text which is a valid screenname for any of the open accounts, in between my other contacts, like when re-ordering buddies, to open the add-buddy dialog.

Change History (4)

comment:1 Changed 15 years ago by adamiser

Description: modified (diff)

Removed drag to send file, since it is already covered by #558

comment:2 Changed 15 years ago by Colin Barrett

field_haspatch: 0
Owner: changed from nobody to kbotc

comment:3 Changed 15 years ago by David Smith

Milestone: Adium X 1.0

Marked #558 as a dupe of this.

comment:4 Changed 15 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

kbotc implemented this in [14670].

Note: See TracTickets for help on using tickets.