Adium

Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#8445 closed defect (fixed)

& in URLs over-escaped to &

Reported by: deeaytch Owned by: nobody
Milestone: Adium 1.2.1 Component: Adium Core
Version: Severity: normal
Keywords: Cc:
Patch Status:

Description

Send yourself (or anyone else, or have someone send you) an URL with an ampersand in it. Say, http://example.com/this&that

Click on it in the message window. Works fine (in this case, a 404, but you got sent to the right place). Close the message window, and View Chat Transcripts. Works fine again.

Re-open the message window (assuming "Show recent messages in new chats" is checked in preferences, and this message is still recent enough to be shown). Click. You'll get sent to http://example.com/this&that -- oops.

Change History (8)

comment:1 Changed 13 years ago by Jordan

Milestone: Adium X 1.2.1

Indeed. Confirmed on 1.2svn r21721

This seems to be occuring when it pulls the recent history from the chat logs (or buffer?) and displays it. I was using modern bubbling when I tested it.

comment:2 Changed 13 years ago by Evan Schoenberg

This looks just like #6850

comment:3 Changed 13 years ago by Evan Schoenberg

Nm, it's the opposite.

comment:4 Changed 13 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

(In [22266]) Unescape the HREF attribute's text before passing it to NSURL which does not expect XML/HTML-escaped entities. Fixes #8445

comment:5 Changed 13 years ago by Evan Schoenberg

(In [22267]) Merged [22266]: Unescape the HREF attribute's text before passing it to NSURL which does not expect XML/HTML-escaped entities. Fixes #8445

comment:6 Changed 13 years ago by Peter Hosey

(In [22275]) Merged r22274 from trunk: -stringByUnescapingFromXMLWithEntities: takes an object instance, not a general pointer. Thus, the correct constant is nil, not NULL.

I forgot to mention this part previously: Refs r22266 on trunk; refs r22267 on this branch; refs #8445.

comment:7 Changed 13 years ago by Evan Schoenberg

Milestone: Adium X 1.2.1Adium X 1.2.2

comment:8 Changed 13 years ago by Evan Schoenberg

Milestone: Adium X 1.2.2Adium X 1.2.1
Note: See TracTickets for help on using tickets.