Adium

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#8353 closed defect (fixed)

Time stamp for status messages cut off in Stockholm chat window

Reported by: gshapiro Owned by: jas8522
Milestone: Adium 1.2.1 Component: Adium Core
Version: Severity: normal
Keywords: Cc:
Patch Status:

Description

When using Stockholm as the chat window style and your time stamp format (Advanced -> Messages -> Time stamp format) is set to 12:34:56, the seconds in the time stamp are cut off in the date display. See the first line of the attached JPG for an illustration. Note the time is 17:31:1?.

Attachments (2)

ChatWindow.jpg (49.0 KB) - added by Gregory Shapiro 12 years ago.
Example Stockholm window showing cut off time stamp
adium.tiff (11.4 KB) - added by Erin Dalzell 12 years ago.

Download all attachments as: .zip

Change History (28)

Changed 12 years ago by Gregory Shapiro

Attachment: ChatWindow.jpg added

Example Stockholm window showing cut off time stamp

comment:1 Changed 12 years ago by Jordan

Milestone: Good idea for "later"
Summary: Time stamp cut off in Stockholm chat windowTime stamp for status messages cut off in Stockholm chat window

comment:2 Changed 12 years ago by Erin Dalzell

This happens even when a non-custom time format is used now with 1.2b8.

comment:3 Changed 12 years ago by Jordan

Milestone: Good idea for "later"Needs feedback from users
pending: 01

Change your minimum font size in the advanced message window preferences...

I can't reproduce this - it fits perfectly if I use the minimum font size of 9 (this setting overrides default font settings and seems to be the only place that can do that in places like the chat header and the status info bubbles).

Changed 12 years ago by Erin Dalzell

Attachment: adium.tiff added

comment:4 Changed 12 years ago by Erin Dalzell

My font size was already set to 9. I have attached the issue. See the cutoff text in the Jan 1 initial timestamp?

comment:5 Changed 12 years ago by username2

Beginning with 1.2 (did not have this problem in any previous versions) I am having a similar problem with Stockholm, though not identical to either of the images posted above. Here's an ASCII rendering of a message window in 1.2:


|MyScreenName 19:0 | |What I said 2 | | |


i.e. Part of the time gets cut off from displaying on the right, and displays on the next line instead.

I have not changed my font size from what I used in the previous version of Adium. (Lucida Grande 12)

comment:6 Changed 12 years ago by username2

Sigh. It reformatted my brilliant ASCII artwork so it doesn't illustrate anything at all. :( But hopefully you can get the idea from my description.

comment:7 Changed 12 years ago by Jordan

Milestone: Needs feedback from usersAdium X 1.2.1
Owner: changed from nobody to Jordan
pending: 10
Status: newassigned

Yes I get the idea. I should be able to fix both of these for 1.2.1 or 1.2.2

comment:8 Changed 12 years ago by Jordan

username2: are you on 10.5.1 or 10.4.11? Could you also tell me what time formatting settings you're using? Just to be sure I got this right, could you upload a screenshot?

Thanks :)

comment:9 Changed 12 years ago by beams

I believe this has been fixed by the author in v.4.2 of the Stockholm Message style posted here: http://www.adiumxtras.com/index.php?a=xtras&xtra_id=1760

He has also added time stamps on rollover. It just need to be updated in the client.

comment:10 Changed 12 years ago by Erin Dalzell

I just tried it and I see the same issue, so I don't think that fixes the issue.

comment:11 Changed 12 years ago by Jordan

Nonetheless, I should definitely update to the new version before making any changes - excellent point :)

comment:12 in reply to:  10 Changed 12 years ago by beams

Replying to edalzell:

I just tried it and I see the same issue, so I don't think that fixes the issue.

It's definitely fixed for me with v4.2. You can't just click "install" from the xtras page because the default Stockholm message style overrides the update. You have to click "download", and then replace the message style inside the app "Adium/Content/Resources/Message Styles/Stockholm.MessageStyle"

comment:13 Changed 12 years ago by Jordan

Yes indeed, this has been fixed for v4.2. We should merge that new version for 1.2.1

comment:14 Changed 12 years ago by Jordan

Though, the username and timestamp header for each message is not fixed in 4.2 - so we need to remember to re-apply the pixel font size to this style for both the time and username

comment:15 in reply to:  14 Changed 12 years ago by matthew Bice

Replying to jas8522:

Though, the username and timestamp header for each message is not fixed in 4.2 - so we need to remember to re-apply the pixel font size to this style for both the time and username

Hey, this is the author. How can I help? Not sure what you mean my username and timestamp for each message. Are you talking about the rollover timestamps?

comment:16 Changed 12 years ago by Jordan

Hi iheartny:

Just a quick fix that went in to 1.2. You can see the problem by going to the messages preference pane, choose "set font" and increase the size. You will notice that the titles of each message (where it shows the user ID and time) get larger and either expand beyond the size of the 'container' or underneath it (due to overflow: hidden).

We changed it so that those two classes had a fixed font size in pixels (if you use point, it will be different for each font used, but pixels will keep every font to the same size). This way only message text can increase, and not the user ID or times.

comment:17 Changed 12 years ago by matthew Bice

Ah, is there any documentation on how to set the header and timestamp to fixed size so that it won't change? Or can I do this with regular CSS?

Sidenote: Strangely, when I increase the font size to Lucida Granda 14 (or any other font for that matter) the header and timestamp change to a different Serif font other that Lucida Grande. Is this a bug?

comment:18 Changed 12 years ago by Jordan

We just did it with regular CSS - specified in the respective classes.

There is another ticket open about that Serif issue - it appears to be a bug.

comment:19 Changed 12 years ago by matthew Bice

Updated the CSS on the xtras page. v4.3.

comment:20 Changed 12 years ago by matthew Bice

I just realized that the status message was affected by the custom font size tool as well, and updated v4.3 again this morning.

comment:21 Changed 12 years ago by Erin Dalzell

Do I still have to install it like beams said?

comment:22 Changed 12 years ago by matthew Bice

either that, or you can just remove "Adium/Content/Resources/Message Styles/Stockholm.MessageStyle" from the app and then you can install it normally.

comment:23 Changed 12 years ago by Evan Schoenberg

Resolution: fixed
Status: assignedclosed

(In [22256]) Updated to Stockholm message style 4.3. Fixes #8353

comment:24 Changed 12 years ago by Evan Schoenberg

(In [22257]) Merged [22256]: Updated to Stockholm message style 4.3. Fixes #8353

comment:25 Changed 12 years ago by Evan Schoenberg

Milestone: Adium X 1.2.1Adium X 1.2.2

comment:26 Changed 12 years ago by Evan Schoenberg

Milestone: Adium X 1.2.2Adium X 1.2.1
Note: See TracTickets for help on using tickets.