Adium

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#8234 closed defect (fixed)

User action ignored... Preferences > Messaging

Reported by: a1iveandwell Owned by: Catfish_Man
Milestone: Adium 1.2.1 Component: Message View
Version: Severity: normal
Keywords: Message style, variant, preferences Cc:
Patch Status:

Description

Hello, using Adium 1.1.3/built 9-30-07, OS X 10.5.0 patched up to 10-31-07. AIM username logged in. Problem persists after app restart and OS reboot.

To reproduce: navigate to preferences, messages. change to a new message style. The first variant you change to from the default is expressed in the message box preview above and in actual message boxes, but any more changes to the variant drop down are ignored until the message style is changed to something different. Effectively, only one change of message style variant is processed until you choose a new message style.

Thank you for your time; keep up the good work, fellas.

Change History (16)

comment:1 Changed 12 years ago by Steve

My apologies, forgot to add that this has been tested with default themes included with this build, and a number of adiumxtras.com themes including "1337" and "strongbad", both installed using the Install link on the page and downloading and invoking the install manually.

comment:2 Changed 12 years ago by Renee

Hmm that sure is odd. I can confirm this bug. I think it's something to do with Leopard messing things up. I was using this version of Adium (1.1.3) before I installed Leopard and I know this bug wasn't there then. So this bug happens with the change over to Leopard.

comment:3 Changed 12 years ago by Jordan

Milestone: Adium X 1.1.4

comment:4 Changed 12 years ago by Zachary West

This isn't a Leopard-specific issue: I've run into it on Tiger (#7963). I expect Leopard does something to bring it to light, however.

comment:5 Changed 12 years ago by Evan Schoenberg

Owner: set to David Smith

The obj-c side of things seems right; perhaps the setStylesheet() function in Template.html is to blame? David, what do you think?

comment:6 Changed 12 years ago by Evan Schoenberg

Milestone: Adium X 1.1.4Adium X 1.2.1

comment:7 Changed 12 years ago by Evan Schoenberg

(In [21507]) Disabled live variant updating via an #if in AIWebKitMessageViewController.m. This resolves the current issue in the message preferences with changing variants by forcing a full reload with each change; it's therefore a workaround, not a fix, which carries a speed tradeoff. Refs #8234

comment:8 Changed 12 years ago by Evan Schoenberg

(In [21509]) Merged [21507]: Disabled live variant updating via an #if in AIWebKitMessageViewController.m. This resolves the current issue in the message preferences with changing variants by forcing a full reload with each change; it's therefore a workaround, not a fix, which carries a speed tradeoff. Refs #8234

comment:9 Changed 12 years ago by The Doctor What

In beta 3, the variants is one click behind what the style is. If you set the style twice to the style you want then the variant list is updated correctly. (in Leopard).

Ciao!

comment:10 Changed 12 years ago by Jordan

I found that after the above changes were made by Evan to get it to work properly I had to change to each message style and choose any other variant than what it is currently on. After doing so once I never encountered this problem again. I'm also using leopard with Beta 3.

comment:11 Changed 12 years ago by Evan Schoenberg

I can't reproduce this using a fresh set of Adium preferences. docwhat, could you please try the steps at Preferences:Troubleshooting Preferences and see if you can reproduce it in the same situation?

comment:12 in reply to:  11 Changed 12 years ago by The Doctor What

Replying to evands:

I can't reproduce this using a fresh set of Adium preferences. docwhat, could you please try the steps at Preferences:Troubleshooting Preferences and see if you can reproduce it in the same situation?

This is with a fresh set of preferences. I had reset my preferences to help troubleshoot another bug (bug #8610) and as I went through the preferences to set things back the way I like it, I discovered this bug.

I can reset them again, but if this feature is that sensitive, then maybe something else is going on?

Ciao!

comment:13 Changed 12 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

(In [22304])

  • Use an array for keeping track of observers. This means that observers which register earlier will be notified earlier; a plugin will therefore typically be notified before its constituent parts or created objects. This fixes #8234, because the webkit plugin needs to update its prefs before the webkit controllers do. A priority/sorting system could be added to allow specification of the order if needed, but it isn't at this time.
  • Retain/release protection on the preferences dictionary passed to observers, as it's possible that a change in preferences could invalidate the dictionary otherwise partway through the enumeration of observers.

comment:14 Changed 12 years ago by Evan Schoenberg

(In [22305]) Merged [22304]:

  • Use an array for keeping track of observers. This means that observers which register earlier will be notified earlier; a plugin will therefore typically be notified before its constituent parts or created objects. This fixes #8234, because the webkit plugin needs to update its prefs before the webkit controllers do. A priority/sorting system could be added to allow specification of the order if needed, but it isn't at this time.
  • Retain/release protection on the preferences dictionary passed to observers, as it's possible that a change in preferences could invalidate the dictionary otherwise partway through the enumeration of observers.

comment:15 Changed 12 years ago by Evan Schoenberg

Milestone: Adium X 1.2.1Adium X 1.2.2

comment:16 Changed 12 years ago by Evan Schoenberg

Milestone: Adium X 1.2.2Adium X 1.2.1
Note: See TracTickets for help on using tickets.