Adium

Opened 12 years ago

Closed 11 years ago

Last modified 10 years ago

#8082 closed enhancement (fixed)

Allow the user to disable XMPP window-closed notifications

Reported by: Sabrejack Owned by: nobody
Milestone: Adium 1.4 Component: Service/Google Talk
Version: 1.4hg Severity: normal
Keywords: Cc:
Patch Status:

Description

I would like to a see a privacy option that allows me to suppress XMPP "user has left the conversation" notifications to other people. It would also be nice to suppress seeing these messages from other people since certain people I chat with have a habit of closing their window after almost every reply.

Change History (26)

comment:1 Changed 12 years ago by jas8522

  • Milestone set to Adium X 1.4

If this is to be done, it may as well be done for 1.4 - events overhaul. Even though this isn't the same type of event (notification dialog/growl/in CL, etc. it's still in the same overall category.

It sounds like a good preference to have - at the very least the one to mute other contacts 'left conversation' notification since I am one of those people that always closes the window ;)

To avoid cluttering prefs, muting of your own conversation status could be within Jabber/XMPP's account prefs, and receiving other people's notification could be added as an event in the event pane... though that would also require placing an 'show inline with messages' option to the "actions" dropdown.

comment:2 Changed 12 years ago by mtrichardson

I would definitely love this option. I get guilt tripped into leaving windows open all day so as not to offend certain people. (not really, but it sometimes feels that way)

comment:3 Changed 12 years ago by wmertens

Yes, please implement this!

I have to leave my window open because I don't want to seem rude and it clutters my desk, making it harder to work.

I'm halfway tempted to downgrade adium just because of this.

comment:4 Changed 12 years ago by djmori

comment:5 Changed 11 years ago by kenlu

It seems the Pidgin team solved this by adding a "Close IMs immediately" checkbox that lets you persist conversations so as not to send the end conversation notice.

http://developer.pidgin.im/ticket/1384

Perhaps Adium could do something similar?

comment:6 Changed 11 years ago by Ethan

Definitely, please include an option to not advertise me closing a window. What I do on my computer should not be sent out until I tell adium to do so. Same as the option to hide 'typing' notifications.

As for the second part, I don't care much about suppressing these messages from others if they have such notifications on. It could be an option, but I don't think it should default to suppressing them.

comment:7 Changed 11 years ago by cbarrett

Ethan: There is already an option to not broadcast typing notifications. Go to the Accounts pane, and double click an account to configure it. Then click on the "Privacy" tab. You'll find the option there.

comment:8 Changed 11 years ago by Ethan

I am aware, I was using that as an example of a good existing control. This issue should be treated the same way; there should be an option to send or not send the 'left the conversation' notifications, just as there is for typing.

comment:9 Changed 11 years ago by stemcel

I sent an email to feedback@adium, but now that I've acquired a Trac account I'll post here as well, just for the record.

I'm massively in favor of not seeing or sending these broadcasts, or at least making it optional. What used to just be tidiness on my part is now rudeness. I have to deal with the clutter of IM windows, hide them and miss conversations, or close them and appear rude, especially since most people I chat with don't have Adium. The only time they get that "X has left the conversation" notification is when I close their window.
There's no reason I should have to make that choice.

In the mean time I'm trying out Psi, Pidgin, and Google Talk through virtualisation.

In the spirit of things I'll add a notification that at least one Adium user has left the conversation.

comment:10 Changed 11 years ago by stemcel

Just re-read my last post. I should make it clear that I think Adium is fantastic. It made my list of things to get the second I got a Mac (along with Quicksilver and Growl). It was a short list, congrats to all who work on it for making such a tasteful IM client.

Like I said most of my contacts use Jabber (google talk) without Adium. This change broke my ability to interact with other users of the service seamlessly. I'll keep checking back to see if it ever changes.

comment:11 Changed 11 years ago by Robby

  • Milestone changed from Adium 1.4 to Good idea for "later"

comment:12 Changed 11 years ago by Ethan

augh, no, don't do that! this is so badly needed. why is it changed to the never-actually-going-to-happen "later" milestone? this is one of the most annoying things about adium that exist right now.

comment:13 Changed 11 years ago by Robby

Because so far nobody has volunteered to do this. Feel free to submit a patch.
By principle, we now only put tickets into milestones which a specific developer actually plans to fix. Perhaps one of them does but I don't know. Consider this a temporary milestone. :)

comment:14 Changed 11 years ago by wwwluckyro

Well I hope one dev will find the time for this.

I'm tired of friends complaining that I closed the conversation and that I am rude and so on.

Maybe one can offer a hack to disable this, until something official? :)

comment:15 follow-up: Changed 11 years ago by zacw

You can disable it by compiling your own libpurple which does not send the "gone" message when the conversation is closed. You can also disable typing notifications, which will prevent the message from being sent. Alternatively, you could add a new preference to libpurple to add a secondary preference specifically for this, which you could then create an Adium UI hook for it in the account privacy preference pane.

comment:16 Changed 11 years ago by daretruth

I agree with mtrichardson, ethan, stemcelm etc. This would be a very helpful feature. The message seems rude, and is inaccurate for users who routinely close their windows to keep their desktop tidy.

(and I know for a fact that "left the conversation" has caused discord between significant others :)

Thank you,

-Jason

comment:17 Changed 11 years ago by funtaff

I also agree. It was something I was slightly more than mildly annoyed with before, but reading the (lack of) response here inspires me to just use another IM client instead.

Adium is one of my top three apps that have forced me to always use a Mac =D. I really appreciate OSS work, but one of my pet peeves is when features are added that only apply to the minority and that aren't optional (as in, preference not created to control them).

This is one of those features.

-David

comment:18 in reply to: ↑ 15 Changed 11 years ago by jas8522

  • Milestone changed from Good idea for "later" to Waiting on libpurple
  • Version changed from 1.1.3 to 1.4svn

Replying to zacw:

You can disable it by compiling your own libpurple which does not send the "gone" message when the conversation is closed. You can also disable typing notifications, which will prevent the message from being sent. Alternatively, you could add a new preference to libpurple to add a secondary preference specifically for this, which you could then create an Adium UI hook for it in the account privacy preference pane.

In which case, this relies upon #p4916

Once that ticket is closed, then we'll likely get a UI hook for it added in to Adium, and if not, then I bet we'll be hearing about it in this ticket!

comment:19 Changed 11 years ago by zacw

  • Status changed from new to closed

Closing all "waiting on libpurple" tickets. There's no reason to keep them around as open, and largely go ignored anyway. File a ticket at http://developer.pidgin.im for any functionality you want to see.

comment:20 Changed 11 years ago by anonymous

  • Milestone Waiting on libpurple deleted

Milestone Waiting on libpurple deleted

comment:21 Changed 11 years ago by zacw

  • Milestone set to Adium 1.4
  • Status changed from closed to new

In im.pidgin.adium d426726115c911c7b6006becc903308f988dd7cb, I removed this annoying message.

comment:22 Changed 11 years ago by zacw

  • Resolution set to fixed
  • Status changed from new to closed

comment:23 Changed 10 years ago by Robby

Ticket #13015 has been marked as a duplicate of this ticket.

comment:24 Changed 10 years ago by chrisfong

If this ticket is closed, how do I go about using this feature? I do not see this customization option anywhere in Adium's preferences.

comment:25 Changed 10 years ago by Robby

The notification has been removed, there is no setting.

comment:26 Changed 10 years ago by pellepim

The notification has not been removed in production versions. As of version 1.3.8: when I close my window, whoever I am talking to get's the message that "XXX has left the conversation".

In the beta versions however it has been removed. You can download betas here: http://beta.adium.im/

Note: See TracTickets for help on using tickets.