Adium

Opened 12 years ago

Closed 12 years ago

Last modified 9 years ago

#8051 closed defect (cantreproduce)

Hidden Contact List disappears on switch to dual monitor

Reported by: bjhomer Owned by: nobody
Milestone: Adium 1.3 Component: Adium UI
Version: Severity: normal
Keywords: Cc:
Patch Status:

Description

If the contact list is set to hide on screen edges and a second monitor is added on that side of the screen, the contact list is no longer accessible.

Steps to reproduce:

  1. Set Preferences -> Advanced -> Window Handling -> On Screen Edges
  2. Hide the contact list on the right side of the screen
  3. Plug in an external monitor which is set to appear on the right side of the screen
  4. Note that the contact list should now be in the middle of the extended screen, but is not visible

The contact list can be forced to reappear by pressing Command-/ a few times (which hides and re-shows the Contact List)

Change History (8)

comment:1 Changed 12 years ago by Jordan

Milestone: zzzDuplicate tickets
Resolution: duplicate
Status: newclosed

#6471. This seems to be a particular incarnatiton of that bug that at least makes it reproducible!

comment:2 Changed 12 years ago by Jordan

Milestone: zzzDuplicate ticketsAdium X 1.3
Resolution: duplicate
Status: closedreopened

This is now fixed either with Leopard or 1.3 or both. Any windows that are offscreen when a new monitor is plugged in are then brought back onscreen and do not hide on the side where the secondary monitor resides.

comment:3 Changed 12 years ago by Jordan

Resolution: worksforme
Status: reopenedclosed

comment:4 Changed 12 years ago by BJ Homer

Still there in Leopard, so it's gotta be 1.3.

comment:5 Changed 11 years ago by Simon Fransson

This (or something similar) is still a present in Adium 1.3.2. I'm using a MacBook Pro with external Cinema Display, and Adium set to hide on the right side of the Cinema Display, which is also my main monitor. The MacBook Pro display extends the desktop on the left side. When disconnecting the Cinema Display the Adium contact list is often moved in the middle of the display or hidden. The problem mostly occurs when reconnecting the Cinema Display, which makes Adium invisible.

comment:6 Changed 10 years ago by Jan Vincent

Same behavior. Using Adum 1.4b17 on Snow Leopard 10.6.2. Main display is the external.

comment:7 in reply to:  6 Changed 10 years ago by Jordan

Replying to jvliwanag:

Same behavior. Using Adum 1.4b17 on Snow Leopard 10.6.2. Main display is the external.

I followed the *exact* steps to reproduce in the description of this ticket. When I plugged in my external monitor, the contact list popped out, and remained unhidden (beside the edge of the screen it was hidden on). Please create a new ticket, with a video capture of the event occurring, exact steps to reproduce, and all other details requested by ReportingBugs.

comment:8 Changed 9 years ago by Daniel Johnson

I still have this happen in Snow Leopard 10.6.7 and Adium 1.4.1. I will try to get a screen capture of it happening to upload. I haven't tried the cmd-/ trick to hide/show it, that sounds much easier than what I do.

Note: See TracTickets for help on using tickets.