Adium

Opened 15 years ago

Closed 12 years ago

Last modified 11 years ago

#80 closed enhancement (fixed)

Chat invitation event

Reported by: habnabit Owned by: anybody
Milestone: Adium 1.2 Component: Adium Core
Version: Severity: normal
Keywords: Cc:
Patch Status:

Description

There doesn't appear to be an event notification for when you receive a request to join a multi-user chat on any protocol.

Change History (27)

comment:1 Changed 15 years ago by Chris Forsythe

Milestone: Adium X 0.90
priority: normallow

comment:2 Changed 15 years ago by David Smith

Milestone: Adium X 0.90 (Old)Adium X 0.90

comment:3 Changed 14 years ago by David Smith

Milestone: Adium X 1.0Adium X 1.5

Group chat -> 1.5

comment:4 Changed 14 years ago by netsonli

I do hope you make this a higher priority, it's a real pain to miss chat invites.

comment:5 Changed 14 years ago by mikesela@…

This is an important feature. Having it as a "Low" priority seems crazy to me. An invitation to a Group chat is MORE important than many of the other things that have event notifications. In this case a GROUP of people want to chat with me, not just one.

comment:6 Changed 14 years ago by anonymous

Yes, this needs to be a higher priority. I'm about to stop using Adium because I can't afford to miss any more group chats!

comment:7 Changed 14 years ago by Zachary West

field_haspatch: 0

Threatening to not use adium is counterproductive and only makes your comments ignored.

comment:8 Changed 14 years ago by adium@…

The conference notifications do work, but instead they only appear behind open (seemingly ALL) windows and there is no sound attached to the event.

This is lagging at least 6 months behind the first report. I assume the priority is low because it is not as popular as other features However, I also assume that there is not much development time involved in moving a notification window to the top of the window stack.

This is an important feature and not just a toy. I engage in IM conferences for certain company meetings. I like Adium and appreciate the effort put into it. It seems like there's an update every time I logon. So can someone please assist?

comment:9 Changed 14 years ago by Robert Boyce

I think that this change is very important. I can't count the number of times I have missed chat invitations because there was another window covering up the center of my screen.

comment:10 Changed 14 years ago by David Smith

Group chat is being focused on for 1.5. It doesn't even work properly in 0.8x half the time.

comment:11 Changed 14 years ago by Thigmo

Is the modification to pop the notification alert to the front that difficult so difficult that it can't be at least patched until 1.5? I can see how this could be a deal-breaker for some. A group of people I do volunteer web work with rely on Yahoo group chat, and the Yahoo client is very buggy with group chat. I've never had any problem with Adium with group chats, except for missing invitations.

comment:12 Changed 14 years ago by Evan Schoenberg

Anybody who is interested can submit code to Adium. If a developer becomes interested, or someone sends in a good patch implementing the feature, we'll be happy to have this before 1.5.

comment:13 Changed 14 years ago by woode_31794@…

Okay, I'll bite! :D

Checked out a copy of the Adium source and I looked at the code. If I can figure this out (never worked on a project this big before), maybe I can get a usable patch ready before 1.5. Cross your fingers, folks.

woode_31794@… aka Thigmo

comment:14 Changed 14 years ago by rcobleigh@…

This is a very important feature! It is a problem I encounter nearly every day and it definitely impacts my ability to communicate effectively. I look forward to the fix!

comment:15 Changed 14 years ago by rdi at mac dot com

I'd also like to see this...the people I have group chats with usually have to msg me to say they've invited me to a group chat...

Also, #3521 seems to be a duplicate of this.

comment:16 Changed 14 years ago by zathras@…

This is HUGE for me ... I'm in a corporate (well, corporate side of academic) environment, trying to spread the Adium word ... just discovered this today that not only is there no provision for event notification, but that it's buried behind other windows! I'm putting this here because I just got in trouble for missing two people's group chat invites to me for an important chat.

If I were a programmer and not a System Administrator, I'd gladly try to fix it... sorry I can't be of much help there.

One possible clue to those who do work on it (aside from buying you the best beer on the menu or other beverage of your choice should we ever meet) -- notification of new emails looks almost identical to what's needed here, and though I've not tested that feature, it can have events associated.

comment:17 in reply to:  10 Changed 14 years ago by ninja@…

Replying to catfish_man:

Group chat is being focused on for 1.5. It doesn't even work properly in 0.8x half the time.

I'll second the importance of this -- and will someone please explain why it's so difficult to implement? I can understand putting off a focus on group chat, but it seems like this would be a one-line change -- you already pop up a window, just add the notification hook there, and add a new notification to the list...

Is there a patch anywhere yet? If not, I might do it myself. Any progress, Thigmo?

Definitely a deal-breaker. When people threaten not to use your software, that should be a red flag that it's important. Again: Why would this be more than a one or two line change?

comment:18 Changed 14 years ago by David Smith

We have 600k users... people threaten not to use the app near-constantly, and for a variety of wacko reasons. This, however, is a perfectly reasonable request. A patch would most definitely be accepted for it, and I've considered looking into it myself, but haven't had time.

comment:19 Changed 14 years ago by Evan Schoenberg

Optimally, you'll need to modify libgaim's server.c serv_got_chat_invite() to use a new, specific callback to the ui_ops for inviting the user to a group chat. You'll then set up the callback adium side to call on some central method -- a new method on the chatController probably -- specifying where to notify when the user makes a choice.

Modifying the joscar code to work similarly will be more trivial; its code in RAFJoscarAccount's - (void)inviteToChat:(NSString *)name fromContact:(NSString *)uid withMessage:(NSString *)message inviteObject:(id)invite can form the basis for the chatController method, and it can simply call that.

The chatController should register the event (with the contactAlertsController) and should generate it when the invitation method is called.

comment:20 Changed 14 years ago by ninja@…

Ok, newbie question: Why are we even touching this library code?

Presumably Joscar, LibGaim, and any others have to hit Adium code somewhere, right? I mean, the chat invitation does pop up a dialog box, although it's completely silent and in the background. Are you telling me joscar and libgaim are drawing those dialogues by themselves? (I mean, they do have the duck logo on them...)

Time to dig deeper...

comment:21 Changed 14 years ago by Evan Schoenberg

joscar is very simple in this regard, as I mentioned. The problem with libgaim is that it's sending a generic "display the following text and buttons, and tell me the response." It needs to be sending a "invite this account to a group chat with this name" and letting the UI actually construct whatever it wants to display.

comment:22 Changed 14 years ago by Chris Forsythe

Reporter: changed from habnabit@… to Aaron Gallagher

Changing submitter field so that she is no longer subscribed. This should be all that is needed.

This is per request of the person who filed the ticket

comment:23 Changed 12 years ago by Mathew Burrack

I would like to add another vote for requesting this feature. I need it for my corporate environment as well, where we have weekly Yahoo meetings, and unless Adium is the active app, I never see the notification until much later when I switch to the app. Is there a path for the plugins to send a proper notification, and the plugins just don't use it yet, or does the pathway need to be added as well?

comment:24 Changed 12 years ago by Jordan

Milestone: Adium X 1.5zzzDuplicate tickets
Patch Status: None
pending: 0
Resolution: duplicate
Status: newclosed

#7923. This will be covered by #7923 which is projected for Adium 1.4

Please do not use #7923 to make additional requests for this feature.

comment:25 Changed 12 years ago by Zachary West

Resolution: duplicatefixed

(In [21567]) Add a "Invites you to a group chat" event. Jabber chat invites don't work at the moment, and MSN crashes on connect, so I could only double-check the AIM invite string. :/ Also a small code cleanup for group chat events ala CFM. Refs #7923. Fixes #80.

comment:26 Changed 12 years ago by Zachary West

Milestone: zzzDuplicate ticketsAdium X 1.2
Summary: multi-user chat request event notificationChat invitation event

comment:27 Changed 11 years ago by Zachary West

Component: Core AdiumAdium Core
Note: See TracTickets for help on using tickets.