Adium

Opened 15 years ago

Closed 6 years ago

Last modified 6 years ago

#8 closed enhancement (fixed)

Ability to turn logging on and off by conversation

Reported by: tick Owned by:
Milestone: Adium 1.6 Component: Logging
Version: Severity: normal
Keywords: Cc:
Patch Status:

Description

Save as support for saving an individual conversation

Attachments (1)

Adium Export.icns (47.3 KB) - added by Benjamindaines 14 years ago.
Icon

Download all attachments as: .zip

Change History (37)

comment:1 Changed 14 years ago by evands

  • Component changed from component1 to Logging

comment:2 Changed 14 years ago by catfish_man

  • Milestone Adium X 0.90 (Old) deleted
  • Resolution set to wontfix
  • Status changed from new to closed

I'm gonna wontfix this. If the functionality is really needed, an "export log" button in the log viewer seems somewhat better suited. All a "save conversation" thing would do is save the log to a different spot. Reopen if you disagree (and have good reasons for doing so).

comment:3 Changed 14 years ago by manan dot drishya {at} gmail dot com

  • Resolution wontfix deleted
  • Status changed from closed to reopened

I disagree. A save conversation is needed, because I may normally have logging turned off, but want to save a particular conversation.

comment:4 Changed 14 years ago by catfish_man

  • Resolution set to wontfix
  • Status changed from reopened to closed

comment:5 Changed 14 years ago by anonymous

  • Resolution wontfix deleted
  • Status changed from closed to reopened

You must be kidding. How is this not a fundamental feature? Who even has logging turned on? Do I really want all the dribble between friends logged to disk from now until I die? When I have an important conversation and want to save it, I want to save it, and do not want idle blather shoved to disk just so that I can save one important conversion once in a while. It is not up for discussion. You cannot have Adium be taken seriously without it. It is simple to do. Undim File | Save As. Write it out. Done.

comment:6 Changed 14 years ago by catfish_man

  • field_haspatch set to 0

300,000+ users disagree with you. Go away, and take your attitude problem with you. (That said, I don't think I'll re-close this. It may get looked into at some point, since it's not a bad idea)

comment:7 Changed 14 years ago by cbarrett

  • Milestone set to Adium X 1.0
  • Owner changed from somebody to cbarrett
  • priority changed from lowest to normal
  • Status changed from reopened to new

anonymous, please have a better attitude. We're all working on this in our free time, so be patient with us. If you really want the feature that badly, please, feel free to help and submit a patch.

That being said, this *is* a good idea, and I will at least look into it wile doing the log format rewriting.

As for "Who even has logging turned on?" lots of people, myself included.

comment:8 Changed 14 years ago by Lfe

Since logging is enabled by default (correct me if im wrong here) and sizes of hdd's aint going down i see no reason to turn off logging because of its size (size of dribble to quote mr. anonymous). The real problem is then how we easy can find whats important and whats not. I am currently very satisfied with the way i search logs.

(just my 2c)

comment:9 Changed 14 years ago by cbarrett

As a temporary work around, you can print the conversation to a PDF.

comment:10 Changed 14 years ago by tick

  • Milestone changed from Adium X 1.0 to Adium X 1.2

comment:11 Changed 14 years ago by anonymous

Hello, I just used Adium for the first time tonight after Yahoo Messenger refused to work. I heard good things about Adium and I enjoyed using it. I normally do a Save As... after the chats with one friend but I noticed that option was grayed out. I found this ticket and wanted to let you know that I definitely will use this feature when it is available. In the meantime, my workaround is to Select All and Copy/Paste into Word. The problem there is that none of the emoticons show up. Ideally I'd like to have them saved in my Saved Chats. Thanks! (pailes)

comment:12 Changed 14 years ago by evands

pailes, FYI, all your chats are logged by default -- check Window->Show Previous Conversations. (You can disable that behavior in the General preferneces).

comment:13 Changed 14 years ago by Benjamindaines

For when this is implemented I have an icon for you :)

Image Attached

Changed 14 years ago by Benjamindaines

Icon

comment:14 Changed 14 years ago by anonymous

I don't want to save my chats in Adium by default, I'm paranoid - my system gets backed up in various places, accessible by various admins.

I _do_ want to save some chats, so it's very odd that there's no way to save a particular chat in Adium. I thought this was basic functionality and has existed in every other client I have ever used.

Please fix this soon! :-)

comment:15 Changed 14 years ago by cbarrett

This is coming eventually. Right now we're focused on rewriting our current logging API to use XML. Once that's done, we will look at adding additional features like this.

comment:16 follow-up: Changed 14 years ago by anonymous

I wonder if there's a way to write an applescript to turn global logging on/off from within the window. This might be a neat fix for the interim. For example, within chat window:

\logon
...
\logoff

comment:17 in reply to: ↑ 16 Changed 13 years ago by tick

  • Milestone changed from Adium X 1.2 to Adium X 1.4

Moving to 1.4

comment:18 Changed 13 years ago by tick

  • Milestone changed from Adium X 1.4 to Good idea for "later"

Milestone Adium X 1.4 deleted

comment:19 Changed 12 years ago by Robby

  • Patch Status set to None
  • pending set to 0
  • Summary changed from Save as support for saving an individual conversation to Ability to turn logging on and off by conversation
  • Type changed from defect to enhancement

This ticket is quite a mess.
I'm going to change it's summary, maybe that helps a little bit.

"Save" as in exporting a transcript should be handled in a separate ticket, I think.

comment:20 Changed 12 years ago by Robby

Exporting is tracked in #6050.

comment:21 Changed 12 years ago by djmori

comment:22 Changed 11 years ago by wixardy

Ticket #2269 has been marked as a duplicate of this ticket.

comment:23 Changed 10 years ago by cbarrett

  • Owner changed from cbarrett to nobody

comment:24 Changed 10 years ago by zacw

Ticket #12222 has been marked as a duplicate of this ticket.

comment:25 Changed 9 years ago by Robby

Ticket #14111 has been marked as a duplicate of this ticket.

comment:26 Changed 9 years ago by Laundry

Being my chat client at work I personally have no interest in it keeping history of any of my private conversations.
Saving logs on my colleges is on the other hand imperative for workflow.

I'll be sure to check up on it this page from time to time, Adium seems an otherwise noteworthy client I'd love to use once it's on par with standards.

comment:27 Changed 9 years ago by solokat

Add another vote for this feature. Like anonymous of 4 years ago, I use Adium for a combination of work and private chats on my work computers. It's important at times to log work chats, but I'd really prefer that my private chats not be archived on my company's backup systems. Since I have no control over what gets archived or when, I'd really like either a simple "Do not log chats for this contact" option or (if you want to get fancy about it) a "Logging enabled/disabled" checkbox in the chat window so you can toggle logging on and off on-the-fly.

comment:28 Changed 9 years ago by Robby

  • Owner nobody deleted

comment:29 Changed 9 years ago by wixardy

Ticket #8254 has been marked as a duplicate of this ticket.

comment:30 Changed 9 years ago by Zachary West <zacw@…>

(In 030035dabb86) Add "Log only certain accounts", which lets you log only certain accounts, and add "Log secure chats" which (enabled by default) logs secure chats.

This was prompted by (for the first time evar!) using a Mac at work all day, and wanting my work chats logged but not my personal ones. I know, it breaks account/service/whatever agnosticism, but hey, whatevs. Encrypted chats not being logged has been a popular request for a while, and I was in here anyway.

Defaults to not "log only certain accounts", and accounts default to enabled for logging.

Take the opportunity to backport [da70be37dabb] as well, which renamed "Save open chats when quitting" to "Reopen chats from last time on startup".

Refs #8, fixes #94 (woohoo old tickets).

comment:31 Changed 8 years ago by mark

Last edited 8 years ago by edr1084 (previous) (diff)

comment:32 Changed 8 years ago by mark

Last edited 8 years ago by edr1084 (previous) (diff)

comment:33 Changed 8 years ago by mark

Last edited 8 years ago by edr1084 (previous) (diff)

comment:34 Changed 6 years ago by Thijs Alkemade <me@…>

  • Resolution set to fixed
  • Status changed from new to closed

(In a531abb7d093) Add a toolbar item that shows the current logging status for a conversation and allows the user to override it for that conversation only.

Also, removed the warning that was shown at the top before when logging and OTR were both on.

The images are still placeholders.

Fixes #8, refs #15729

comment:35 Changed 6 years ago by Robby

  • Milestone changed from Good ideas for later to libotr4.0.0

comment:36 Changed 6 years ago by Robby

  • Milestone changed from libotr4.0.0 to Adium 1.6

The libotr4.0.0 branch has been merged into 1.6.

Note: See TracTickets for help on using tickets.