Adium

Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#7933 closed defect (fixed)

Adium hangs when upgrading 1.0.5 to 1.1.2 or using fresh install of 1.1.2

Reported by: ranathari Owned by: nobody
Milestone: Adium 1.2.4 Component: Adium Core
Version: Severity: normal
Keywords: hang, upgrade Cc:
Patch Status:

Description (last modified by Evan Schoenberg)

I can't upgrade my copy of Adium 1.0.5 to 1.1.1 or 1.1.2 because Adium hangs on loading and won't log-in to any of my accounts. If I click the "Status" menu-bar entry then no drop-down menu appears. Opening Adium's preferences shows only the Accounts preference pane, which is empty (not showing any of my accounts). The problem is the same if I trash my 1.0.5 install and all preferences and then do a fresh install of 1.1.1 or 1.1.2 A fresh install of 1.0.6 works perfectly. I'm running OS X 10.4.10.

Console.log output is:

2007-09-17 21:18:02.681 Adium[1341] Exception raised during posting of notification.  Ignored.  exception: launch path not accessible
2007-09-17 21:18:12.720 Adium[1341] [--- PREFERENCES DEBUG MESSAGE ---]
Did not add preference pane "General" to the toolbar ordering array, because that pane does not exist.

2007-09-17 21:18:12.720 Adium[1341] [--- PREFERENCES DEBUG MESSAGE ---]
Did not add preference pane "Personal" to the toolbar ordering array, because that pane does not exist.

2007-09-17 21:18:12.720 Adium[1341] [--- PREFERENCES DEBUG MESSAGE ---]
Did not add preference pane "Messages" to the toolbar ordering array, because that pane does not exist.

2007-09-17 21:18:12.720 Adium[1341] [--- PREFERENCES DEBUG MESSAGE ---]
Did not add preference pane "Status" to the toolbar ordering array, because that pane does not exist.

2007-09-17 21:18:12.720 Adium[1341] [--- PREFERENCES DEBUG MESSAGE ---]
Did not add preference pane "Events" to the toolbar ordering array, because that pane does not exist.

2007-09-17 21:18:12.720 Adium[1341] [--- PREFERENCES DEBUG MESSAGE ---]
Did not add preference pane "File Transfer" to the toolbar ordering array, because that pane does not exist.

2007-09-17 21:18:12.720 Adium[1341] [--- PREFERENCES DEBUG MESSAGE ---]
Did not add preference pane "Advanced" to the toolbar ordering array, because that pane does not exist.

Change History (20)

comment:1 Changed 13 years ago by Jordan

Did you try restarting? It's saying launch path not accessible which is odd... you copied it into the applications folder? And you've trashed prefs as outlined in TroubleshootingTips? You could try the AdiumBeta and enable debug logging from the Adium -> Debug Window and attach it here.

comment:2 Changed 13 years ago by Jordan

Milestone: Needs feedback from users
pending: 01

comment:3 Changed 13 years ago by jtrofa

Same problem here, but i was a fresh install.

I already try using the Adium debug panel in the beta version (1.1.3b4) but the debug panel remained only with the message"07:08:40: Got dirty logs (null)". I accessed to the prefs panel, navigate through menu and still nothing.

I also cleaned the prefs using the TroubleshootingTips and still nothing.

Now i cleaned the prefs and tried the Adium 1.0.5 version and this version works fine.

comment:4 Changed 13 years ago by Jordan

jtrofa: same problem as in, it hangs? How did you access the prefs if it was hanging? Please describe in detail exactly what happens after loading Adium.

comment:5 Changed 13 years ago by jtrofa

I'll try my best/

I double click and Adium starts (init). As you can see, it doesn't have an icon in the menu bar as usual and the menu add acount is empty.

If you try got to the prefs (Account prefs), also the add account menu is empty and there is only two panes.

The other pane is appearance (Appearance).

The errors that gives are well described by ranathari.

Hope pictures help.

As i said before, the only solution i find was go back to version 1.0.5.

comment:6 Changed 13 years ago by Jordan

pending: 10

jtrofa, you mentioned that you've already tried a fresh set of preferences, would you be able to try disabling any 3rd party apps that might be conflicting with Adium? This would mean virtue desktops, uno, shapeshifter, quicksilver, etc... I've seen reports of odd issues being caused by some of those applications before.

Does anyone know if the problem reported by 'Got dirty logs' could cause Adium to actually stop loading or incorrectly load like that? I would think there's more to it than that.

comment:7 Changed 13 years ago by jtrofa

"07:08:40: Got dirty logs (null)" - I think that this message means that Adium doesn't have dirty logs because of the "(null)".

I tried your (jas8522) suggestion and nothing got better. It just stopped as i described before.

Sometime ago, i was searching for this problem and i got a site (which i don't remember) blaming the faulty drivers of hp, so, maybe is worth to mentioning that i installed and uninstalled hp drivers for my all-in-one hp.

comment:8 Changed 13 years ago by Evan Schoenberg

Are you using a case sensitive file system?

comment:9 Changed 13 years ago by jtrofa

No, just Journaled.

Nothing changed im my computer, between the experiments of using Adium 1.0.5 and Adium 1.1.2/1.1.3b4, and the first works perfectly well, but the other two don't.

What changed dramatically between 1.0.* branch and 1.1.* branch?

comment:10 Changed 13 years ago by Robert

pending: 01

Is the problem persisting?

comment:11 Changed 13 years ago by jtrofa

Unfortunately, yes. The problem still persists.

Tested with a clean install (removed the preferences) and version 1.2.2 of Adium.

comment:12 Changed 13 years ago by Robert

Milestone: Needs feedback from usersAdium X 1.2.4
pending: 10

This is pretty severe. I'll set 1.2.4 as the milestone.

comment:13 Changed 13 years ago by Evan Schoenberg

Description: modified (diff)

comment:14 Changed 13 years ago by Evan Schoenberg

Please see RunningAdiumInGDB and follow the instructions there. This will let us know where that initial exception is occurring.

comment:15 Changed 13 years ago by jtrofa

(gdb) run
Starting program: /Users/jmsm/Desktop/Adium.app/Contents/MacOS/Adium 
Reading symbols for shared libraries .........................................................................++...+++.... done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done

Breakpoint 1, 0x92bfff64 in -[NSException raise] ()
(gdb) bt full
#0  0x92bfff64 in -[NSException raise] ()
No symbol table info available.
#1  0x92bffdb8 in +[NSException raise:format:] ()
No symbol table info available.
#2  0x92bd2b08 in -[NSConcreteTask launchWithDictionary:] ()
No symbol table info available.
#3  0x92be768c in +[NSTask launchedTaskWithLaunchPath:arguments:] ()
No symbol table info available.
#4  0x000a1c24 in -[AILoggerPlugin reimportLogsToSpotlightIfNeeded] ()
No symbol table info available.
#5  0x0009fb04 in -[AILoggerPlugin installPlugin] ()
No symbol table info available.
#6  0x000c928c in -[AICoreComponentLoader loadComponents] ()
No symbol table info available.
#7  0x000c9018 in -[AICoreComponentLoader init] ()
No symbol table info available.
#8  0x00004b68 in -[AIAdium completeLogin] ()
No symbol table info available.
#9  0x92be4a04 in _nsnote_callback ()
No symbol table info available.
#10 0x90805eb4 in __CFXNotificationPost ()
No symbol table info available.
#11 0x907fdf2c in _CFXNotificationPostNotification ()
No symbol table info available.
#12 0x92bcee0c in -[NSNotificationCenter postNotificationName:object:userInfo:] ()
No symbol table info available.
#13 0x937a5078 in -[NSApplication _postDidFinishNotification] ()
No symbol table info available.
#14 0x937a4f64 in -[NSApplication _sendFinishLaunchingNotification] ()
No symbol table info available.
#15 0x937a4aac in -[NSApplication(NSAppleEventHandling) _handleAEOpen:] ()
No symbol table info available.
#16 0x937a4654 in -[NSApplication(NSAppleEventHandling) _handleCoreEvent:withReplyEvent:] ()
No symbol table info available.
#17 0x92be5a10 in -[NSAppleEventManager dispatchRawAppleEvent:withRawReply:handlerRefCon:] ()
No symbol table info available.
#18 0x92be5870 in _NSAppleEventManagerGenericHandler ()
No symbol table info available.
#19 0x91500960 in aeDispatchAppleEvent ()
No symbol table info available.
#20 0x915007fc in dispatchEventAndSendReply ()
No symbol table info available.
#21 0x91500654 in aeProcessAppleEvent ()
No symbol table info available.
#22 0x9329f2e0 in AEProcessAppleEvent ()
No symbol table info available.
#23 0x937a2d9c in _DPSNextEvent ()
No symbol table info available.
#24 0x937a2888 in -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] ()
No symbol table info available.
#25 0x9379edcc in -[NSApplication run] ()
No symbol table info available.
#26 0x9388f974 in NSApplicationMain ()
No symbol table info available.
#27 0x00003560 in _start ()
No symbol table info available.
#28 0x00003264 in start ()
No symbol table info available.
(gdb) next 
Single stepping until exit from function -[NSException raise], 
which has no line number information.
0x92bfff74 in _NSRaiseError ()
(gdb) next 
Single stepping until exit from function _NSRaiseError, 
which has no line number information.
0x92be49e8 in _nsnote_callback ()
(gdb) next 
Single stepping until exit from function _nsnote_callback, 
which has no line number information.
2008-02-25 23:16:24.300 Adium[4961] Exception raised during posting of notification.  Ignored.  exception: launch path not accessible
0x92bc212c in restFP ()
(gdb) next 
Single stepping until exit from function restFP, 
which has no line number information.
0x90805eb4 in __CFXNotificationPost ()
(gdb) next 
Single stepping until exit from function __CFXNotificationPost, 
which has no line number information.
0x907fdf2c in _CFXNotificationPostNotification ()
(gdb) next 
Single stepping until exit from function _CFXNotificationPostNotification, 
which has no line number information.
0x92bcee0c in -[NSNotificationCenter postNotificationName:object:userInfo:] ()
(gdb) next 
Single stepping until exit from function -[NSNotificationCenter postNotificationName:object:userInfo:], 
which has no line number information.
0xfffeff00 in objc_msgSend_rtp ()
(gdb) next 
Single stepping until exit from function objc_msgSend_rtp, 
which has no line number information.
0x92bcefa0 in -[NSConcreteNotification recycle] ()
(gdb) next 
Single stepping until exit from function -[NSConcreteNotification recycle], 
which has no line number information.
0x937a5078 in -[NSApplication _postDidFinishNotification] ()
(gdb) next 
Single stepping until exit from function -[NSApplication _postDidFinishNotification], 
which has no line number information.
0x937a4f64 in -[NSApplication _sendFinishLaunchingNotification] ()
(gdb) next 
Single stepping until exit from function -[NSApplication _sendFinishLaunchingNotification], 
which has no line number information.
0x937a4aac in -[NSApplication(NSAppleEventHandling) _handleAEOpen:] ()
(gdb) next 
Single stepping until exit from function -[NSApplication(NSAppleEventHandling) _handleAEOpen:], 
which has no line number information.
0x937a4654 in -[NSApplication(NSAppleEventHandling) _handleCoreEvent:withReplyEvent:] ()
(gdb) next 
Single stepping until exit from function -[NSApplication(NSAppleEventHandling) _handleCoreEvent:withReplyEvent:], 
which has no line number information.
0x92be5a10 in -[NSAppleEventManager dispatchRawAppleEvent:withRawReply:handlerRefCon:] ()
(gdb) 
Single stepping until exit from function -[NSAppleEventManager dispatchRawAppleEvent:withRawReply:handlerRefCon:], 
which has no line number information.
0x92bc212c in restFP ()
(gdb) next 
Single stepping until exit from function restFP, 
which has no line number information.
0x92be5870 in _NSAppleEventManagerGenericHandler ()
(gdb) next 
Single stepping until exit from function _NSAppleEventManagerGenericHandler, 
which has no line number information.
0x91500960 in aeDispatchAppleEvent ()
(gdb) 
Single stepping until exit from function _Z20aeDispatchAppleEventPK6AEDescPS_mPh, 
which has no line number information.
0x915007fc in dispatchEventAndSendReply ()
(gdb) 
Single stepping until exit from function _Z25dispatchEventAndSendReplyPK6AEDescPS_, 
which has no line number information.
0x91500654 in aeProcessAppleEvent ()
(gdb) 
Single stepping until exit from function aeProcessAppleEvent, 
which has no line number information.
0x9329f2e0 in AEProcessAppleEvent ()
(gdb) 
Single stepping until exit from function AEProcessAppleEvent, 
which has no line number information.
0x937a2d9c in _DPSNextEvent ()
(gdb) 
Single stepping until exit from function _DPSNextEvent, 
which has no line number information.
0x937a2888 in -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] ()
(gdb) 
Single stepping until exit from function -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:], 
which has no line number information.
0x9379edcc in -[NSApplication run] ()
(gdb) 
Single stepping until exit from function -[NSApplication run], 
which has no line number information.
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done

HANGS HERE

It was raised the exception Adium[4961]. It's in the text above.

I really hope it helps. I really want to tray adium 1.2.4 :-) I am still using version 1.0.5

comment:16 Changed 13 years ago by Evan Schoenberg

The problem is that Adium is unable to launch /usr/bin/mdimport. This program should be present in Mac OS X 10.4.0+. Is it missing on your system?

comment:17 Changed 13 years ago by jtrofa

you were right, Evands.

The problem was, the permissions on

../../System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/Metadata.framework/Versions/A/Support/mdimport

were ----------.

Changed to -rwxr-xr-x and I have my Adium back.

Thank you very, very much for your patience.

comment:18 Changed 13 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

(In [22694]) Catch and log rather than crashing on the exception if we can't run /usr/bin/mdimport on first launch of 1.1 or later. Fixes #7933

comment:19 Changed 13 years ago by Evan Schoenberg

(In [22695]) merged [22694]: Catch and log rather than crashing on the exception if we can't run /usr/bin/mdimport on first launch of 1.1 or later. Fixes #7933

comment:20 Changed 13 years ago by Evan Schoenberg

No problem. I've now fixed the problem that this isn't handled gracefully, as well, in case someone else has a similar permissions problem

Note: See TracTickets for help on using tickets.