Adium

Opened 7 years ago

Closed 5 years ago

Last modified 15 months ago

#7848 closed defect

Gtalk invisible status does not work

Reported by: meighan Owned by: nobody
Milestone: Component: Service/Google Talk
Version: 1.3.3b2 Severity: normal
Keywords: Cc:
Patch Status:

Description

Using Version 1.1.2 running on Mac OS X 10.4.10

When changing the status to 'Invisible' any Google Talk contacts simply see my status changing to idle, rather than appearing offline.

The same is happening under for MSN accounts.

Attachments (1)

gtalkinv.diff (1.5 KB) - added by deniz 3 years ago.

Download all attachments as: .zip

Change History (22)

comment:1 Changed 7 years ago by jas8522

  • Component changed from Adium Core to Google Talk
  • Milestone set to Waiting on libpurple
  • Summary changed from Invisble status does not work to Gtalk invisble status does not work

I just tested this with 1.1.3b2 and 1.2svn with MSN and it worked fine - setting myself to invisible showed as offline to my contacts. However this is accurate for google talk - using the web-based messenger built into gmail. This is reliant on libpurple which only has partial invisible support - looking through tickets finds an answer to this exact problem revealed as: we don't support invisible yet.

comment:2 Changed 6 years ago by djmori

comment:3 Changed 6 years ago by Robby

  • Version changed from 1.1.2 to 1.3svn

comment:4 Changed 6 years ago by radek

I confirm that in 1.3b5 invisibility still doesnt work for GTalk. Its a pity because it works for such obscure protocols like gadugadu, while not for gtalk.

comment:5 Changed 6 years ago by Robby

  • Summary changed from Gtalk invisble status does not work to Gtalk invisible status does not work

comment:6 Changed 5 years ago by jas8522

  • Version changed from 1.3svn to 1.3.3b2

Just tested this for confirmation for #11227 - exact same behaviour with 1.3.3b2

comment:7 Changed 5 years ago by Robby

"We will not support the Google Talk invisibility, because it requires using their shared status stuff which we have no interest in supporting." #p5828

comment:8 Changed 5 years ago by zacw

  • Status changed from new to closed

Closing all "waiting on libpurple" tickets. There's no reason to keep them around as open, and largely go ignored anyway. File a ticket at http://developer.pidgin.im for any functionality you want to see.

comment:9 Changed 5 years ago by anonymous

  • Milestone Waiting on libpurple deleted

Milestone Waiting on libpurple deleted

comment:10 Changed 5 years ago by Robby

Ticket #12907 has been marked as a duplicate of this ticket.

comment:11 Changed 4 years ago by Robby

Ticket #13787 has been marked as a duplicate of this ticket.

comment:12 Changed 4 years ago by Robby

Ticket #13962 has been marked as a duplicate of this ticket.

comment:13 Changed 4 years ago by Robby

Ticket #13613 has been marked as a duplicate of this ticket.

Changed 3 years ago by deniz

comment:14 Changed 3 years ago by deniz

I made a very quick and very dirty patch for this, it will make you 'invisible' on login (with a second delay as it does right after connect), and when you change status.

comment:15 Changed 2 years ago by jpoa

Greetings!

This issue has reappeared. I'm logged in only with Adium and I cannot set the status to invisible...

Bet regards!

comment:16 Changed 2 years ago by sphynx

jpoa: Adium has never supported invisibility on GTalk and will not as long as libpurple does not support it. They dislike the way it works (for good reasons #p11433).

deniz: I'm sorry, that patch is way too hackish to use (I also apologize it has been unreviewed for 11 months). First of all, we have APIs to construct XML nodes (either libpurple's xmlnode* or NSXMLNode*), which is a lot better than hard-coding a string. Secondly, sending an unavailable presence has a lot of disadvantages, as described here: http://developer.pidgin.im/ticket/5828#comment:10.

comment:17 Changed 2 years ago by jpoa

sphynx: My appologies and thank you for the feedback!

comment:18 Changed 21 months ago by sphynx

Ticket #16215 has been marked as a duplicate of this ticket.

comment:19 Changed 20 months ago by sphynx

Ticket #16223 has been marked as a duplicate of this ticket.

comment:20 follow-up: Changed 15 months ago by noleli

I've been keeping an occasional eye on this ticket almost since it was created, and it recently led me to write a blog post.

The tl;dr is that an ideological insistance on the part of the developers that the protocol be implemented to spec is in opposition to user expectations. The open-source community is taking ideological stances to the detriment of users and the user experience, which is harmful and counterproductive. When “doing it right” and “making the user happy” are at odds, the open-source world needs to redefine “doing it right”.

In the Adium UI, Gtalk is listed as a different protocol than Jabber, so there's no reason the status of Gtalk contacts shouldn't be treated the way users would expect.

Sorry if this was ranty. I love Adium and just want to see it be awesome. Just my 2¢. :)

comment:21 in reply to: ↑ 20 Changed 15 months ago by sphynx

Replying to noleli:

The open-source community is taking ideological stances to the detriment of users and the user experience, which is harmful and counterproductive. When “doing it right” and “making the user happy” are at odds, the open-source world needs to redefine “doing it right”.

It is not that black and white. There are two different user expectations in conflict here: being invisible on GTalk and being able to set a separate status on each of your own clients that is signed in. If we want to support the first, then we break the second. Adium doesn't even internally support the concept of being forced to change your status because the server tells it to.

Talking about "the open-source community" as a whole taking ideological stances is silly. There's a handful of people working on Adium and libpurple, and those mostly work on the features they find important. Most of the Pidgin developers have taken the stance that this addition breaks a core feature of XMPP, so they won't add it.

So:

  • Nobody is interested in implementing or maintaining it.
  • It's a strange trade-off that can't be easily explained in a checkbox label.
  • Pidgin has a plugin for it.

...makes me conclude that the best approach is, if any developer is interested in this feature, they should port the Pidgin plugin to an Adium plugin.

Let me also reply to this part from your blog:

To me, this is as if the web developers of ten or fifteen years ago simply decided that they didn’t care if what they produced looked wrong for the vast majority of users because IE was wrong. Just because you don’t like the way something is implemented doesn’t mean you should break the user experience.

If we pick browser creators here instead of web developers, then that is exactly what happened. If you try to use ActiveX in Firefox you'll notice it doesn't look right. Mozilla decided that ActiveX was not worth implementing because it is broken and unneccessary.

Note: See TracTickets for help on using tickets.