Adium

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#7839 closed defect (fixed)

IP Based Links aren't turned into links automatically

Reported by: siriusfox Owned by: nobody
Milestone: Adium 1.2.1 Component: Adium UI
Version: Severity: regression
Keywords: applebug Cc: stephen.holt@…
Patch Status:

Description

For some reason, now links with IPs in them aren't automatically turned into links in Adium. I have to manually go into the link interface to add the link, when in previous versions http://#.#.#.#/file.html would be turned into the link.

I'm currently running Adium 1.1.2.

Change History (22)

comment:1 Changed 12 years ago by Evan Schoenberg

It sounds like this worked for you in the past. What version was the last for it to work?

comment:2 Changed 12 years ago by Luke

It last worked in 1.1.1. It has worked with every version I used save 1.1.2, all the way up through 1.1.1.

comment:3 Changed 12 years ago by Jordan

Resolution: worksforme
Status: newclosed

This works fine in both the 1.1.3 AdiumBeta and 1.2svn

If it fails to work for you in the AdiumBeta or 1.1.3 when it is final, try TroubleshootingTips.

comment:4 Changed 12 years ago by Luke

This was somewhat working in the 1.1.3 release, but for whatever reason, it's broken again in the 1.1.4b2 release.

Even when it was working an IP that used a specific port (e.x. 192.168.0.4:8080) wasn't formated.

comment:5 Changed 12 years ago by Jordan

Milestone: Adium X 1.1.5
Resolution: worksforme
Severity: normalregression
Status: closedreopened
Version: 1.1.21.1.4

Confirmed, no IP based links are working in 1.1.4

comment:6 Changed 12 years ago by Stephen Holt

I'm looking into this.

If you use the link editor window (cmd-k), you can see that the IP based link gets accepted as valid when typing it in. A warning gets displayed for likely invalid URIs, it's absence means that the link scanner itself is likely functioning properly .

As for actual linkification, here are some test cases on my computer with Adium 1.1.4, sent from an external client:

http://10.0.1.3 - works http://10.0.1.3/ - works http://10.0.1.3/foo - works http://10.0.1.3/foo/ - works http://10.0.1.3/foo/bar.baz - works http://10.0.1.3/foo/bar?baz - works http://10.0.1.3/foo/bar?baz=biz - works

http://10.0.1.3:8080 - works http://10.0.1.3:8080/ -works http://10.0.1.3:8080/foo - works

...and we see the trend.

Works for me.

comment:7 Changed 12 years ago by Stephen Holt

Cc: stephen.holt@… added

comment:8 Changed 12 years ago by Luke

But that isn't the bug. It used to autodetect and autoformat those as links. Using the dialog I can format ANY text into a link.

comment:9 Changed 12 years ago by Stephen Holt

Re-read my comment. It is auto-detecting and formatting those URIs into links. Every one.

comment:10 Changed 12 years ago by Stephen Holt

which is to say, each of those test cases was sent from a client not on my computer to my local Adium 1.1.4. Each of those URIs were detected by Adium and linkified upon receipt.

Worksforme.

comment:11 Changed 12 years ago by Jordan

Resolution: invalid
Status: reopenedclosed

Yes, I don't know what I was thinking when I checked this. For some reason I was trying just 192.168.1.1 but it can't know that's a URL without the HTTP in front of it. Now that I've tested IP linkification with the http:// in front, it seems to work fine...

comment:12 Changed 12 years ago by Luke

Adium won't detect the link unless it is preceded by a the http, AND if the last number in the IP is only one digit. Currently things like http://10.0.0.15, or http://192.168.0.26 aren't detected.

comment:13 Changed 12 years ago by Zachary West

The former requirement (a protocol must be specified) will not be going away. Both http://10.0.0.15 and http://192.168.0.26 linkfiy on trunk -- did 1.1.4 miss a merge?

comment:14 Changed 12 years ago by Zachary West

Milestone: Adium X 1.1.5Adium X 1.2

comment:15 Changed 12 years ago by Luke

I'm currently running Adium 1.2b1, and this bug is still a problem.

Links that end in more than a single digit number still don't link automatically. http://192.168.0.50, http://10.0.0.35, http://65.218.142.23 and all fail to link.

comment:16 Changed 12 years ago by Jordan

Milestone: Adium X 1.2Adium X 1.2.1
Resolution: invalid
Status: closedreopened

Confirmed with 1.2b1 - I used 192.168.1.10 and it didn't linkify...

Pushing to 1.2.1 officially since it is a specific case and not all IP links.

comment:17 Changed 12 years ago by Evan Schoenberg

Resolution: fixed
Status: reopenedclosed

(In [22243]) I don't understand why the valid regex expression ([0-9]{1,3}\.){3}[0-9]{1,3} is acting identically to ([0-9]{1,3}\.){3}[0-9] in lex. It works fine for me in other tools, such as SubEthaEdit's Find dialogue.

([0-9]{1,3}\.){3}[0-9][0-9]?[0-9]? behaves as expected, allowing a dotted quad of 3 digits per section.

Fixes #7839

comment:18 Changed 12 years ago by Evan Schoenberg

(In [22244]) Merged [22243]: I don't understand why the valid regex expression ([0-9]{1,3}\.){3}[0-9]{1,3} is acting identically to ([0-9]{1,3}\.){3}[0-9] in lex. It works fine for me in other tools, such as SubEthaEdit's Find dialogue.

([0-9]{1,3}\.){3}[0-9][0-9]?[0-9]? behaves as expected, allowing a dotted quad of 3 digits per section.

Fixes #7839

comment:19 Changed 12 years ago by Peter Hosey

Keywords: applebug added

The previous expression was correct. Moreover, the test case works just fine if I build Adium on Tiger, but if I build it on Leopard, it fails.

So, this seems to be a bug in the version of flex that comes with Leopard, or with something involved in the build process for flex. We should report it to Apple.

comment:20 Changed 12 years ago by Stephen Holt

Try turning the debug option on in the lex source, and watching the output in the debugging console (in XCode).

When I tested this, lex was identifying the patterns properly, and it seemed this was somehow ignored between the lexer and output. I mention this only because

([0-9]{1,3}\.){3}[0-9]{1,3}

is more efficient than

([0-9]{1,3}\.){3}[0-9][0-9]?[0-9]?

comment:21 Changed 12 years ago by Evan Schoenberg

Milestone: Adium X 1.2.1Adium X 1.2.2

comment:22 Changed 12 years ago by Evan Schoenberg

Milestone: Adium X 1.2.2Adium X 1.2.1
Note: See TracTickets for help on using tickets.