Adium

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#7791 closed defect (fixed)

Adium crashes when checking chat logs (Command-L)

Reported by: alikishi Owned by: evands
Milestone: Adium X 1.1.3 Component: Adium Core
Version: Severity: normal
Keywords: crash, chat logs Cc: alyson.yap@…
Patch Status:

Description

In order to reproduce the error, all I have to do is press Command-L to check the chat logs. Then it would automatically crash and quit the application.

I'm currently using 1.1.2 but the problem still occurred when I was still using 1.1.1

Attachments (2)

crash.rtf (801 bytes) - added by alikishi 12 years ago.
this is the part of the crash log (too big to attach) that pertains to the adium crash
crash (updated).rtf (129.7 KB) - added by alikishi 12 years ago.
Updated crash log (from console.log --> crashreporter --> Adium.crash.log

Download all attachments as: .zip

Change History (10)

Changed 12 years ago by alikishi

Attachment: crash.rtf added

this is the part of the crash log (too big to attach) that pertains to the adium crash

comment:1 Changed 12 years ago by Evan Schoenberg

We need the actual crash log (the file listed in the section you showed in your attachment), not the console logging.

Changed 12 years ago by alikishi

Attachment: crash (updated).rtf added

Updated crash log (from console.log --> crashreporter --> Adium.crash.log

comment:2 Changed 12 years ago by alikishi

is there any update to this?

comment:3 Changed 12 years ago by Evan Schoenberg

Please try this build: Adium_1.1.2-indexing-debug-1.dmg

and email me the output to Console when you open the chat transcript viewer (/Applications/Utilities/Console.app).

I say email me because the Console will contain the contents of one or more of your log files as it indexes them. I just need the last set of entries which are logged (before the crash), but even so I figure you would prefer to keep that private.

comment:4 in reply to:  3 Changed 12 years ago by alikishi

Replying to evands:

Please try this build: Adium_1.1.2-indexing-debug-1.dmg

and email me the output to Console when you open the chat transcript viewer (/Applications/Utilities/Console.app).

I say email me because the Console will contain the contents of one or more of your log files as it indexes them. I just need the last set of entries which are logged (before the crash), but even so I figure you would prefer to keep that private.

I installed the version 1.1.2-indexing-debug version but it still crashes. I have also emailed you the console.app already. Thank you very much!

comment:5 Changed 12 years ago by Evan Schoenberg

Milestone: Adium X 1.1.3
Owner: changed from nobody to Evan Schoenberg
Status: newassigned

alikishi's debug log shows that searchIndex is somehow NULL in -[AILoggerPlugin _cleanDirtyLogsThread:]. I think this is happening because the index is corrupt, so -[AILoggerPlugin createLogIndex] returns NULL after first attempting to open it (gets null) then attempting to create it (fails because a file exists in that location already). More info to follow.

comment:6 Changed 12 years ago by Evan Schoenberg

(In [20882]) Debug logging and possible fix for #7791. Refs #7791.

  • If there is a log index file but it can't be opened, it is presumably corrupt. Remove it before attempting to create a new one so the creation can succeed.
  • Log to console if -[AILoggerPLugin _cleanDirtyLogsThread:] is called with a NULL searchIndex; that should never happen.

comment:7 Changed 12 years ago by Evan Schoenberg

(In [20883]) Merged [20882]: Debug logging and possible fix for #7791. Refs #7791.

  • If there is a log index file but it can't be opened, it is presumably corrupt. Remove it before attempting to create a new one so the creation can succeed.
  • Log to console if is called with a NULL ; that should never happen.

comment:8 Changed 12 years ago by Evan Schoenberg

Resolution: fixed
Status: assignedclosed

[20882] and [20883] are indeed fixes for the crash reported in this ticket :)

Note: See TracTickets for help on using tickets.