Adium

Opened 12 years ago

Closed 12 years ago

#7778 closed defect (fixed)

Setting "Use no icon" in personal preferences does not propagate the lack of an icon to any service

Reported by: gorsefan Owned by: nobody
Milestone: Adium 1.3 Component: Adium Core
Version: Severity: normal
Keywords: user icon Cc: jon_3345@…
Patch Status:

Description

Am using 1.1.2, this was also a problem in 1.1.1

I go to Preferences -> Personal, whether I select "Use no icon" or chose a different icon, my contacts and I still see the old icon i chose. Whether I try a new icon, or a different icon that previously worked OK, still the same old icon.

My preferences do seem to be saved, it just silently fails to actually do anything.

Under Preferences -> Address Book, Images preferences, I have none of the user icon-type preferences checked. Have rebooted and restarted Adium several times.

Change History (18)

comment:1 Changed 12 years ago by John Heltsley

I have the exact same problem, running 1.1.2 currently, has been going on for about 2 months now. I don't know if this affects all services or not, but I use GTalk exclusively.

comment:2 Changed 12 years ago by Jordan

Milestone: Adium X 1.5

Confirmed with MSN. I thought there was an earlier ticket about this, it I think only the appearance of your buddy icon in the toolbar of the contact list was removed when set to "use no icon".

So for clarification, choosing "use no icon" should result in:

  1. the buddy icon not appearing in the toolbar of the contact list (already done)
  2. the buddy icon in personal preferences showing up as the service icon (to show that it's not your personal icon)
  3. the buddy icon in the message window showing up as the service icon - this should follow from 2 I would think.

comment:3 in reply to:  1 Changed 12 years ago by John Heltsley

Replying to jheltsley:

I have the exact same problem, running 1.1.2 currently, has been going on for about 2 months now. I don't know if this affects all services or not, but I use GTalk exclusively.

Actually, I should modify my statement; my problem is still very similar, so I think it may be the same issue. If I change my icon in Adium controls, it changes in the Preferences > Personal tab but this change does not get translated over to my GTalk account. (Even with myself on my buddy list it doesn't show.)

comment:4 Changed 12 years ago by Jordan

jheltsley: your problem is actually not this one - this one deals with local disabling of the buddy icon. This means that if the icon is changed to nothing locally (if the code for the different services like AIM, MSN, Gtalk etc works fine) then it will show as nothing on all the services as well.

Your problem is that changing your icon does not propagate to the contacts using Gtalk. The difference being that the problem in this ticket relies on the code where your problem exists working properly. The problem you're mentioning is most likely handled by ticket #6645.

comment:5 in reply to:  4 Changed 12 years ago by John Heltsley

Replying to jas8522:

jheltsley: your problem is actually not this one - this one deals with local disabling of the buddy icon. This means that if the icon is changed to nothing locally (if the code for the different services like AIM, MSN, Gtalk etc works fine) then it will show as nothing on all the services as well.

Your problem is that changing your icon does not propagate to the contacts using Gtalk. The difference being that the problem in this ticket relies on the code where your problem exists working properly. The problem you're mentioning is most likely handled by ticket #6645.

Yeah, the description sounds a bit closer, although still not perfect, as it says that changing in Adium updates on the server, where mine does not. You can delete all of my comments off this ticket, I suppose. (If you'd like to contact me personally, just email me and I'll be happy to discuss this.)

comment:6 Changed 12 years ago by Peter Hosey

No, jas8522, this ticket covers changing the icon as well. Read the ticket description.

comment:7 Changed 12 years ago by Shreevatsa R

I can confirm the same problem on my GTalk account too. More symptoms:

  • The first time I installed and started Adium, it actually did update my Gtalk icon to my local (user) icon on my OS X account.
  • After this, it is now impossible to change my Gtalk icon through Adium. (Either by explicitly setting the icon for that account, or asking that account to use the global (changed) icon.)
  • Changing the global icon does change it for other XMPP servers (like jabber.org or mit.edu) It is only GTalk that's a problem.
  • It also changes the icon for *my* side. This means that if I carry on a conversation with myself, I see messages I send with the new icon, and the messages I get with the old (wrong) icon.
  • Nothing changes even if externally change the icon (like, login to GMail and delete the icon). I still see my own picture for my side (which is wrong too) and the old picture for the incoming side (which is wrong too).

Hope this helps.

comment:8 in reply to:  7 ; Changed 12 years ago by Shreevatsa R

Ok, impatient with not being able to do it through Adium, I logged in to GMail and changed the icon. It didn't update it in Adium (despite restarting) till I clicked on Get Info. (I have myself on my buddy list, as I assume, do many people.) Then it worked.

So in other words, the problem is that:

  • If Adium doesn't already have a cache for that user, everything works fine -- it gets the icon from the server, and update the icon too if the user is you.
  • If Adium already has an icon for that user, it will never automatically update the icon.
  • If Adium already has an icon, and you click on "Get info", it will update the icon, but not if the new icon is "empty". Looks like it's impossible to clear an icon.
  • If Adium already has an icon, and it's *you*, it doesn't update it on (propagate it to) the server either.

So probably something to do with caching, although uninformed user comments are useless, I know.

comment:9 Changed 12 years ago by gorsefan

Hi folks,

For what it's worth, I am seeing the same behaviour as I originally reported. I am now using v 1.1.3.

I only use the Yahoo! protocol. Several of my colleagues use the same version of Adium, OS X and hardware and none have this problem. I have also tried deleting the Adium.app and reinstalling which did not appear to work. Thanks for your efforts, if i can provide any more info to help track this down pls let me know :)

comment:10 Changed 12 years ago by Jordan

Milestone: Adium X 1.5Adium X 1.2.1

Moving this up a bit. I just tested it again, and setting to No Icon, does make the picture disappear from the toolbar, but it does not seem to propagate the lack of a picture to contacts.

comment:11 in reply to:  8 Changed 12 years ago by Miha Filej

I found the same issues that shreevatsa mentioned and I can confirm that reinstalling adium and cleaning out prefereces from ~/Library/Application Support wouldn't solve the problem.

comment:12 Changed 12 years ago by Jordan

Milestone: Adium X 1.2.1Adium X 1.2.2

comment:13 Changed 12 years ago by Evan Schoenberg

Milestone: Adium X 1.2.2Adium X 1.2.3

comment:14 Changed 12 years ago by Matt Gregory

Just want to comment, in case it may help. I commented on 6645 a while ago as well.

This issue with the inability to change the user icon, for GTalk accounts at least, worked in 1.0.4. It has not worked in any version since then. Each time a new version is released I try it, and reinstall 1.0.4 to get this functionality back.

Hopefully that will help whoever works on this issue.

comment:15 Changed 12 years ago by Jordan

Summary: Cannot change or remove personal User IconSetting "Use no icon" in personal preferences does not propagate the lack of an icon to any service

Just confirmed this on 1.2.3 with MSN, AIM, and ICQ by adding myself to my contact list for AIM, MSN and ICQ - display picture still shows even when choosing "use no icon". I also asked a contact who has me added to their MSN and AIM contact list - he says my picture did not go away. I'm going to continue to assume this works the same for all services.

comment:16 Changed 12 years ago by Jordan

For those with additional icon issues with Gtalk (like changing the icon not working), #6645 covers that quite well. In my tests, changing my user icon worked fine for all services except Gtalk - it was only removing it that didn't work for all of them. Between these two tickets it seems to be covered quite well. I think there's even another one around here somewhere for Yahoo icons not updating properly.

comment:17 Changed 12 years ago by Jordan

Milestone: Adium X 1.2.4Adium X 1.3

comment:18 Changed 12 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

(In [23375]) When the KEY_USE_USER_ICON or KEY_DEFAULT_USER_ICON preference changes, the account needs to update its user icon. Added -[AIAccount effectiveStatusKeyForKey:] to make this and other substitutions, which are like setKeys:triggerChangeNotificationsForDependentKey:. Fixes #7778 (setting no icon actually did work, but only at connect time, not live)

Note: See TracTickets for help on using tickets.