Adium

Opened 12 years ago

Closed 12 years ago

#7747 closed enhancement (fixed)

Authorization requests pop up and get in the way while typing in chat window

Reported by: cheungpat Owned by: nobody
Milestone: Adium 1.2 Component: Adium UI
Version: Severity: normal
Keywords: authorization Cc:
Patch Status:

Description

What I observed is that the authorization request window pops up in the foreground and become focused whenever Adium is the active application. That is if the user is chatting and typing in the chat window, the authorization request window will get in the way and ask for response. If the user is typing the window will get the keystrokes and this causes unintended accept/deny of the request.

A possible enhancement can be to pop this window in the background and make the duck bounces on the dock.

Change History (6)

comment:1 Changed 12 years ago by Jordan

Resolution: invalid
Status: newclosed

You can use the "Contact Requests Authorization" event to manage this the way you like...

comment:2 in reply to:  1 Changed 12 years ago by Kwok-kuen Cheung

To reproduce the problem,

  1. Connect to an MSN account with Adium
  2. Go to Preferences > Events, add "Bounce the dock icon" action to the "Contact requests authorization" (as you said)
  3. Keep Adium in focus
  4. At another computer (so that Adium is still in focus), use another account to add this account as contact.
  5. The authorization pops up, and it catches the focus
  6. The dock icon doesn't bounce because Adium already has the attention.

My point is that, regardless of whether you have set any actions with the event, the authorization box pops up, and it catches the attention. If I am chatting in a chat box at the same time and if I type a space as the box pops up, I will be taken straight to the Add contact box, which is unintended.

Pidgin's implementation of this is to display an authorization panel at the bottom of the contact list, and it will not get in the way, especially when you are typing.

Replying to jas8522:

You can use the "Contact Requests Authorization" event to manage this the way you like...

comment:3 Changed 12 years ago by Jordan

Milestone: Adium X 1.3
Resolution: invalid
Status: closedreopened
Version: 1.1.11.1.2

Ahh yes, this is the same as the email event notification!

comment:4 Changed 12 years ago by Jordan

Milestone: Adium X 1.3zzzDuplicate tickets
Resolution: duplicate
Status: reopenedclosed

comment:5 Changed 12 years ago by Zachary West

Resolution: duplicate
Status: closedreopened

Fixed in [21565].

comment:6 Changed 12 years ago by Zachary West

Milestone: zzzDuplicate ticketsAdium X 1.2
Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.