Adium

Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#7744 closed defect (fixed)

Certain contacts behave as if they are blocked when they are not

Reported by: maddymoiselle Owned by: nobody
Milestone: Adium 1.2.4 Component: Service/Yahoo
Version: Severity: regression
Keywords: Cc:
Patch Status:

Description

I blocked one person on my list a few days ago and since then other users have been randomly blocked without my saying so. They do not show up as blocked until I have logged out and logged back in again. Until then, they are only shown as being offline.

Change History (36)

comment:1 Changed 13 years ago by Jordan

Milestone: Needs feedback from users
pending: 01

What service is this with? (ie: AIM, MSN, Gtalk... etc) Have you tried anything in TroubleshootingTips? Check out ReportingBugs for more details on how to format a bug report to give us as much info as possible to help you solve this problem.

comment:2 Changed 13 years ago by Peter Hosey

Component: Adium CoreYahoo

This seems to be a Yahoo! problem; #7798 specifies Yahoo!, as does a user on feedback.

comment:3 Changed 13 years ago by siavash Bahrieh

I have the exact problem with Yahoo on my Macbook since the latest update.

comment:1 Changed 13 years ago by trac-robot

pending: 10
Status: newclosed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

comment:2 Changed 13 years ago by Peter Hosey

Status: closedreopened

Oops. I forgot to uncheck Pending.

comment:3 Changed 13 years ago by Jordan

Milestone: Needs feedback from usersNeeds Feedback - Received

Refs: #8009, #7825

comment:4 Changed 12 years ago by mlaaker

Just tried on 1.2b5... still seeing the same problem (a fair number of my Yahoo! Messenger contacts are marked as 'blocked' in my Contacts List... unblocking them seems to work only temporarily... next time I login with 1.2b5, they remain blocked).

I'd posted my steps for duplication up on Bug 7825, but happy to document further here, if that would help. Thanks.

comment:5 Changed 12 years ago by Jordan

Milestone: Needs Feedback - ReceivedNeeds feedback from users
Version: 1.1.11.2b5

If you have access to a Windows or Linux install, try using Pidgin (latest version = 2.3.1) and see if the same things occur. If so then we have to wait for the Pidgin team to fix this problem.

comment:6 Changed 12 years ago by mlaaker

I installed Pidgin 2.3.1 on my Windows XP machine... sadly, no reproduction there. The Yahoo! Messenger users blocked in Adium aren't blocked in Pidgin (in fact, none of the folks in my buddy list were blocked).

comment:7 Changed 12 years ago by Jordan

mlaaker: you probably already tried this, but does a fresh set of preferences help? TroubleshootingTips describes how to do this if you are unfamiliar with the process. Hold on to your old set, since if it doesn't help anything then you'll want to restore it.

comment:8 Changed 12 years ago by mlaaker

I installed the beta on a brand new iMac (no previous Adium preferences), and saw the same pattern, unfortunately. In the past, I've also archived my Adium Application Suppot folder and preferences just to see if that worked, but no dice there either.

comment:9 Changed 12 years ago by Zachary West

Milestone: Needs feedback from usersAdium X 1.2.1

The blocking code sounds like it needs a looking-over in general.

comment:10 Changed 12 years ago by mlaaker

For what its worth, don't know if there's a connection, but I have nearly 500 Yahoo! IM contacts. (Everyone at work uses Y! IM.) I've noticed that alongside a 1/3 or so of my contacts being blocked, some just don't show up at all in the new Adium. Makes me wonder if there's a connection to the size of the Buddy List.

comment:11 Changed 12 years ago by Stanford Griffith

I just upgraded to the latest version. The problem is considerably worse now.

Now, the randomly blocked contacts don't show up at all. They are supposed to simply appear offline, but they don't.

The Privacy Preferences pane has changed completely, so my work around above cannot be done.

The contacts appear to have been deleted.

When I add them back, Adium pops up a bunch of messages asking me about a bunch of contacts. Then, it crashes.

This latest built is the worst yet as far as this issue goes.

I think I'm going to have to drop Adium as I need to have those contacts.

comment:12 Changed 12 years ago by Evan Schoenberg

Severity: normalregression

Privacy Preferences has not changed at all.

We need debug logs on this. Please download the CurrentAdiumDebug build and post a debug log to the ticket of signing on (and finding contacts 'randomly blocked').

comment:13 Changed 12 years ago by Stanford Griffith

I see what you mean, but...

The Privacy Settings have changed in that they now cause Adium to crash if you unblock the randomly blocked contacts.

Isn't this the ticket about randomly blocked contacts?

comment:14 Changed 12 years ago by Jordan

sagriffith: I suggest creating a new ticket with the crash log attached and post the new ticket # here.

comment:15 Changed 12 years ago by Levi

I've been having this blocking problem for quite some time now.

Once I accidentally blocked a friend of mine, and tried unblocking it. It actually did unblock, but the next time i fired up adium, he was blocked again. Now every time I run adium, i have to unblock my friend. Over and over again.

I tried tinkering with the privacy settings, switched it to "allow anyone" then back to "block certain contacts", and now it won't show up any blocked contacts at all. It's just the same as if it were "allow anyone". And the kicker is that people are still blocked. Ever since 1.2, i've had one more friend that got blocked, and i don't think i did it by mistake. He was just suddenly blocked, as if automatically by adium.

comment:16 Changed 12 years ago by Evan Schoenberg

Milestone: Adium X 1.2.1Adium X 1.2.2

comment:20 Changed 12 years ago by Levi

Now adium crashes every time i try changing the privacy settings (the block thing)

comment:21 Changed 12 years ago by Stanford Griffith

Levi, I think this ticket has been moved to here: http://trac.adiumx.com/ticket/8974.

comment:22 Changed 12 years ago by Evan Schoenberg

Milestone: Adium X 1.2.2Adium X 1.2.3

comment:23 Changed 12 years ago by Jordan

priority: normalhigh
Summary: Randomly blocked usersCertain contacts behave as if they are blocked when they are not

Ticket #8974 is regarding only the crashes then occur when attempting to remove such users from the contact list. This problem with the users being 'blocked' to begin with is still covered by this ticket. I think this should take a higher priority since it affects a fair number of users and appears to be Adium specific.

I think this is a better description.

comment:24 Changed 12 years ago by Stanford Griffith

My problem is also Adium specific. Please see my last post in #8974.

Thanks.

comment:25 Changed 12 years ago by Evan Schoenberg

Please try Adium_1.2.4svn20080301 and see if this fixes either of these issues.

comment:26 Changed 12 years ago by mlaaker

Just tried Adium_1.2.4svn20080301 and still have the same issue: a large number of my Yahoo! Messenger contacts who are friends/colleagues (i.e those who I normally communicate with, not folks I block) are marked as 'blocked' in my Contacts List... unblocking them seems to work only temporarily in the same session I'm in with that client... next time I login with Adium_1.2.4svn20080301, they remain blocked. When any of these folks do try to message me, the message doesn't come through, meaning that the block appears to be quite real for all intents and purposes.

comment:27 Changed 12 years ago by Evan Schoenberg

Could you email me the Adium Debug Log (adium menu) of connecting with just your Yahoo account and then messaging a falsely blocked contact, please?

comment:28 Changed 12 years ago by Levi

Same results as mlaaker. Didn't fix this particular problem.

Though... it seems to have made the file-transfer functional. o_O i can actually receive files from non-adium users.

comment:29 Changed 12 years ago by Evan Schoenberg

(In [22814]) Test build of libpurple which should fix the Yahoo privacy issue (Refs #7744); will commit upstream if effective.

comment:30 Changed 12 years ago by Evan Schoenberg

(In [22815]) merged [22814]: Test build of libpurple which should fix the Yahoo privacy issue (Refs #7744); will commit upstream if effective.

comment:31 Changed 12 years ago by Evan Schoenberg

Resolution: fixed
Status: reopenedclosed

Fix confirmed as good. Committed upstream in cce3a22f53972bd3834175b08ad5e7b800bf98e9 of im.pidgin.pidgin.

comment:32 in reply to:  1 Changed 12 years ago by Stanford Griffith

I cannot download the fix. The file name contains a comma instead of a period before the extension, but even after changing that, it refuses to mount.

I would like to try this fix for myself to see if it will fix the problem.

Thank you.

comment:33 Changed 12 years ago by Evan Schoenberg

http://adiumx.cachefly.net/Adium_1.2.4svn20080301.dmg works fine. Empty your cache and try again.

comment:34 Changed 12 years ago by Levi

As a continuation, the privacy settings crash still hasn't been fixed (ticket 8974), so i can't exactly testify to evands' statement that the problem is fixed. I think you guys should start working on 8974 to get this whole issue done and over with.

comment:35 Changed 12 years ago by Stanford Griffith

Levi, thanks for the swift reply.

That time I got it to work. I think the comma in the file name as part of the download (http://adiumx.cachefly.net/Adium_1.2.4svn20080301,dmg) was throwing the file off somehow.

As you said, Adium still crashes though.

But I appreciate your help.

comment:36 Changed 12 years ago by Levi

I've tried the update in 8974. It works! Thanks much. :)

Note: See TracTickets for help on using tickets.