Adium

Opened 9 years ago

Closed 3 years ago

Last modified 3 years ago

#7690 closed enhancement (fixed)

tabs should use all the space on the tab bar

Reported by: jchang Owned by: wixardy
Milestone: Adium 1.5.10 Component: Adium UI
Version: 1.1.1 Severity: normal
Keywords: PSMTabBarControl Cc:
Patch Status:

Description

There is a small space on the right side of the tabbar that should be utilized when the tabs have not yet overflowed.

Attachments (1)

tabbar.png (2.5 KB) - added by jchang 9 years ago.
image of the tab bar

Download all attachments as: .zip

Change History (15)

Changed 9 years ago by jchang

image of the tab bar

comment:1 Changed 9 years ago by evands

  • Milestone set to Adium X 1.2

comment:2 Changed 9 years ago by evands

  • Milestone changed from Adium X 1.2 to Good idea for "later"

If someone would like to tackle this, please feel free; it's nontrivial so far as I can tell and I won't be tackling this tab problem any time soon.

comment:3 Changed 9 years ago by evands

The problem is that rightMarginForTabBarControl returns 24.0f to allow space for the overflow chevron - space needed only if the tabs will be overflowing.

comment:4 Changed 9 years ago by evands

  • Milestone changed from Good idea for "later" to Patches welcome

Note that the code to change would be in PSMTabBarControl, found at http://code.google.com/p/maccode/

comment:5 Changed 9 years ago by djmori

comment:6 Changed 8 years ago by Robby

  • Milestone changed from Patches welcome to Good idea for "later"

comment:7 Changed 6 years ago by Robby

  • Owner nobody deleted

comment:8 Changed 4 years ago by paulwilde

  • Resolution set to fixed
  • Status changed from new to closed

This seems fixed in 1.6, for me.

http://cl.ly/OtB3

comment:9 Changed 4 years ago by paulwilde

  • Milestone changed from Good ideas for later to Adium 1.6

comment:10 Changed 4 years ago by Robby

  • Keywords PSMTabBarControl added

comment:11 Changed 3 years ago by Robby

  • Resolution fixed deleted
  • Status changed from closed to new

Reopening for attribution

comment:12 Changed 3 years ago by Robby

  • Owner set to wixardy

comment:13 Changed 3 years ago by Robby

  • Resolution set to fixed
  • Status changed from new to closed

comment:14 Changed 3 years ago by Robby

  • Milestone changed from Adium 1.6 to Adium 1.5.10
Note: See TracTickets for help on using tickets.