Adium

Opened 12 years ago

Closed 12 years ago

#7685 closed defect (fixed)

Sametime server not saved in preferences after completing first-time wizard

Reported by: jsquyres Owned by: nobody
Milestone: Adium 1.2 Component: Adium Core
Version: Severity: normal
Keywords: Cc:
Patch Status:

Description

I was initially reporting a bug that in v1.1.1, the ST auto-connect did not work. I.e., my ST account would not auto-connect

  • When restoring my MBP from sleep/opening the lid
  • When launching Adium

AIM auto-connects just fine (but ST does not). 1.0.x did not exhibit this behavior -- ST auto-connected just fine.

I was collecting debug information about this to report, and was following the instructions on Preferences to test with a new set of preferences when I noticed that the ST server was not listed in the ST account preferences pane. Specifically:

  1. Follow the instructions on Preferences to rename my old preferences
  2. Re-launch Adium 1.1.1 (and 1.1b5, per ticket #7577 -- results are the same)
  3. Have it ask me to add an account, since my old prefs are gone.
  4. Add my samtime account. The initial window does not ask for a ST server, so a supplemental window pops up asking for the ST server. I fill it in.
  5. Adium connects to my ST server and all is good.
  6. Quit Adium.
  7. Re-launch Adium. ST does not auto-reconnect.
  8. Going to the Adium menu bar pulldown and selecting "Available" forces Adium to reconnect to ST, and all is well.
  9. Looking at Preferences in Adium, I pull up the Accounts pane and double click on my ST account. The ST server field is blank (!). I fill in the ST server and exit preferences.
  10. Exit Adium.
  11. Re-launch Adium.
  12. Adium now auto-connects to ST properly.

Did the location of the ST server storage get changed from 1.0.x to 1.1.x somehow, such that the preferences / auto-connect functionality can no longer find it by default, perchance?

Could this be related to #7577?

Change History (4)

comment:1 Changed 12 years ago by Evan Schoenberg

The preferences location didn't change... the server field being specified is indeed needed for autoconnect to work. It's -also- needed for connect to work, unless I'm misunderstanding the information you're putting in, so I'm mystified as to how it's connecting at all with a blank server.

I don't think this is related to #7577; the server information is not accessed when joining a group chat (assuming you're currently connected... and if you're not, the option is disabled).

comment:2 Changed 12 years ago by Jordan

Component: SametimeAdium Core
Milestone: Adium X 1.2
Summary: Sametime server disappeared from preferencesSametime server not saved in preferences after completing first-time wizard

I think there are two problems presented here, of which the first one was solved by re-adding the account:

What Happened to jsquyres here

  1. He couldn't connect after the upgrade - he thought this was due to the problem he found in #2, but I don't think that is the case. This appears to be solved by creating a new set of prefs / re-adding the ST account.
  2. Once he set up a fresh set of preferences and opened Adium which presented the Add new account Wizard, he proceeded to add his ST account. The server field in preferences was not saved in even though he had entered it when asked upon creation. Entering it in a second time by manually entering the preferences for it seems to have worked for him.

As Evan said, #7577 implies that the user is already connected, so this cannot be related.

Confirmation of the bug He is right about #2 - I just copied out my prefs, and allowed Adium to create a fresh set. When it came up with the wizard to add a new account that you get on first start, adding a ST account (though mine was fake since I don't have one) prompts you for a username/password. When you click continue it pops up a dialog asking for the server hostname or IP which I entered in. It then seems to try to connect but fails (which would happen anyway for me because I have no real ST server to connect to). When I check in preferences, the server field is blank - so the host I entered in the wizard did not get saved.

comment:3 Changed 12 years ago by Evan Schoenberg

The 'enter sametime community server' prompt originates from libpurple and is only for the current session. We should instead display our own prompt so we can save the result to our preferences.

jsquyres: Does the prompt need a port field, as well, or is assuming the default port the better behavior?

comment:4 Changed 12 years ago by Evan Schoenberg

Resolution: fixed
Status: newclosed

(In [20873]) If no server is specified for an account which needs one, prompt for one and save the resulting server for future use. Fixes #7685

Note: See TracTickets for help on using tickets.