Adium

Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#7542 closed defect (fixed)

"Check For Updates..." systematically crashes adium

Reported by: mij Owned by: nobody
Milestone: Adium X 1.0.6 Component: Adium Core
Version: Severity: major
Keywords: check updates sparkle sparkleplus crash Cc:
Patch Status:

Description (last modified by Peter Hosey)

Since Adium 1.1, 90% of the times you use "Check for Updates..." from the Adium menu makes Adium crash with a Segmentation fault.

This is the output from console:

CMSCreateDataProviderOrGetInfo : Invalid colorspace type
CMSCreateDataProviderOrGetInfo : Invalid colorspace type
CMSCreateDataProviderOrGetInfo : Invalid colorspace type
[now clicking "Check For Updates..."]
Segmentation fault

Attachments (4)

adium11checkupdatescrash.txt (21.2 KB) - added by Mij 13 years ago.
crash dump
Adium.crash.log (41.6 KB) - added by Kristine Gregorowicz 13 years ago.
Adium Crash Log from Today.
20070813_adiumx_1.0.5_crashlog_when_updating.txt (21.7 KB) - added by HJ 13 years ago.
Crashlog on MacBook Pro / Tiger 10.4.10
adium_crash.txt (21.6 KB) - added by Dan Gaul 13 years ago.
adding my crash log from 7543

Download all attachments as: .zip

Change History (19)

Changed 13 years ago by Mij

crash dump

comment:1 Changed 13 years ago by David Smith

Milestone: Adium X 1.1.1

That's bizarre...

comment:2 Changed 13 years ago by Evan Schoenberg

Is this reproducable on other machines? We should push a fix for this ASAP if it's happening on automatic version checks, in particular, or we'll have a bunch of people locked into 1.1.

comment:3 Changed 13 years ago by David Smith

We've gotten a *ton* of reports on irc

comment:4 Changed 13 years ago by Zachary West

#7543 for a ton of info.

comment:5 Changed 13 years ago by Evan Schoenberg

What do you think about updating adiumx.com/changelogs/1.1.html to have big red blinking text not to upgrade if using 10.3 and then removing the minimum system requirement stuff from the appcast? It seems really really likely that it's the culprit.

comment:6 Changed 13 years ago by Zachary West

What's strange is, it's not a 100% crash on check for me. It only crashes ~1/3 of the time. Otherwise it says it had an error checking (?) or I'm up to date.

As a temporary fix, definitely. If everybody is crashing as often as I am... oi.

comment:7 Changed 13 years ago by Kristine Gregorowicz

This happens to me on multiple machines every time I launch Adium 1.0.5. I thought it was just a settings issue at first, but then I came home and it happened on my PowerBook G4. My other machine is a PPC Mac Mini. I'm attaching the crash log.

Changed 13 years ago by Kristine Gregorowicz

Attachment: Adium.crash.log added

Adium Crash Log from Today.

comment:8 Changed 13 years ago by HJ

Consistent crashes for me except when I had myself marked as "Available." If I used Away, Invisible, etc., I would see the pop-up indicating it was trying to contact the update server, then... *boom*. This is AdiumX 1.0.5 on a MacBook Pro, 10.4.10. On the off chance that it might yield some additional (non-redundant) info, I'm attaching a crash log as well.

Resolution for me: set to Available, update normally; 1.1 runs fine (no crashes so far, unlike what others have reported).

Changed 13 years ago by HJ

Crashlog on MacBook Pro / Tiger 10.4.10

Changed 13 years ago by Dan Gaul

Attachment: adium_crash.txt added

adding my crash log from 7543

comment:9 Changed 13 years ago by Dan Gaul

I added my crash log. On MacPro with 10.4.10. Crash happens upon every start of Adium. The contact list begins to load and then the crash happens.

I'm running 1.1. I tried re-install but it did not fix the issue.

comment:10 Changed 13 years ago by mfazekas

I've built a debug version of adium with a debug version of SparklePlus and i was able to repeat the crash 100% (even under debugger).

Then i've stepped through the code in SparklePlus, and it didn't crash.

Now i'm unable to reproduce the crash - nor with debug/release version. So it might be some settings related bug.

comment:11 in reply to:  2 Changed 13 years ago by Mij

Replying to evands:

Is this reproducable on other machines? We should push a fix for this ASAP if it's happening on automatic version checks, in particular, or we'll have a bunch of people locked into 1.1.

I can confirm I get this behavior with nearly the same frequency on these machines:

  • Intel MBP (2.16GHz second release) with OS X 10.4.10
  • Intel MBP (Santa Rosa) with OS X 10.4.10
  • PowerPC iMag G5 with OS X 10.4.10

comment:12 Changed 13 years ago by Peter Hosey

Description: modified (diff)
Severity: normalblocker

This bug is in 1.0.5 and 1.1, and was revealed by my fix to the appcast this morning.

The bug is simple: One of the piece of data from the appcast wasn't being retained, so when Sparkle Plus tried to use it again later, it was a dead object, which caused a crash.

This bug is only in Sparkle Plus. It was fixed five months ago in Sparkle, but somehow, the fix never made it to Sparkle Plus, which is how it never made it to Adium.

We're still working on exactly how we should roll out the fix, but we do think we've found and fixed the problem. I'm updating the description accordingly, to hopefully stem the flow of confirmations. Thanks to all the users who've helped out with this.

comment:13 Changed 13 years ago by Peter Hosey

Description: modified (diff)
Keywords: sparkle sparkleplus added

s/h3/h2/

comment:14 Changed 13 years ago by Peter Hosey

Milestone: Adium X 1.1.1Adium X 1.0.6
Resolution: fixed
Status: newclosed

Fixed by r20578 and r20585 for 1.0.6, and r20577 and r20585 for 1.1.1.

comment:15 Changed 13 years ago by Peter Hosey

Description: modified (diff)

Removed “We don't need crash logs now” message. If you get this same crash with 1.0.6 or 1.1.1, please do attach the crash log.

Note: See TracTickets for help on using tickets.