Adium

Opened 12 years ago

Closed 11 years ago

#7508 closed enhancement (fixed)

Please make %userIconPath% valid in status.html

Reported by: mathuaerknedam Owned by: Catfish_Man
Milestone: Adium 1.4 Component: Message View
Version: 1.2svn Severity: minor
Keywords: Cc:
Patch Status:

Description

From IRC:

[14:31] mathuaerknedam: How difficult would it be to make %userIconPath% valid in status.html?
[14:32] Catfish_Man: hmm
[14:33] mathuaerknedam: I think it would fix my problem with adjusting status messages when I adjust other messages when "show user icon" is toggled.
[14:33] Catfish_Man: the issue is that not all status messages have an associated user
[14:33] mathuaerknedam: True.
[14:33] mathuaerknedam: but wouldn't that only be a problem if messagestyle authors use it indiscriminately?
[14:33] Catfish_Man: well, what would it do when there was no user?
[14:33] Catfish_Man: just give an empty string?
[14:34] mathuaerknedam: we should be able to use %status% to determine when to use it.
[14:34] Catfish_Man: hm
[14:34] Catfish_Man: interesting point
[14:34] Catfish_Man: I'll think about it

Change History (9)

comment:1 Changed 12 years ago by Catfish_Man

  • Owner set to Catfish_Man
  • Status changed from new to assigned
  • Summary changed from Pleaser make %userIconPath% valid in status.html to Please make %userIconPath% valid in status.html

comment:2 Changed 12 years ago by mathuaerknedam

I read through the IRC conversation again, and realized that I was potentially unclear in my suggestion on the use of %status% to determine the appropriateness of using %userIconPath% in status messages. Because I intend to use this in a non-standard way, I'd like it to be left up to the messagestyle author to use it correctly. My use is dependent on being able to have the "show user icons" checkbox apply to all status messages.

comment:3 Changed 11 years ago by Robby

  • Milestone set to Good idea for "later"

comment:4 Changed 11 years ago by catfish_man

(In [26662]) Tentative fix for #7508. aerk, please let me know if this works. Refs #7508

comment:5 Changed 11 years ago by Catfish_Man

  • Milestone changed from Good idea for "later" to Adium 1.4
  • Resolution set to fixed
  • Status changed from assigned to closed

comment:6 Changed 11 years ago by mathuaerknedam

  • Resolution fixed deleted
  • Status changed from closed to reopened

I thought (and previously reported in IRC) that this was working great. However, I failed to notice that it doesn't work for twitter. It works fine for AIM, Yahoo!, Jabber, Gtalk, and IRC. As I understand it, twitter and bonjour are the only two protocols not handled by libpurple; I suspect bonjour would have the same problem, but I never have anyone in bonjour range for testing.

The problem I'm seeing in all Twitter status/event messages %userIconPath% will be replaced with Incoming/buddy_icon.png, regardless of the state of the "show user icons" checkbox. For all the other protocols I've tested the replacement happens only when the checkbox is deselected.

comment:7 Changed 11 years ago by zacw

  • Severity changed from normal to minor

comment:8 Changed 11 years ago by zacw

Twitter's status messages have no source, so that's probably the correct behavior.

comment:9 Changed 11 years ago by zacw

  • Resolution set to fixed
  • Status changed from new to closed

Yeah, this is probably why. None of the status messages in twitter have a source, and you might find this to be the case for messages in IRC and a few other protocols when there's no source from a message.

Note: See TracTickets for help on using tickets.